Version 0.14.10

Information about releases and roadmap.
User avatar
FactorioBot
Factorio Staff
Factorio Staff
Posts: 338
Joined: Tue May 12, 2015 1:48 pm

Version 0.14.10

Post by FactorioBot »

  • Changes
    • Disabled multiplayer support in the 32 bit version of the game.
    • Multiplayer map downloading GUI shows average over the last 2 seconds instead of 20 seconds.
  • Bugfixes
    • Potential fix of the crash after desync.
    • Fixed desync related to electric network statistics of accumulators.
    • Fixed assertion fail in tightspot level-05 (29724)
    • Removed 2 redundant research prerequisites. (33097)
    • Fixed non even selection boxes of locomotive versus cargo wagon. (33078)
    • Fixed that Factorio would crash when unable to delete a mod. (33228)
    • Fixed that the chart would display user's names from other surfaces. (33226)
    • Fixed blueprint tiles alignment inside preview/editor. (28250)
    • Fixed player limit disallowing connection attempt in public server list. (33377)
    • Fixed mod browser filters and ordering being lost. (33277)
    • Fixed freshly installed mods not being marked in the mod browser. (33277)
    • Fixed signals sometimes not finding their child signals properly. (33148)
    • Fixed up/down keys in schedule gui were not selecting properly. (33227)
    • Additional keys ignored when the console is opened. (33411)
    • Fixed that aliens would ignore very narrow paths they could barely fit through. (33069)
    • Fixed that numbers were sometimes rounded differently on 32 bit systems in lua.
    • Fixed that the game would freeze when game.speed was set to a value less than 0.2. (33317)
    • Fixed cargo wagon air resistance being smaller than that of the locomotive.
    • Fixed of loading "require_user_verification" from server-settings (It was called verify_user_identity at one place and require_user_verification at other).
    • Fixed underground belt fast replace when replacing the same belt multiple times. (33019)
    • Fixed rendering of turret range when construction network area overlay is also being drawn. (33057)
    • Temporary decrease of decorative entities counts.
    • Fixed server max upload speed.
    • Fixed that Factorio wouldn't give an error when --start-server-load-scenario was combined with --start-server or --start-server-load-latest. (33055)
    • Fixed beam would apply one extra damage tick. (32973)
Use the automatic updater if you can (check experimental updates in other settings) or download full installation at http://www.factorio.com/download/experimental.

User avatar
Mooncat
Smart Inserter
Smart Inserter
Posts: 1183
Joined: Wed May 18, 2016 4:55 pm
Contact:

Re: Version 0.14.10

Post by Mooncat »

So many bug fixes. :o
Thanks for the update. :D
I want to play more Factorio. I want to mod more Factorio.
But life sucks. So many things I need to do. So many things I want to do. So little time.

KrzysD
Long Handed Inserter
Long Handed Inserter
Posts: 60
Joined: Mon Oct 27, 2014 6:49 pm
Contact:

Re: Version 0.14.10

Post by KrzysD »

still waiting on a fix for viewtopic.php?f=182&t=32733

Ratzap
Filter Inserter
Filter Inserter
Posts: 371
Joined: Sun Aug 16, 2015 11:15 pm
Contact:

Re: Version 0.14.10

Post by Ratzap »

FactorioBot wrote:
  • Fixed of loading "require_user_verification" from server-settings (It was called verify_user_identity at one place and require_user_verification at other).
Which one is now correct then? Or will either work?

I've updated my server and it won't start back up. Can't see much else in the list that might be stopping it.

kovarex
Factorio Staff
Factorio Staff
Posts: 8052
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: Version 0.14.10

Post by kovarex »

Ratzap wrote:
FactorioBot wrote:
  • Fixed of loading "require_user_verification" from server-settings (It was called verify_user_identity at one place and require_user_verification at other).
Which one is now correct then? Or will either work?

I've updated my server and it won't start back up. Can't see much else in the list that might be stopping it.
require_user_verification is to be used.
What do you mean by can't start back up?

Baughn
Long Handed Inserter
Long Handed Inserter
Posts: 82
Joined: Wed Jan 20, 2016 4:44 pm
Contact:

Re: Version 0.14.10

Post by Baughn »

[*] Fixed that Factorio wouldn't give an error when --start-server-load-scenario was combined with --start-server or --start-server-load-latest. (33055)

I think you got a bit overzealous, there. New bug time!

Code: Select all

$ /nix/store/pgfys3md3z31dklrpypx0ckwks16fjw2-factorio-headless-0.14.10/bin/.factorio-wrapped -c $HOME/.factorio/config.cfg --start-server terracognito.zip --mod-directory 0.14/mods --autosave-interval 10 --autosave-slots 6 --server-settings server-settings.json

start-server can't be used together with start-server

KurioHonoo
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sun Jul 10, 2016 2:37 am
Contact:

Re: Version 0.14.10

Post by KurioHonoo »

I am getting this issue anytime I try to full screen now. http://imgur.com/a/8tXzl

hmage
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed Sep 28, 2016 7:35 pm
Contact:

Re: Version 0.14.10

Post by hmage »

Having same problems with create-server

https://asciinema.org/a/0cw447hc9sl0wdst4w72jtct5

Ratzap
Filter Inserter
Filter Inserter
Posts: 371
Joined: Sun Aug 16, 2015 11:15 pm
Contact:

Re: Version 0.14.10

Post by Ratzap »

kovarex wrote:
Ratzap wrote:
FactorioBot wrote:
  • Fixed of loading "require_user_verification" from server-settings (It was called verify_user_identity at one place and require_user_verification at other).
Which one is now correct then? Or will either work?

I've updated my server and it won't start back up. Can't see much else in the list that might be stopping it.
require_user_verification is to be used.
What do you mean by can't start back up?
Probably what that guy is getting but I'm on a rented host and I get diddly squat for logs :(

rfvgyhn
Burner Inserter
Burner Inserter
Posts: 18
Joined: Fri Apr 22, 2016 5:14 pm
Contact:

Re: Version 0.14.10

Post by rfvgyhn »

Just want to mention that server-settings.example.json still uses `verify_user_identity` (at least in the steam version).

User avatar
DofD
Inserter
Inserter
Posts: 21
Joined: Thu Jun 18, 2015 10:16 am
Contact:

Re: Version 0.14.10

Post by DofD »

Baughn wrote:[*] Fixed that Factorio wouldn't give an error when --start-server-load-scenario was combined with --start-server or --start-server-load-latest. (33055)

I think you got a bit overzealous, there. New bug time!

Code: Select all

$ /nix/store/pgfys3md3z31dklrpypx0ckwks16fjw2-factorio-headless-0.14.10/bin/.factorio-wrapped -c $HOME/.factorio/config.cfg --start-server terracognito.zip --mod-directory 0.14/mods --autosave-interval 10 --autosave-slots 6 --server-settings server-settings.json

start-server can't be used together with start-server
Can confirm this
Image
Image

User avatar
spunkybd
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed Sep 28, 2016 8:14 pm
Contact:

Re: Version 0.14.10

Post by spunkybd »

DofD wrote:
Baughn wrote:[*] Fixed that Factorio wouldn't give an error when --start-server-load-scenario was combined with --start-server or --start-server-load-latest. (33055)

I think you got a bit overzealous, there. New bug time!

Code: Select all

$ /nix/store/pgfys3md3z31dklrpypx0ckwks16fjw2-factorio-headless-0.14.10/bin/.factorio-wrapped -c $HOME/.factorio/config.cfg --start-server terracognito.zip --mod-directory 0.14/mods --autosave-interval 10 --autosave-slots 6 --server-settings server-settings.json

start-server can't be used together with start-server
Can confirm this
Image
Image

Can confirm. Same issue, had to revert to .9.

keyboardhack
Filter Inserter
Filter Inserter
Posts: 478
Joined: Sat Aug 23, 2014 11:43 pm
Contact:

Re: Version 0.14.10

Post by keyboardhack »

FactorioBot wrote: [*]Changes
  • Disabled multiplayer support in the 32 bit version of the game.
If this is true then you will have to do something about the tags added to Factorio is steam and probably other stores as well. With this change the game isn't a multi-player, online multi-player, local multi-player, Co-op, online Co-op with the 32 bit version that some people can only play with. Some clarification of this is probably required to not receive angry costumers.
Waste of bytes : P

User avatar
aubergine18
Smart Inserter
Smart Inserter
Posts: 1264
Joined: Fri Jul 22, 2016 8:51 pm
Contact:

Re: Version 0.14.10

Post by aubergine18 »

Fixed that numbers were sometimes rounded differently on 32 bit systems in lua.
Does this mean it's now safe to use `string.format( "%f" )`?
Better forum search for modders: Enclose your search term in quotes, eg. "font_color" or "custom-input" - it prevents the forum search from splitting on hypens and underscores, resulting in much more accurate results.

User avatar
binbinhfr
Smart Inserter
Smart Inserter
Posts: 1524
Joined: Sat Feb 27, 2016 7:37 pm
Contact:

Re: Version 0.14.10

Post by binbinhfr »

cannot download it here ?
https://www.factorio.com/download/experimental

EDIT : Internal server error
My mods on the Factorio Mod Portal :geek:

Oarc
Fast Inserter
Fast Inserter
Posts: 100
Joined: Sun Sep 18, 2016 2:04 pm
Contact:

Re: Version 0.14.10

Post by Oarc »

Could you explain what exactly this did? I'm very interested.
Fixed server max upload speed
I also would like to know what exactly it does.
Does it limit max upload speed for ALL game data or just map uploading?

Much thanks!
Oarc

floodo1
Inserter
Inserter
Posts: 21
Joined: Tue Jun 28, 2016 2:33 am
Contact:

Re: Version 0.14.10

Post by floodo1 »

anyone else having issues trying to use the game/server browser? I get "Couldn't reach the auth server" after I hit the 'Browser Public Games" in the menu and am prompted for my username/pass. (Steam version, win64 in the About dialog).

after reverting back to 0.14.9 and game/server browser works just fine.

User avatar
impetus maximus
Smart Inserter
Smart Inserter
Posts: 1299
Joined: Sat Aug 20, 2016 10:07 pm
Contact:

Re: Version 0.14.10

Post by impetus maximus »

Oarc wrote:Could you explain what exactly this did? I'm very interested.
Fixed server max upload speed
I also would like to know what exactly it does.
Does it limit max upload speed for ALL game data or just map uploading?

Much thanks!
Oarc
not sure why they didn't link to it. the map upload limit for headless would work then wouldn't.
"max_upload_in_kilobytes_per_second": 0,

it's still
"verify_user_identity": true,

for those that update in-game (saves factorio.com bandwidth) here is the updated server-settings.json file
Last edited by impetus maximus on Wed Sep 28, 2016 10:47 pm, edited 1 time in total.

Oarc
Fast Inserter
Fast Inserter
Posts: 100
Joined: Sun Sep 18, 2016 2:04 pm
Contact:

Re: Version 0.14.10

Post by Oarc »

impetus maximus wrote:
Oarc wrote:Could you explain what exactly this did? I'm very interested.
Fixed server max upload speed
I also would like to know what exactly it does.
Does it limit max upload speed for ALL game data or just map uploading?

Much thanks!
Oarc
not sure why they didn't link to it. the map upload limit for headless would work then wouldn't.
"max_upload_in_kilobytes_per_second": 0,

it's still
"verify_user_identity": true,

for those that update in-game (saves factorio.com bandwidth) here is the updated server-settings.json file

Do you know if "max_upload_in_kilobytes_per_second" applies to all traffic equally? Or specifically for map upload?
Does it apply to all players at once, or per player?

User avatar
impetus maximus
Smart Inserter
Smart Inserter
Posts: 1299
Joined: Sat Aug 20, 2016 10:07 pm
Contact:

Re: Version 0.14.10

Post by impetus maximus »

i think it's the total upload used for map upload. meaning if you limit it to 100kB and 2 users are downloading they will share the 100kB.

i too am getting [Win64]
"start-server can't be used together with start-server"

Code: Select all

factorio.exe --start-server saves/4.zip --allow-commands admins-only --autosave-interval 15 --autosave-slots 4 -c "c:\Program Files\Factorio_0.14.10\config\server-config.ini" --server-settings server-settings.json

Post Reply

Return to “Releases”