Version 0.17.66

Information about releases and roadmap.
Post Reply
User avatar
FactorioBot
Factorio Staff
Factorio Staff
Posts: 239
Joined: Tue May 12, 2015 1:48 pm

Version 0.17.66

Post by FactorioBot » Fri Aug 16, 2019 1:37 pm

Changes
  • Blocked underground pipe connections (see e.g. 73840) are always highlighted.
Bugfixes
  • Fixed crash when using the close button while the client is saving the map for desync report. (74508)
  • Fixed a crash related to settings copy/paste of some modded assemblers. (74025)
  • Correctly highlighting blocked connections of modded underground pipes. (74116)
  • Fixed a case of disappearing fluid in a special fluid furnace configuration. (74373)
  • Fixed programmable speaker caused crash when using --disable-audio command line option. (74551)
  • Fixed that an underground pipe ghost did not split fluid systems. (74252)
  • Fixed that an underground pipe ghost did not split blocked connection. (74269)
  • Fixed that fluids in assembling machines and furnaces would get voided any time mods changed. (74284)
  • Prevented construction of underground pipe that could crash the game due to blocked pipe connection. (74116)
Scripting
  • Added LuaEntityPrototype::terrain_friction_modifier read.
Use the automatic updater if you can (check experimental updates in other settings) or download full installation at http://www.factorio.com/download/experimental.

User avatar
SuperSandro2000
Filter Inserter
Filter Inserter
Posts: 693
Joined: Sun Jan 12, 2014 3:54 am
Contact:

Re: Version 0.17.66

Post by SuperSandro2000 » Fri Aug 16, 2019 1:38 pm

I just watched a video about Route 66. Is this a sign?
Btw is this considered to be the stable candidate?

And the release in binary: 0.10001.1000010

Xgkkp
Burner Inserter
Burner Inserter
Posts: 10
Joined: Wed Jul 27, 2016 12:58 am
Contact:

Re: Version 0.17.66

Post by Xgkkp » Fri Aug 16, 2019 7:30 pm

This is the first 0.17 I've played. I know the GUI has gone through a lot of changes; consider this a single data-point personal feedback based on what I find intuitive; I'm sure you've heard all this before but I couldn't see an obvious thread about the GUI/usability.

Probably all this is just because I knew what it was before!
  • I got lost going forwards creating new game because I missed the giant green "play" button - it didn't look like a button/the other buttons. (Edit: I think it's just that it's really long so looks like a 'bar' - the "Save" button is the same colour but had no problem)
  • The reduced-tree research screen baffled me, I thought all I could research now at the start was "automation" then wanted splitters but could only research "electronics" then realised what I wanted logistics and couldn't find it anywhere. Trimming stuff downwards is great and the arrows made that intuitive, but the tree is the main volume of the window and trimming upwards without any visual indicator made me think the default displayed node was the only one. I eventually realised that apparently I can only select what I want from the "list of techs" and that despite the trees overlapping you can never seem to show the roots together. This took me a minute or two on the third time opening the screen, and I knew what I was looking for. I've used tech trees since Civ2, and I miss being able to see the whole tree, or at least browse back to the root. Even clicking up/down on the tree for a while made it appear random which techs were shown above. Assuming this is by design and not a this-version bug.
  • I couldn't work out how to update mods. I swear it used to have a "you must restart to apply changes" popup. I went to update, clicked "update" and all the entries disappeared from the list, but all the mods in the mod list still said out of date. It took me giving up, starting a game, going out then in again before I realised that I needed to click the giant green button _after_ clicking
  • Is there any reason the "Toggle alt-mode" couldn't just be labelled "show building contents" or something; I knew Alt by muscle memory and that new highly visible button confused me.....
Last edited by Xgkkp on Fri Aug 16, 2019 11:48 pm, edited 1 time in total.

generi
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Mar 02, 2019 8:01 am
Contact:

Re: Version 0.17.66

Post by generi » Fri Aug 16, 2019 8:20 pm

There was no twitter post about this version. Actually the last few... Is something not working or did you just stop informing on twitter about new versions?

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 311
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: Version 0.17.66

Post by RocketManChronicles » Mon Aug 19, 2019 11:10 am

Xgkkp wrote:
Fri Aug 16, 2019 7:30 pm
This is the first 0.17 I've played. I know the GUI has gone through a lot of changes; consider this a single data-point personal feedback based on what I find intuitive; I'm sure you've heard all this before but I couldn't see an obvious thread about the GUI/usability.

Probably all this is just because I knew what it was before!
  • I got lost going forwards creating new game because I missed the giant green "play" button - it didn't look like a button/the other buttons. (Edit: I think it's just that it's really long so looks like a 'bar' - the "Save" button is the same colour but had no problem)
  • The reduced-tree research screen baffled me, I thought all I could research now at the start was "automation" then wanted splitters but could only research "electronics" then realised what I wanted logistics and couldn't find it anywhere. Trimming stuff downwards is great and the arrows made that intuitive, but the tree is the main volume of the window and trimming upwards without any visual indicator made me think the default displayed node was the only one. I eventually realised that apparently I can only select what I want from the "list of techs" and that despite the trees overlapping you can never seem to show the roots together. This took me a minute or two on the third time opening the screen, and I knew what I was looking for. I've used tech trees since Civ2, and I miss being able to see the whole tree, or at least browse back to the root. Even clicking up/down on the tree for a while made it appear random which techs were shown above. Assuming this is by design and not a this-version bug.
  • I couldn't work out how to update mods. I swear it used to have a "you must restart to apply changes" popup. I went to update, clicked "update" and all the entries disappeared from the list, but all the mods in the mod list still said out of date. It took me giving up, starting a game, going out then in again before I realised that I needed to click the giant green button _after_ clicking
  • Is there any reason the "Toggle alt-mode" couldn't just be labelled "show building contents" or something; I knew Alt by muscle memory and that new highly visible button confused me.....
The 0.17 GUI takes a little to adjust to from earlier versions. But after a short while you will get the hang of it. After 6 months, it feels very intuitive to use and flows much better than older versions.

User avatar
jockeril
Filter Inserter
Filter Inserter
Posts: 327
Joined: Sun Feb 08, 2015 11:04 am
Contact:

Re: Version 0.17.66

Post by jockeril » Wed Aug 21, 2019 8:06 am

RocketManChronicles wrote:
Mon Aug 19, 2019 11:10 am
Xgkkp wrote:
Fri Aug 16, 2019 7:30 pm
This is the first 0.17 I've played. I know the GUI has gone through a lot of changes; consider this a single data-point personal feedback based on what I find intuitive; I'm sure you've heard all this before but I couldn't see an obvious thread about the GUI/usability.

Probably all this is just because I knew what it was before!
  • I got lost going forwards creating new game because I missed the giant green "play" button - it didn't look like a button/the other buttons. (Edit: I think it's just that it's really long so looks like a 'bar' - the "Save" button is the same colour but had no problem)
  • The reduced-tree research screen baffled me, I thought all I could research now at the start was "automation" then wanted splitters but could only research "electronics" then realised what I wanted logistics and couldn't find it anywhere. Trimming stuff downwards is great and the arrows made that intuitive, but the tree is the main volume of the window and trimming upwards without any visual indicator made me think the default displayed node was the only one. I eventually realised that apparently I can only select what I want from the "list of techs" and that despite the trees overlapping you can never seem to show the roots together. This took me a minute or two on the third time opening the screen, and I knew what I was looking for. I've used tech trees since Civ2, and I miss being able to see the whole tree, or at least browse back to the root. Even clicking up/down on the tree for a while made it appear random which techs were shown above. Assuming this is by design and not a this-version bug.
  • I couldn't work out how to update mods. I swear it used to have a "you must restart to apply changes" popup. I went to update, clicked "update" and all the entries disappeared from the list, but all the mods in the mod list still said out of date. It took me giving up, starting a game, going out then in again before I realised that I needed to click the giant green button _after_ clicking
  • Is there any reason the "Toggle alt-mode" couldn't just be labelled "show building contents" or something; I knew Alt by muscle memory and that new highly visible button confused me.....
The 0.17 GUI takes a little to adjust to from earlier versions. But after a short while you will get the hang of it. After 6 months, it feels very intuitive to use and flows much better than older versions.
But those are still very legitimate beginner remarks - I'd suggest wube make some first time onscreen tips that explain where to find buttons/ next steps like in professional apps you install on the phone and some games also do that - they put a bubble with a pointer to the button with an explanation of is function and a "next" button in it, then it moves to the next button/ or area of the screen to explain that,

I will try to make an example mockup when I have time today, using this user's remarks :geek:
[request] RTL support please

Hebrew Translator for FARL & EvoGUI and much more

join me on
- Twitter[@jockeril],
- Twitch.tv/jockeril,
- Youtube/jocker-il (or JoCKeR-iL)
- and steam !
Image

funky.bibimbap
Burner Inserter
Burner Inserter
Posts: 10
Joined: Sun Sep 16, 2018 9:29 am
Contact:

Re: Version 0.17.66

Post by funky.bibimbap » Wed Aug 21, 2019 2:12 pm

When it comes to the GUI, my biggest problem is to find the button to synchronise the mods with the save that I want to load. I didn't know about its existence in 0.16 (I thought people used parallel installations of factorio for different mod sets :roll:), and never noticed its existence. I discovered it by accident in 0.17 since the interface was new and I was actually paying attention to all the buttons, but still I find it in a non-intuitive place.

In terms of workflow, I wish Factorio could auto-detect that my mods are not in sync with the ones in the saved game, and ask me in a popup whether I want to sync them when I click on "Load".

User avatar
BlueTemplar
Smart Inserter
Smart Inserter
Posts: 1572
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: Version 0.17.66

Post by BlueTemplar » Wed Aug 21, 2019 3:51 pm

funky.bibimbap wrote:
Wed Aug 21, 2019 2:12 pm
[...]
(I thought people used parallel installations of factorio for different mod sets :roll:)
[...]
It's a kind of a "nuclear option", but even with all the improvements in 0.17, IMHO still the most hassle-free way to run Factorio, especially if you want to run multiple versions of the base game itself !

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6812
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: Version 0.17.66

Post by bobingabout » Sun Aug 25, 2019 10:35 am

funky.bibimbap wrote:
Wed Aug 21, 2019 2:12 pm
I thought people used parallel installations of factorio for different mod sets :roll:
I have parallel installations of Factorio that are different versions.
for mods, just make another mod folder inside the game directory (I don't use the steam version, mods are installed in the game directory, not your user profile), then you can load the game with a command line, such as...

Code: Select all

S:\Games\Factorio 0.17\bin\x64\  factorio.exe --mod-directory "S:\Games\Factorio 0.17\tea-mods"
or, you know, make a new shortcut icon for it.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 3527
Joined: Tue Jul 12, 2016 9:03 am
Contact:

Re: Version 0.17.66

Post by eradicator » Sun Aug 25, 2019 11:35 am

bobingabout wrote:
Sun Aug 25, 2019 10:35 am
funky.bibimbap wrote:
Wed Aug 21, 2019 2:12 pm
I thought people used parallel installations of factorio for different mod sets :roll:
I have parallel installations of Factorio that are different versions.
I have an ugly mess of a batch-based custom launcher that manages different mod folders / config files / startup options.
Xgkkp wrote:
Fri Aug 16, 2019 7:30 pm
  • Is there any reason the "Toggle alt-mode" couldn't just be labelled "show building contents" or something;
There's a whole FFF about translation, leakage of internal names, etcpp. TL;DR version: Finding a better wording is really difficult, especially as there are so many different languages.
Author of: Hand Crank Generator, Screenshot Hotkey 2.0
Mod support languages: 日本語, Deutsch, English
My code in the post above is dedicated to the public domain under CC0.

Hiladdar
Fast Inserter
Fast Inserter
Posts: 103
Joined: Mon May 14, 2018 6:47 pm
Contact:

Re: Version 0.17.66

Post by Hiladdar » Sun Aug 25, 2019 6:03 pm

Since I write and maintain my mods, I set up my PC with 3 separate installs of Factorio as:

../dev/*.*
../stable/*.*
../experimental/*.*

I also have 3 separate icons one per install.

The disadvantage is when I need to patch a new version, I may have to do it between 2 and 3 times. But the advantage is when an experimental version comes out as a "failed experiment" with a "fast patch to fix the patch", I'm not blown out having to download the full patch. The other advantage was then the classes or events changed, necessitating updates some of the mods I play with, I rolled back what I used the stable back a release or 2, and did not update it until the other mod developers updated their mods to work with the revised classes / events.

Hiladdar

User avatar
jockeril
Filter Inserter
Filter Inserter
Posts: 327
Joined: Sun Feb 08, 2015 11:04 am
Contact:

Re: Version 0.17.66

Post by jockeril » Mon Aug 26, 2019 4:52 am

bobingabout wrote:
Sun Aug 25, 2019 10:35 am
funky.bibimbap wrote:
Wed Aug 21, 2019 2:12 pm
I thought people used parallel installations of factorio for different mod sets :roll:
I have parallel installations of Factorio that are different versions.
for mods, just make another mod folder inside the game directory (I don't use the steam version, mods are installed in the game directory, not your user profile), then you can load the game with a command line, such as...

Code: Select all

S:\Games\Factorio 0.17\bin\x64\  factorio.exe --mod-directory "S:\Games\Factorio 0.17\tea-mods"
or, you know, make a new shortcut icon for it.
I love your idea, maybe I will try it. Didn't know there was an option for mod directory... and I also use different folders for different versions but also used to for vanilla vs modded before 0.17
[request] RTL support please

Hebrew Translator for FARL & EvoGUI and much more

join me on
- Twitter[@jockeril],
- Twitch.tv/jockeril,
- Youtube/jocker-il (or JoCKeR-iL)
- and steam !
Image

murgo
Burner Inserter
Burner Inserter
Posts: 8
Joined: Tue Mar 13, 2018 1:25 am
Contact:

Re: Version 0.17.66

Post by murgo » Tue Aug 27, 2019 12:53 pm

Hi,

I just wanted to let you know that we played pure vanilla 0.17.66 multiplayer server this weekend and had a blast. I think we saw 0 bugs altogether for the whole run from start to launch. New oil recipe is way smaller thing for experienced players than what the amount of discussion suggests, new oil was pretty simple to set up but I don't mind since there is so much stuff to do at that point anyway, and the Advanced Oil Processing came maybe an hour after so whatever. Total time till launch was about 22h or something. Also the replay works 100% OK from start to finish.

Seems pretty stable to me already, great work!

Post Reply

Return to “Releases”

Who is online

Users browsing this forum: No registered users