[0.9.6] Blueprint: Buildings rotated after placement

This subforum contains all the issues which we already resolved.
Post Reply
inthev01d
Burner Inserter
Burner Inserter
Posts: 15
Joined: Mon Mar 31, 2014 4:09 pm
Contact:

[0.9.6] Blueprint: Buildings rotated after placement

Post by inthev01d » Mon Mar 31, 2014 4:33 pm

For some blueprints, the rotation of the blueprint before placement is not the same as the buildings that are actually placed. It seems that the checks if the position is ok are done correctly, but after the left click that places the buildings they are rotated differently.
One of the blueprints this happens for is in a chest right next to the player character.

Again, as the save was too large, here's a link to a file hoster:
http://www.file-upload.net/download-876 ... n.zip.html

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10461
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by ssilk » Mon Mar 31, 2014 7:30 pm

Yes, that sounds exactly like this:

https://forums.factorio.com/forum/vie ... =18&t=2839

As with my problem there, your blueprints work, after saving/loading.

But now I mean saw a very, very short rotation, when first selected.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

kovarex
Factorio Staff
Factorio Staff
Posts: 7279
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by kovarex » Mon Mar 31, 2014 7:38 pm

I tested the blueprint (with 2 assembling machines 4 inserters 5 electric poles and transport belts) and it was working correctly for me.
What exactly is wrong?

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10461
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by ssilk » Mon Mar 31, 2014 9:12 pm

Hm. I could describe only my example from the linked post: It was like explained by inthev01d . The blueprints have a visible orientation and that didn't match with the orientation, which is used for "position check"/placed items.

I recorded a blueprint, then used it correctly. But after restarting the game the next day, they where rotated like that. One was rotated 90 degrees and the second 180 degrees. The 180 degrees blueprint was placed always in the same orientation, no matter how I rotated it. After saving/restarting it worked.

As promised in the other post I tried to reproduce that, but no luck. I have all the saves and couldn't reproduce that. I'll try to send them tomorrow, perhaps it helps.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

inthev01d
Burner Inserter
Burner Inserter
Posts: 15
Joined: Mon Mar 31, 2014 4:09 pm
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by inthev01d » Mon Mar 31, 2014 10:11 pm

Ok this is puzzling… I tried reloading that save several times to make sure the bug persisted before I posted it, but didn't restart factorio. Now, after a reboot, it works fine for me too. Guess I should have tried that too before reporting, sorry…
I did a search for similar problems and looked through the bug reports of course, but missed ssilk's post.

Good to know restarting factorio is a workaroud. When this happens again I'll try if this really needs a restart of factorio or is indeed fixed by saving/reloading and I'm somehow mistaken. This might be hard to debug if the effects of the bug don't propagate into the contents of the save. Hopefully we can figure out a way to replicate this…

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10461
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by ssilk » Tue Apr 01, 2014 4:13 am

@inthev01d: no, no, it was right and really important to post it. A bug like that needs a second example and the fact that it disappears after restarting factorio is very important.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

kovarex
Factorio Staff
Factorio Staff
Posts: 7279
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by kovarex » Tue Apr 01, 2014 9:25 am

Maybe I misunderstand the report.

Is the whole blueprint rotated differently than previewed or the individual machines (inserters, transport belts) have different rotations while the whole blueprint structure has the correct rotation?

inthev01d
Burner Inserter
Burner Inserter
Posts: 15
Joined: Mon Mar 31, 2014 4:09 pm
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by inthev01d » Tue Apr 01, 2014 12:36 pm

It's the whole blueprint, the components are rotated correctly. The assembers in the blueprint in my save would still work correctly when the bug occured, it's as if I had rotated everything again by pressing 'R'. I even used this or a similar blueprint in one case where this happened by trying different rotations and placements until the result was correct.

Everything seemed fine and I could place the blueprint only when there were no red parts, but after the final left-click the building ghosts that appeared were as if the blueprint was in fact placed in a different rotation.

I'm sorry I can't explain this any better, I will make screenshots if it happens again.

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10461
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by ssilk » Tue Apr 01, 2014 8:23 pm

Hits it very good.
With my words: I saw, that it can't be placed, even if there is nothing below. Then find a place, where it could be placed and saw, that it was the rotated blueprint. And then I realized, that this was the reason, why it can't be placed before. Then I begun to find the rules: the blueprint is shown in this direction, but placed in that. I compared, if anything else was wrong, but really nothing. Tried other blueprint, which was turned 180 degrees....
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

User avatar
N3X15
Inserter
Inserter
Posts: 24
Joined: Sat Oct 26, 2013 11:44 pm
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by N3X15 » Thu Apr 03, 2014 2:28 am

kovarex wrote:Maybe I misunderstand the report.

Is the whole blueprint rotated differently than previewed or the individual machines (inserters, transport belts) have different rotations while the whole blueprint structure has the correct rotation?
It's like the blueprint has been rotated once with R when you place it. This only seems to happen after first upgrade, however, so I'm wondering if the serialization in the save is initially borked.

kovarex
Factorio Staff
Factorio Staff
Posts: 7279
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.9.6] Blueprint: Buildings rotated after placement

Post by kovarex » Thu Apr 03, 2014 6:57 am

Hello, I already found out what is the cause yesterday. It was bugged this way, if something with diagonal direction was built before. (rail, signal etc.), as the conversion from diagonal->orthogonal direction was not consistent in the preview vs building.

It is fixed for 0.9.7 now.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users