[SOLVED] Swap Buffers Failed

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Mar 10, 2019 12:46 pm

[SOLVED] Swap Buffers Failed

Post by ekamien » Fri May 17, 2019 1:34 pm

Windows 10 x64 on Intel i7 with Nvidia Geforce ti 1060

Code: Select all

   0.002 2019-05-17 08:30:08; Factorio 0.17.40 (build 45018, win64, steam)
   0.002 Operating system: Windows 10 (version 1803) 
   0.002 Program arguments: "E:\SteamLibrary\steamapps\common\Factorio\bin\x64\Factorio.exe" 
   0.002 Read data path: E:/SteamLibrary/steamapps/common/Factorio/data
   0.002 Write data path: C:/Users/Media/AppData/Roaming/Factorio [153633/243383MB]
   0.002 Binaries path: E:/SteamLibrary/steamapps/common/Factorio/bin
   0.010 System info: [CPU: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz, 8 cores, RAM: 6212/16338 MB, page: 8458/18770 MB, virtual: 4330/134217727 MB, extended virtual: 0 MB]
   0.012 Display options: [FullScreen: 0] [VSync: 1] [UIScale: automatic (100.0%)] [Native DPI: 1] [Screen: 255] [Special: 00] [Lang: en]
   0.021 Available displays: 1
   0.021  [0]: \\.\DISPLAY1 - NVIDIA GeForce GTX 1060 6GB {0x05, [0,0], 1920x1080, 32bit, 60Hz}
   0.073 [Direct3D11] Display: 0, Output: 0, DisplayAdapter: 0, RenderingAdapter: 0; d3dcompiler_47.dll
   0.172 Initialised Direct3D[0]: NVIDIA GeForce GTX 1060 6GB; id: 10de-1c03; driver: nvldumdx.dll
   0.172   D3D Feature Level: 11.1, DXGI 1.5+, SwapChain: 1,discard,-,-,none
   0.172   [Local Video Memory] Budget: 5151MB, CurrentUsage: 1MB, Reservation: 0/2727MB
   0.172   [Non-Local Vid.Mem.] Budget: 7352MB, CurrentUsage: 0MB, Reservation: 0/3880MB
   0.172   Tiled resources: Tier 2
   0.172   Unified Memory Architecture: No
   0.172   BGR 565 Supported: Yes
   0.172   MaximumFrameLatency: 3, GPUThreadPriority: 0
   0.235 Desktop composition is active.
   0.235 Graphics settings preset: very-high
   0.235   Dedicated video memory size 6061 MB
   0.235 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 100%] [DXT: high-quality]
   0.235                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 0] [Rotation quality: normal] [Color: 32bit]
   0.309 DSound: Starting _dsound_update thread
   0.309 DSound: Enter _dsound_update; tid=16364
   0.515 Loading mod core 0.0.0 (data.lua)
   0.980 Loading mod base 0.17.40 (data.lua)
   1.535 Loading mod base 0.17.40 (data-updates.lua)
   1.764 Checksum for core: 539540923
   1.764 Checksum of base: 1856828385
   2.186 Loading sounds...
   3.080 Info PlayerData.cpp:69: Local player-data.json unavailable
   3.080 Info PlayerData.cpp:72: Cloud player-data.json available, timestamp 1558061496
   3.309 Initial atlas bitmap size is 16384
   3.380 Created atlas bitmap 16384x16384 [none]
   3.388 Created atlas bitmap 16384x11396 [none]
   3.388 Created atlas bitmap 8192x3884 [decal]
   3.390 Created atlas bitmap 16384x4288 [low-object]
   3.390 Created atlas bitmap 2048x192 [icon-background, not-compressed, linear-minification, linear-magnification, linear-mip-level, , no-crop, no-scale]
   3.391 Created atlas bitmap 8192x3552 [mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   3.392 Created atlas bitmap 16384x6880 [terrain, mipmap, linear-minification, linear-mip-level, no-crop]
   3.392 Created atlas bitmap 4096x1600 [smoke, mipmap, linear-minification, linear-magnification]
   3.393 Created atlas bitmap 4096x1408 [not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level, no-crop, no-scale]
   3.394 Created atlas bitmap 8192x1496 [alpha-mask]
   3.400 Created atlas bitmap 16384x12628 [shadow, linear-magnification, alpha-mask]
   3.400 Created atlas bitmap 8192x2352 [shadow, mipmap, linear-magnification, alpha-mask]
   3.411 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
  15.689 Parallel Sprite Loader initialized (threads: 7)
  23.948 Sprites loaded
  23.998 Generated mipmaps (4) for atlas [3] of size 16384x4288   
  24.023 Generated mipmaps (3) for atlas [5] of size 8192x3552   
  24.069 Generated mipmaps (3) for atlas [6] of size 16384x6880   
  24.083 Generated mipmaps (3) for atlas [7] of size 4096x1600   
  24.096 Generated mipmaps (3) for atlas [8] of size 4096x1408   
  24.110 Generated mipmaps (3) for atlas [11] of size 8192x2352   
  24.117 Custom inputs active: 6
  24.216 Factorio initialised
 995.227 Loading map C:\Users\Media\AppData\Roaming\Factorio\saves\Another one-1-1.zip: 12259526 bytes.
 995.284 Loading level.dat: 27389154 bytes.
 995.292 Info Scenario.cpp:187: Map version 0.17.40-0
 996.594 Loading script.dat: 328 bytes.
 996.602 Checksum for script C:/Users/Media/AppData/Roaming/Factorio/temp/currently-playing/control.lua: 412551764
1102.095 Info AppManager.cpp:277: Saving to _autosave3 (blocking).
1102.744 Info AppManagerStates.cpp:1748: Saving finished
1402.745 Info AppManager.cpp:277: Saving to _autosave1 (blocking).
1403.560 Info AppManagerStates.cpp:1748: Saving finished
1703.580 Info AppManager.cpp:277: Saving to _autosave2 (blocking).
1704.405 Info AppManagerStates.cpp:1748: Saving finished
2004.404 Info AppManager.cpp:277: Saving to _autosave3 (blocking).
2005.238 Info AppManagerStates.cpp:1748: Saving finished
2305.237 Info AppManager.cpp:277: Saving to _autosave1 (blocking).
2306.060 Info AppManagerStates.cpp:1748: Saving finished
2608.195 Info AppManager.cpp:277: Saving to _autosave2 (blocking).
2609.035 Info AppManagerStates.cpp:1748: Saving finished
2894.031 Info AppManagerStates.cpp:1748: Saving finished
2917.360 Info AppManager.cpp:277: Saving to _autosave3 (blocking).
2918.238 Info AppManagerStates.cpp:1748: Saving finished
3218.827 Info AppManager.cpp:277: Saving to _autosave1 (blocking).
3219.623 Info AppManagerStates.cpp:1748: Saving finished
3522.867 Info AppManager.cpp:277: Saving to _autosave2 (blocking).
3523.833 Info AppManagerStates.cpp:1748: Saving finished
3555.879 D3D11_ERROR: IDXGISwapChain::Present failed in swapBuffers on line 1458. Error [0x887a0005] - DXGI_ERROR_DEVICE_REMOVED
3555.879 GetDeviceRemovedReason(): [0x887a0006] DXGI_ERROR_DEVICE_HUNG
3555.880 Error Util.cpp:97: Swap buffers failed.

IDXGISwapChanin::Present error: DXGI_ERROR_DEVICE_REMOVED (0x887a0005)

Reason: DXGI_ERROR_DEVICE_HUNG (0x887a0006)

If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.

User avatar
Filter Inserter
Filter Inserter
Posts: 831
Joined: Wed Aug 03, 2016 2:00 pm

Re: [posila] Swap Buffers Failed

Post by mexmer » Fri May 17, 2019 3:36 pm

i suggest you try to revert nvidia drivers to previous version if you have latest ones, on the other hand, if you have some old driver, first try updating to newer.

from what i found 417.58 seems to be rather stable and good version, while lot of 418.xx drivers shows similar problem to yours trough different games (just search for nvidia DXGI_ERROR_DEVICE_HUNG )

Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Mar 10, 2019 12:46 pm

Re: [posila] Swap Buffers Failed

Post by ekamien » Fri May 17, 2019 5:30 pm

388.13... I suppose it's time to update...

Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Mar 10, 2019 12:46 pm

Re: [posila] Swap Buffers Failed

Post by ekamien » Mon May 20, 2019 12:02 pm

I was living under a rock. There were a number of stability issues before, now everything seems resolved!

Factorio Staff
Factorio Staff
Posts: 3992
Joined: Thu Jun 11, 2015 1:35 pm

Re: [SOLVED] Swap Buffers Failed

Post by posila » Mon May 20, 2019 2:15 pm

Thanks for letting us know. There are some people who have this error often and driver update nor computer reboot doesn't fix it for them, but it seems it is still definitelly good first step to try.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users