[SOLVED] Headless Server + Login Credentials? (Connection Problems)

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

[SOLVED] Headless Server + Login Credentials? (Connection Problems)

Post by Hellkeeper » Wed Jan 09, 2019 8:50 am

Hey there,
I installed a Headless Factorio Server (0.16.51) on one of our Linux Servers. Several other People can connect without Problems to this Server.
But I simply can't get a Connection to my own Server (with Windows Client) ... (Start's downloading the Map, disconnects)

Could it be that I can't Log-In with the Same Credentials on Server AND Client? (Username/Token or Password)

As soon as I try to Connect to the Server - the Others are also kicked off the Server and I get this Error in the Server Logs:
100.428 Error ServerRouter.cpp:194: Nat punch request failed: multiplayer.invalid-address("pingpong1.factorio.com:34197", "System error")
As if the Factorio Systems noticed that the IP of my "User" changed from the Server IP to the Client IP?!? (Just a guess)

I hope someone here can give me a helping Hand? ;-)

Thank you, bye from Austria
Andreas Schnederle-Wagner
Last edited by Hellkeeper on Fri Jan 11, 2019 11:42 am, edited 1 time in total.

Loewchen
Global Moderator
Global Moderator
Posts: 5045
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Loewchen » Wed Jan 09, 2019 9:22 am

Post the complete server and client logs after a session with the issue, mask any passwords.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Hellkeeper » Wed Jan 09, 2019 9:45 am

Server Log: http://temp.in.futureweb.at/factorio/server.log
Client Log: http://temp.in.futureweb.at/factorio/client.log

- ignore Audio Errors - as I just started this Session over RDP - so no full directX
- server fresh restarted - no other players
- My Username (Server and Client): Hellkeeper
- if other players are logged in - they can see "Hellkeeper joined game / downloading Map / Hellkeeper disconnected) - after that they get disconnected too

Loewchen
Global Moderator
Global Moderator
Posts: 5045
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Loewchen » Wed Jan 09, 2019 11:00 am

Something strange is happening when the server starts to serve the map, it seems to freeze for several seconds. I assume the only difference between your client and the others who can connect is that you are in the same network as the server, it might be that the map transfer is causing some network issue.
I expect that the Nat punch error is only fallout of the actual issue, it is just a service for the server to determine its external IP.
You could try if setting a limit to the servers maximum upload speed changes anything.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Hellkeeper » Wed Jan 09, 2019 11:07 am

Hey Loewchen,

Server (85.125.90.204) and Client (178.191.75.241) are NOT in the same Net - the Server is located in our Datacenter - connected with 1 GBit to the Internet ... (As we are a Hosting Provider ... we got some Servers to play at Hand ... ;-))
The Freeze might be because I created those Test Logs over RDP Session as I'm in the Office right now ... and the Client is @ home ...

Will redo Logs when I'm @ home ...

The NAT Punch Error is coming every time (tried several dozen times) when I try to Log in ... also every other Player is reproduceable kicked out of the Server when I try to Log into that Server ... (That's the strange thing ... why is it affecting others when I try to Log In ...)

Andreas

ps) so it's definately no problem when Client and Server use the Same User + Token, right? (client | server other Networks / other IPs ...)

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Hellkeeper » Wed Jan 09, 2019 11:34 am

alright - tested from our Office now (which is connected with 300 MBit directly to the Internet) - got excactly the same Problems like at home?!?

Server Log: http://temp.in.futureweb.at/factorio/server-1.log
Client Log: http://temp.in.futureweb.at/factorio/client-1.log

This just doesn't make any sense? Everybody can connect to my Server without Problems - but I can't connect to it - from 2 different PCs from 2 different ISPs / Networks ... ?!?

@home I have Steam install
@work I tried it with the ZIP downloaded Version (fresh downloaded a few Minutes ago)

Only similiarity (home + work) is the User I log in with ... ?!?

Andreas

Loewchen
Global Moderator
Global Moderator
Posts: 5045
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Loewchen » Wed Jan 09, 2019 11:49 am

Using the same account for server and client is standard practice for factorio servers afaik and any restrictions would not make sense anyway since account authentication for clients is purely optional and keep in mind that your client successfully connected to the server already, the issue arises way down the road when uploading the map to it. I would rule out any account issue.

Maybe what the problematic instances have in common is a high connection speed that triggers something weird in the server but it would have to be something really weird. I would try the upload speed limiter in the factorio server settings just to rule it out.
You might have to wait for a dev to take a look at this.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Hellkeeper » Wed Jan 09, 2019 12:23 pm

tested with 8 Mbit Upload restriction ("max_upload_in_kilobytes_per_second": 8224) - same Problem.

Do the Devs monitor the Boards themself? Or could you maybe point them to this Thread?

Hope they can help isolate the Problem.

Server-Side Firewall Session Log to Factorio Server: http://temp.in.futureweb.at/factorio/firewall.jpg
Image

Thank you for trying to help! ;-)
Last edited by Hellkeeper on Wed Jan 09, 2019 12:35 pm, edited 4 times in total.

zacharias2k
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed Jan 09, 2019 12:22 pm
Contact:

Re: Headless Server + Login Credentials?

Post by zacharias2k » Wed Jan 09, 2019 12:24 pm

Loewchen wrote:
Wed Jan 09, 2019 11:49 am
Using the same account for server and client is standard practice for factorio servers afaik and any restrictions would not make sense anyway since account authentication for clients is purely optional and keep in mind that your client successfully connected to the server already, the issue arises way down the road when uploading the map to it. I would rule out any account issue.
Sounds legit.
Loewchen wrote:
Wed Jan 09, 2019 11:49 am
Maybe what the problematic instances have in common is a high connection speed that triggers something weird in the server but it would have to be something really weird. I would try the upload speed limiter in the factorio server settings just to rule it out.
A race condition seems unlikely. I was able to connect, got a pretty good connection speed too, so this one seems a dead end too.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Hellkeeper » Wed Jan 09, 2019 2:25 pm

Server Log with "--verbose" Logging: http://temp.in.futureweb.at/factorio/se ... erbose.log
Client Log with "--verbose" Logging: http://temp.in.futureweb.at/factorio/cl ... erbose.log

Zavian
Smart Inserter
Smart Inserter
Posts: 1385
Joined: Thu Mar 02, 2017 2:57 am
Contact:

Re: Headless Server + Login Credentials?

Post by Zavian » Thu Jan 10, 2019 7:25 am

Hellkeeper wrote:
Wed Jan 09, 2019 12:23 pm
Do the Devs monitor the Boards themself? Or could you maybe point them to this Thread?

Hope they can help isolate the Problem.
At least some of the devs do read the Technical help sub-forum (and other sub-forums). You see them pop-up in random threads, but typically only when they have something to say, eg a solution/suggestion of what to do.

I note that the server seemed to have issues right after

Code: Select all

335.884 Verbose ServerRouter.cpp:157: Sending keepalive nat punch request to pingpong server.
355.900 Error ServerRouter.cpp:194: Nat punch request failed: multiplayer.invalid-address("pingpong1.factorio.com:34197", "System error")
That sounds like it might be solved by the fix for viewtopic.php?f=218&t=62814, which is fixed in 0.17. Meanwhile adding static entries for pingpong1 and pingpong2 to your hosts file might work as a temporary workaround. (Any chance that your dns server is rate limiting requests for that address? Maybe also check the dns servers logs to see if it is logging an error? Any other reason for factorio to be logging that error message?)

There have been some other changes to networking code in 0.17 (steam networking will be supported, probably other fixes/changes as well). So there is a fair possibility that this will also be fixed in 0.17, even if we never pin down what the root cause is.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Hellkeeper » Thu Jan 10, 2019 2:21 pm

Hey Zavian,

thx for your Answer - but the "Nat punch request failed: multiplayer.invalid-address("pingpong1.factorio.com:34197", "System error")" Error ALWAYS appears when I try to Log-In into the Server. When others Log-In no such Error appears ... I suspect this is a companion appearance of the real Problem (whatever it is ...).
Also I would rule out DNS Problems ... we are a Hosting Provider running our own DNS Infrastructure ... 2 of our DNS Servers are in the same DC as this Server ... Factorio Server --> DNS Servers are connected @ 10Gbit ... ;-)
Also no Rate Limiting for our own IP Ranges ...

Really frustrating ... :-(

Jap2.0
Smart Inserter
Smart Inserter
Posts: 1934
Joined: Tue Jun 20, 2017 12:02 am
Contact:

Re: Headless Server + Login Credentials?

Post by Jap2.0 » Thu Jan 10, 2019 10:34 pm

Hellkeeper wrote:
Thu Jan 10, 2019 2:21 pm
the "Nat punch request failed: multiplayer.invalid-address("pingpong1.factorio.com:34197", "System error")" Error ALWAYS appears when I try to Log-In into the Server. When others Log-In no such Error appears ... I suspect this is a companion appearance of the real Problem (whatever it is ...).
I'm just going to point out a few things that I see consistently as well, and some of the timing and ordering of events is confusing me a bit. I'm afraid I can't say anything beyond this.

t ConnectionRequestReplyConfirm (type(ConnectionRequestReplyConfirm) ) from(IP ADDR:({x.x.x.x:x}))
t Refusing connection for address (IP ADDR:({x.x.x.x:x})), username (Hellkeeper). PasswordMissing
t+1 Warning TransmissionControlHelper.cpp:176: Fragment 0001 failed too many times
t+2 ConnectionRequestReplyConfirm (type(ConnectionRequestReplyConfirm) ) from(IP ADDR:({x.x.x.x:y}))
t+2 ServerRouter.cpp:409: Replying to connectionRequest for address(IP ADDR:({x.x.x.x:y})).
t+2 ServerSynchronizer.cpp:557: nextHeartbeatSequenceNumber(x) adding peer(1)
t+2 ServerMultiplayerManager.cpp:699: mapTick(x) changing state from(InGame) to(InGameSavingMap)
t+2 ServerMultiplayerManager.cpp:795: mapTick(x) received stateChanged peerID(1) oldState(Ready) newState(ConnectedWaitingForMap)
t+4 ServerMultiplayerManager.cpp:855: MapTick(x) Serving map(/opt/factorio/temp/mp-save-0.zip) for peer(1) size(y) crc(z)
t+4 ServerMultiplayerManager.cpp:699: mapTick(x) changing state from(InGameSavingMap) to(InGame)
t+4 ServerMultiplayerManager.cpp:795: mapTick(x) received stateChanged peerID(1) oldState(ConnectedWaitingForMap) newState(ConnectedDownloadingMap)
t+30-40 ServerRouter.cpp:194: Nat punch request failed: multiplayer.invalid-address("pingpong1.factorio.com:34197", "System error")
t+35-55 ServerMultiplayerManager.cpp:901: Disconnect notification for peer (1)
t+35-55 ServerSynchronizer.cpp:576: nextHeartbeatSequenceNumber(6121) removing peer(1).
There are 10 types of people: those who get this joke and those who don't.

Hellkeeper
Burner Inserter
Burner Inserter
Posts: 14
Joined: Tue Jan 08, 2019 9:15 pm
Contact:

Re: Headless Server + Login Credentials?

Post by Hellkeeper » Fri Jan 11, 2019 9:56 am

Guess I found the Source of the Problems ... seems like the IPS/DOS SENSORS on our Firewall triggered because of the extremely high amount of UDP Packages ...
Still not sure why it worked for others ... maybe because they were on a slower Connection and so the amount of UDP Packages / Time wasn't that high like on my Connection??? ¯\_(ツ)_/¯
Also why others were kicked out of the Server when I tried to log in will remain a mystery ... (as we do Source IP blocking on IPS/DOS Sensors and no Destination IP blocking) ... maybe the additional UDP Packages "informing" the other Player that I joined were just a few too much ... so Sensor triggered too ... lol ... really mean ... ;-)

Attack Name udp_flood
Attack ID 285212772
Reference http://www.fortinet.com/ids/VID285212772
Count 19026
Severity HIGH
Message anomaly: udp_flood, 734 > threshold 500, repeats 19026 times

Thx all who tried to figure out the Problem!! :D

Andreas

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: Skeletpiece