[16.9] Save hangs system

This subforum contains all the issues which we already resolved.
Post Reply
zBeeble
Burner Inserter
Burner Inserter
Posts: 7
Joined: Mon May 15, 2017 8:41 am
Contact:

[16.9] Save hangs system

Post by zBeeble » Fri Dec 29, 2017 10:20 pm

I've found that after loading the attached save, saving again hangs the system. Autosaves also hang the system. I'm also including the save.tmp file in case that helps, because I don't see stuff about the save in the log file.

In the save, the train is rushing to the copper-1 stop. Normally I get out there and try to place two filter inserters for the 5th car. One gets artillery shells and the other gets repair packs. Every time I have tried a manual save on this after this point, it has hung and I have been unable to kill the process with the task manager (requiring a reboot to rectify). Additionally, I don't know if it scribbles on the mod directory at this point, but I've had complaints about mods on startup (not every time) and startup takes a long time following the reboot.

Originally, it was an autosave that hung the system, but I have refined the point at which the problem is caused by saving ever-closer to the problem.

Originally, the problem was detected under 0.16.8. The game updated to 0.16.9 and testing showed the problem continues.

No mods were used.
Attachments
factorio-previous.log
previous log file, just 'cause.
(32.86 KiB) Downloaded 36 times
factorio-current.log
log file from the most recent attempt
(3.67 KiB) Downloaded 34 times
sixteen_AA_062.tmp.zip
example of a safe file that failed.
(1.18 MiB) Downloaded 20 times
sixteen_AA_061.zip
closest save file I have.
(11.96 MiB) Downloaded 20 times

ichttt
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Dec 29, 2017 10:26 pm
Contact:

Re: Save hangs system.

Post by ichttt » Fri Dec 29, 2017 10:36 pm

I also have this problem. I was playing multiplayer with a friend of mine and the system hanged up when saveing autosave 3, and after he closed it using alt+f4, I tried to save it as well, and my game hung up as well. When we tried resuming the old autosave, it hung up as soon as it tried to save the new autosave. We do use mods, however, but it is only the electric trains and the miniloader mod.
EDIT: I was using 0.16.8 when it first crahed, but the second crash happen in 0.16.9
Attachments
_autosave2.zip
The latest functional autosave
(11.34 MiB) Downloaded 15 times
Screenshot_2.png
A stacktrace of the selected thread
Screenshot_2.png (11.29 KiB) Viewed 6168 times
Screenshot_1.png
A screenshot of proccess exlorer (sysiternals) was hanging
Screenshot_1.png (38.33 KiB) Viewed 6168 times
0.16.8.tmp.zip
My save attempt
(1.04 MiB) Downloaded 18 times
factorio-current.log
(46.74 KiB) Downloaded 34 times
factorio-previous.log
(71.24 KiB) Downloaded 29 times

gogogadgetjimbo
Manual Inserter
Manual Inserter
Posts: 2
Joined: Fri Dec 29, 2017 8:26 pm
Contact:

Re: [16.9] Save hangs system

Post by gogogadgetjimbo » Fri Dec 29, 2017 10:49 pm

I have the same issue. Vanilla Game, no mods. 0.16.9. Hangs on save after about 3 minutes of game play. Manual or Auto save. Windows 10 Pro
Attachments
factorio-current.log
(8.4 KiB) Downloaded 36 times
Last edited by gogogadgetjimbo on Fri Dec 29, 2017 11:19 pm, edited 1 time in total.

Aprofis05
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Dec 29, 2017 10:41 pm
Contact:

Re: [16.9] Save hangs system

Post by Aprofis05 » Fri Dec 29, 2017 11:02 pm

Hello
It's similar in my case. On the first crash, I wanted to build a wall when the autosave started. Then the game crashed. After the restart, I drove back to my base to get new material. I found that some vendor boxes had no connections despite sufficient ports. Then I exchanged them for a steel box and then back and the boxes had logistic connection again. After the third box came the Autosave again and the game fell off again.
Mods I have not installed since 0.16.8.

So far I never had any problems with the game and was really surprised to see two crashes in one day.
Attachments
factorio-current.log
(17.34 KiB) Downloaded 33 times
_autosave3.zip
(14.3 MiB) Downloaded 16 times

aequitas
Burner Inserter
Burner Inserter
Posts: 6
Joined: Mon May 01, 2017 5:11 pm
Contact:

Re: [16.9] Save hangs system

Post by aequitas » Fri Dec 29, 2017 11:15 pm

Same issue. 0.16.8 and 0.16.9, macOS, a few mods (mostly simple QOL). Hangs on auto save. Does not seem to happen every time the game is (auto)saved.
Attachments
_autosave1.zip
Previous game save
(9.74 MiB) Downloaded 17 times
_autosave2.tmp.zip
Fail autosave
(1007.64 KiB) Downloaded 17 times
factorio-current.log
(6.95 KiB) Downloaded 30 times

Fisher42
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Dec 29, 2017 11:17 pm
Contact:

Re: [16.9] Save hangs system

Post by Fisher42 » Fri Dec 29, 2017 11:21 pm

We are having the same issue with 16.9 and the attached save.
If you do anything with the chest located at 1852,2438 the next save crashes the game.

Code: Select all

#0  0x00000000008a327a in Logging::flush() at /tmp/factorio-vfxQMy/src/Util/Logging.cpp:61
#1  0x00000000008cd29f in Logging::logAndAbortOrThrow(char const*, unsigned int, LogLevel, std::string const&) at /tmp/factorio-vfxQMy/src/Util/Logging.cpp:79
#2  0x000000000099822c in Logging::logAndAbortOrThrow(char const*, unsigned int, LogLevel, char const*, ...) at /tmp/factorio-vfxQMy/src/Util/Logging.cpp:73
#3  0x000000000099847b in LogisticSupplyChestDistribution::save(MapSerialiser&) const at /tmp/factorio-vfxQMy/src/Logistics/LogisticSupplyChestDistribution.cpp:35
#4  0x00000000009985cf in ConstIntrusiveListIterator<LogisticSupplyChestDistribution, ChestDistributionSupplyTag, false>::operator++() at /tmp/factorio-vfxQMy/src/Util/Container/IntrusiveList.hpp:433
#5  0x00000000009986a7 in LogisticSupplyItemState::save(MapSerialiser&) const at /tmp/factorio-vfxQMy/src/Logistics/LogisticSupplyItemState.cpp:85
#6  0x0000000000998a8e in LogisticSupply::save(MapSerialiser&) const at /tmp/factorio-vfxQMy/src/Logistics/LogisticSupply.cpp:69 (discriminator 3)
#7  0x0000000000998c88 in LogisticNetwork::save(MapSerialiser&) const at /tmp/factorio-vfxQMy/src/Logistics/LogisticNetwork.cpp:305
#8  0x00000000009996ff in LogisticManager::save(MapSerialiser&) const at /tmp/factorio-vfxQMy/src/Logistics/LogisticManager.cpp:119
#9  0x0000000000a8ad54 in SerialiserHelper<MapSerialiser>::Saver<LogisticManager, void>::save(MapSerialiser&, LogisticManager const&) at /tmp/factorio-vfxQMy/src/Util/SerialiserHelper.hpp:41
#10 0x0000000000a8b7a4 in MapSerialiser& MapSerialiser::operator<< <LogisticManager>(LogisticManager const&) at /tmp/factorio-vfxQMy/src/Map/MapSerialiser.hpp:35
#11 0x0000000000a8bf5b in ForceData::save(MapSerialiser&) const at /tmp/factorio-vfxQMy/src/Force/ForceData.cpp:394
#12 0x0000000000b5e2b6 in ForceManager::save(MapSerialiser&) const at /tmp/factorio-vfxQMy/src/Force/ForceManager.cpp:72
#13 0x0000000001498e0f in std::vector<CircuitNetwork*, std::allocator<CircuitNetwork*> >::size() const at /usr/include/c++/7/bits/stl_vector.h:671
#14 0x0000000000007619 in Map::save(MapSerialiser&, ProgressObserver*) const at /tmp/factorio-vfxQMy/src/Map/Map.cpp:1086
#15 (nil) in Scenario::saveMap(SaveType, ZipPackageWriter&, TargetSerialiser&, ProgressObserver*, bool&) at /tmp/factorio-vfxQMy/src/Scenario/Scenario.cpp:624
 113.922 Error LogisticSupplyChestDistribution.cpp:37: LogisticSupplyChestDistribution is attempting to save without an owner. Item: copper-plate, count:4800
Attachments
EoSMP.zip
(33.12 MiB) Downloaded 17 times

Brambor
Long Handed Inserter
Long Handed Inserter
Posts: 85
Joined: Thu May 07, 2015 1:52 pm
Contact:

Re: [16.9] Save hangs system

Post by Brambor » Fri Dec 29, 2017 11:31 pm

Same issue in my case. Once it autosaves it crashes.
Attaching current-log and save that works.
And the 'unfinished' autosave.

At the same time, second, probably related bug: there are passive-provider-chests blinking that they are not in reach of roboport logistic covarage even thought they are. Deconstructing them and placing them resolves the issue as well as marking them for deconstruction and canceling that marking.
Attachments
_autosave3.tmp.zip
(1.07 MiB) Downloaded 19 times
0.16.zip
will crash in less than 5 mins
(13.43 MiB) Downloaded 16 times
factorio-current.log
(3.56 KiB) Downloaded 34 times

arbarbonif
Fast Inserter
Fast Inserter
Posts: 105
Joined: Fri Jul 01, 2016 2:46 am
Contact:

Re: [16.9] Save hangs system

Post by arbarbonif » Fri Dec 29, 2017 11:37 pm

I had it hang on (I believe) the first autosave of 16.9, while I was changing the recipe in a assembly machine. Seems to be fine now tho, after I loaded from the previous save.

ejg
Long Handed Inserter
Long Handed Inserter
Posts: 52
Joined: Fri May 05, 2017 9:15 am

Re: [16.9] Save hangs system

Post by ejg » Sat Dec 30, 2017 12:21 am

Saving map _autosave2 with a fully black bar here. I can still open and close the map (m) but my friend dropped from the game. I do see him disconnecting though (Wackerstamfer left the game). I do use TeamSpeak 3 and play the game via Steam.

After I open the latest autosave game all requester chests are screwed (symbol stating that they are not in logistic range although they definitely are).

The weird thing is that the chests were fine while playing. This makes me believe that the autosaving or the saving causes the requester chests to go faulty.
Attachments
_autosave1.zip
While playing the chests were OK (we manually corrected the errors), after playing however disconnected icons appear.
(23.35 MiB) Downloaded 15 times
factorio-current.log
(33.19 KiB) Downloaded 35 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [16.9] Save hangs system

Post by kovarex » Sat Dec 30, 2017 12:24 am

Thanks for the report, it is fixed for the next version (0.16.10)

ejg
Long Handed Inserter
Long Handed Inserter
Posts: 52
Joined: Fri May 05, 2017 9:15 am

Re: [16.9] Save hangs system

Post by ejg » Sat Dec 30, 2017 12:38 am

Can we use the saves with corrupted chests or do I need to take an older save before they were corrupted?

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [16.9] Save hangs system

Post by kovarex » Sat Dec 30, 2017 12:45 am

I made a migration to 0.16.10, that should fix it, so I would try it and if it works properly it should be fine, but I would keep the older save for some time to be sure.
Edit: I tried to load the sixteen_AA_061.zip in 0.16.10 in debug mode, ran the consistency checks, and it all passed, so it should be fine.

MakCuber
Burner Inserter
Burner Inserter
Posts: 11
Joined: Tue Mar 01, 2016 5:18 am
Contact:

Re: [16.9] Save hangs system

Post by MakCuber » Sat Dec 30, 2017 3:41 am

Same issue all day today on my server. Would happen on average once per hour, always when saving/autosaving. Only change recently is the server actually crashed, where as before it would just hang
Attachments
factorio-current.log
(17.55 KiB) Downloaded 31 times

firstzerg
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Dec 30, 2017 9:11 am
Contact:

Re: [16.9] Save hangs system

Post by firstzerg » Sat Dec 30, 2017 9:17 am

I'm having the same problem while saving.
I found out that it occurs when the number of objects in the chest is limited.
Video with bug: https://youtu.be/eCJaA9-nAKY

jevon
Burner Inserter
Burner Inserter
Posts: 12
Joined: Sun May 08, 2016 7:42 am
Contact:

Re: [16.9] Save hangs system

Post by jevon » Sat Dec 30, 2017 9:46 am

Brambor wrote:At the same time, second, probably related bug: there are passive-provider-chests blinking that they are not in reach of roboport logistic covarage even thought they are. Deconstructing them and placing them resolves the issue as well as marking them for deconstruction and canceling that marking.
This seems very related, a passive chest was suddenly blinking "not in reach of roboport". Deleting the chest and re-building it and then trying to save causes a crash.

Save game attached. When loading the save game in 0.16.9, some (many?) (one?) of the passive chests will say "not in coverage". Delete one of the passive chests and build on top of it - saving causes a crash. Reproducible.
Attachments
_autosave3.zip
(8.88 MiB) Downloaded 19 times

jevon
Burner Inserter
Burner Inserter
Posts: 12
Joined: Sun May 08, 2016 7:42 am
Contact:

Re: [16.9] Save hangs system

Post by jevon » Sat Dec 30, 2017 12:37 pm

jevon wrote:
Brambor wrote:At the same time, second, probably related bug: there are passive-provider-chests blinking that they are not in reach of roboport logistic covarage even thought they are. Deconstructing them and placing them resolves the issue as well as marking them for deconstruction and canceling that marking.
This seems very related, a passive chest was suddenly blinking "not in reach of roboport". Deleting the chest and re-building it and then trying to save causes a crash.

Save game attached. When loading the save game in 0.16.9, some (many?) (one?) of the passive chests will say "not in coverage". Delete one of the passive chests and build on top of it - saving causes a crash. Reproducible.
Confirmed that 16.10 fixed this. Yay! Thank you! :) xoxoxo

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Google [Bot]