Search found 100 matches

by Oarc
Fri Aug 28, 2020 1:51 pm
Forum: Desyncs with mods
Topic: [1.0.0] Scenario desync, no mods (not happening before 1.0.0)
Replies: 1
Views: 137

[1.0.0] Scenario desync, no mods (not happening before 1.0.0)

I'm not sure what changed. I haven't made any significant changes to my scenario code since 1.0.0 was released. However, I'm seeing a huge number of desyncs now for players joining my server. Here are some reports uploaded by another player: https://www.dropbox.com/sh/za0h0osa019h5bh/AACfWG54apNPyog...
by Oarc
Fri Jun 19, 2020 2:51 am
Forum: Duplicates
Topic: [0.18.X] LuaChunkIterator not safe when deleting chunks?
Replies: 2
Views: 159

[0.18.X] LuaChunkIterator not safe when deleting chunks?

Not sure if this is expected behavior, it probably is. It seems like it's not safe to use a LuaChunkIterator if you happen to delete the chunk that it's currently pointing to. (At least that is my guess) If it's expected, just mark not a bug. Clearly if I am deleting chunks I need to get a new itera...
by Oarc
Tue Apr 28, 2020 4:07 pm
Forum: Technical Help
Topic: Text rendering is pixellated?
Replies: 4
Views: 343

Re: Text rendering is pixellated?

Thanks for the clarification!
by Oarc
Mon Apr 27, 2020 6:38 pm
Forum: Technical Help
Topic: Text rendering is pixellated?
Replies: 4
Views: 343

Re: Text rendering is pixellated?

What are those fonts that fit your categories? default-game and count-font ? Also, this same lua line USED to work a few weeks ago. Something happened and the exact same stuff no longer works... Was this changed in a recent update? I used to be able to use scenario-message-dialog before and it worke...
by Oarc
Sun Apr 26, 2020 2:39 pm
Forum: Technical Help
Topic: Text rendering is pixellated?
Replies: 4
Views: 343

Text rendering is pixellated?

I don't think this is a bug since it seems others don't have this issue. I tried rolling back to 0.18.16, and tried versions .19/20/21. The issue is shown in the attached picture. font scaling issue.png The code I am using to generate this is: /c rid = rendering.draw_text{text="Welcome...", surface=...
by Oarc
Tue Feb 25, 2020 7:56 pm
Forum: Modding help
Topic: [0.18.8] find_enemy_units doesn't seem to work on other forces?
Replies: 5
Views: 287

Re: [0.18.8] find_enemy_units doesn't seem to work on other forces?

Thank you for the info and quick response!
by Oarc
Tue Feb 25, 2020 12:52 pm
Forum: Modding help
Topic: [0.18.8] find_enemy_units doesn't seem to work on other forces?
Replies: 5
Views: 287

Re: [0.18.8] find_enemy_units doesn't seem to work on other forces?

Okay so it's just a documentation inconsistency then? find_nearest_enemy says "Find nearest enemy unit". For the record, if that's the case, I'd suggest renaming find_nearest_enemy -> find_nearest_enemy_unit But I'd also like to request you keep find_nearest_enemy and also add a find_enemies to comp...
by Oarc
Tue Feb 25, 2020 4:06 am
Forum: Modding help
Topic: [0.18.8] find_enemy_units doesn't seem to work on other forces?
Replies: 5
Views: 287

[0.18.8] find_enemy_units doesn't seem to work on other forces?

I did the following to test: Loaded up a vanilla game and ran this command: /c game.player.print(serpent.block(game.player.surface.find_enemy_units(game.player.position, 1000))) It found 2 entities. Then I ran this command: /c game.player.print(serpent.block(game.player.surface.find_enemy_units(game...
by Oarc
Wed Jan 29, 2020 5:39 pm
Forum: Minor issues
Topic: Scenario created from a save from a mod scenario doesn't copy image file?
Replies: 2
Views: 299

Scenario created from a save from a mod scenario doesn't copy image file?

I'm not sure what is expected here but I did the following: 1. I have a scenario with no blueprint.zip or .dat or whatever in it. It works great, prompts the user for map gen settings on the start, and it also has a image.png that displays nicely. 2. I made a mod version of my scenario. It shows up ...
by Oarc
Sun Aug 11, 2019 8:37 pm
Forum: Resolved Problems and Bugs
Topic: [Oxyd] [0.17.64] Desync on telling unit to build a base.
Replies: 1
Views: 866

[Oxyd] [0.17.64] Desync on telling unit to build a base.

I started my server using the freeplay scenario. Sent these commands: /c global.bug = game.player.surface.create_entity{name = "small-biter", position = {x=0,y=-50}} /c global.bug.set_command({type = defines.command.build_base, destination = {x=0,y=-50}, ignore_planner = true, distraction = defines....
by Oarc
Sun Aug 11, 2019 2:53 pm
Forum: Modding help
Topic: Desync in scenario - need help please. [solved]
Replies: 2
Views: 293

Desync in scenario - need help please. [solved]

Hiya, I'm having trouble figuring out this desync so I'm posting it here in the hopes that someone knowledgeable can help me out. The only difference I can see in the level_with_tags_tick is attached as an image. Sometimes on other desyncs, I see a difference in biter positions it looks like. But in...
by Oarc
Wed Aug 07, 2019 8:23 pm
Forum: Modding help
Topic: [0.17.63] Game Freeze (Custom Scenario) on unit group destroy or autonomous.
Replies: 2
Views: 247

[0.17.63] Game Freeze (Custom Scenario) on unit group destroy or autonomous.

THIS IS A CUSTOM SCENARIO SPECIFIC ISSUE so I understand if you don't have time to help. I tried to figure out how to reproduce this with minimal scenario code, but I still can't figure it out after spending several hours on this. For some reason, when I use set_autonomous() or destroy() on my unit...
by Oarc
Sat Jul 20, 2019 11:29 pm
Forum: News
Topic: Friday Facts #304 - Small bugs; Big changes
Replies: 668
Views: 60714

Re: Friday Facts #304 - Small bugs; Big changes

I like the new proposed oil changes. Definitely interested to see how it plays out.
by Oarc
Sat Jul 06, 2019 5:48 pm
Forum: Resolved Problems and Bugs
Topic: [Oxyd] [0.17.54] Biters are ideling / not finding way to base
Replies: 4
Views: 1512

Re: Biters are ideling / not finding way to base

I'm just guessing, but I think my bug report, and this reddit post might all be related: https://forums.factorio.com/viewtopic.php?f=7&t=72961 https://www.reddit.com/r/factorio/comments/c9uhe1/dont_bother_me_im_really_busy_with_this_rock/ The general issues seems to be biters not moving when they re...
by Oarc
Sat Jul 06, 2019 3:19 am
Forum: Resolved Problems and Bugs
Topic: [Oxyd] [0.17.54] Unit Group gets stuck between move and attack commands in a compound command.
Replies: 1
Views: 950

[Oxyd] [0.17.54] Unit Group gets stuck between move and attack commands in a compound command.

I noticed this while trying to create a scenario/mod that creates some enemy groups and goes to attack the player or some player buildings. In this particular case, they are trying to attack a stone furnace. The problem is as follows: 1. Group is created and given a compound command with several "go...
by Oarc
Thu Jul 04, 2019 2:02 pm
Forum: Releases
Topic: Version 0.17.54
Replies: 55
Views: 14668

Re: Version 0.17.54

Yep, latest headless is just 404 when I try to download it.
CDN issues maybe?
by Oarc
Wed Jul 03, 2019 3:46 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.53] Missing defines for group_state?
Replies: 1
Views: 253

[0.17.53] Missing defines for group_state?

From people on the discord forum, this it the enum for LuaUnitGroup.state: enum class State : uint8_t { Gathering = 0, Moving = 1, AttackingDistraction = 2, AttackingTarget = 3, Finished = 4, Pathfinding = 5, WanderInGroup = 6 }; These are the only ones in the defines.group_state though: defines.gro...
by Oarc
Mon Jul 01, 2019 5:25 pm
Forum: Not a bug
Topic: Compilatron can get in the way?
Replies: 1
Views: 288

Compilatron can get in the way?

My compilatron stopped me from moving or fueling one of the inserters.
See image.

Is there a way to get compi to move out of the way? Did I do something wrong?

Go to advanced search