[Oxyd] [0.17.18] Multiple issues with technology tree

This subforum contains all the issues which we already resolved.
Post Reply
jarcionek
Fast Inserter
Fast Inserter
Posts: 137
Joined: Thu Mar 10, 2016 11:26 am
Contact:

[Oxyd] [0.17.18] Multiple issues with technology tree

Post by jarcionek »

There is a couple of issues, not sure whether it would be possible to split them, so I will walk you through the user actions and describe what's happening and what I was expecting to happen instead.

I opened the technology tree, "Artillery shell range 9" shows on the list but the "Worker robot speed 15" does not:
Screenshot 1.PNG
Screenshot 1.PNG (340.98 KiB) Viewed 1590 times


I would like to see roughly how many rockets I have to fire to finish the current tech. I can see that "Artillery shell range 9" is selected (it's brighter and pushed in). So I click on the "Artillery shell range 8" that is being researched, but nothing changes. I was expecting the selection to change from "Artillery shell range 9" to "Artillery shell range 8" and the displayed number to change from "x 512k" to "x 256k", together with the title "Artillery shell range 9 (Available)" to something like "Artillery shell range 9 (In Queue)".



Then I realise that to get the information I need, I simply need to hover over current tech:
Screenshot 2.PNG
Screenshot 2.PNG (354.59 KiB) Viewed 1590 times


Then I click on the "Worker robot speed 14" being researched. Notice that the "Artillery shell range 9" is no longer pushed in, but is still in brighter yellow:
Screenshot 3.PNG
Screenshot 3.PNG (345.25 KiB) Viewed 1590 times


Then I click on the "Artillery shell shooting speed 4", which becomes pushed in and brighter yellow, but the "Artillery shell range 9" is still brighter yellow:
Screenshot 4.PNG
Screenshot 4.PNG (340.91 KiB) Viewed 1590 times


Now that I described it, I can actually isolate the individual issues:
1. When the technology is in queue (but not being researched), its next tier is not showing in the list of technologies
2. Technologies in the research queue behave inconsistently with technologies in the list of technologies (i.e. they cannot be clicked)
2b. When the technology tree opens, I would expect the currently researching technology to be selected, not its next tier
3. Background of the technologies in the list of technologies stays brighter after being clicked

jarcionek
Fast Inserter
Fast Inserter
Posts: 137
Joined: Thu Mar 10, 2016 11:26 am
Contact:

Re: [Oxyd] [0.17.18] Multiple issues with technology tree

Post by jarcionek »

Playing 0.17.23 now, I have noticed that this has slightly changed. I can no longer reproduce:
jarcionek wrote:
Tue Mar 26, 2019 9:33 am
3. Background of the technologies in the list of technologies stays brighter after being clicked
But to compensate for it ( :) ) I have noticed that the tier of infinite research is sometimes not showing:

Screenshot.PNG
Screenshot.PNG (248.42 KiB) Viewed 1465 times

Oxyd
Former Staff
Former Staff
Posts: 1428
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [Oxyd] [0.17.18] Multiple issues with technology tree

Post by Oxyd »

jarcionek wrote:
Tue Mar 26, 2019 9:33 am
1. When the technology is in queue (but not being researched), its next tier is not showing in the list of technologies
Fixed in 0.17.24.
jarcionek wrote:
Tue Mar 26, 2019 9:33 am
2. Technologies in the research queue behave inconsistently with technologies in the list of technologies (i.e. they cannot be clicked)
Fixed in 0.17.24, thanks.
jarcionek wrote:
Tue Mar 26, 2019 9:33 am
2b. When the technology tree opens, I would expect the currently researching technology to be selected, not its next tier
I wouldn't
jarcionek wrote: I have noticed that the tier of infinite research is sometimes not showing
I can't reproduce that. Can you give the exact steps to reproduce this? Ideally in a new thread, since this one is getting marked as resolved.

Bilka
Factorio Staff
Factorio Staff
Posts: 2853
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [Oxyd] [0.17.18] Multiple issues with technology tree

Post by Bilka »

Oxyd wrote:
Tue Apr 02, 2019 3:25 pm
jarcionek wrote: I have noticed that the tier of infinite research is sometimes not showing
I can't reproduce that. Can you give the exact steps to reproduce this? Ideally in a new thread, since this one is getting marked as resolved.
It's this bug, it was already fixed: 68846
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

Post Reply

Return to “Resolved Problems and Bugs”