[Oxyd] [0.17.21] Infinite research missing when queued

This subforum contains all the issues which we already resolved.
Post Reply
n_slash_a
Inserter
Inserter
Posts: 31
Joined: Wed Feb 27, 2019 1:05 am
Contact:

[Oxyd] [0.17.21] Infinite research missing when queued

Post by n_slash_a »

I just upgraded from 0.17.17 to 0.17.21. After loading my game and playing for a bit, my in-progress research of robot speed 7 completed. I opened my research queue, and found that robot speed and laser damage researches are not in the available research technologies.

What I expect: the next levels to be there so I can add them to the queue.

I tired adding mining productivity 7 to the queue, and 8 did not appear like I would expect.

Screenshot of research queue attached.

Relevant mods [to the tech tree]: YARM and Power Armor Mk 4
Other mods [probably not relevant]: Auto Deconstruct, Bottleneck, EvoGUI, Squeak Through, Vehicle Snap

EDIT: Follow on, once robot speed 8 and 9 completed, 10 appeared in the list of technologies. When I added 10 to the queue, 11 did not appear.
Attachments
screenshot.PNG
screenshot.PNG (273.42 KiB) Viewed 1998 times

Twinsen
Factorio Staff
Factorio Staff
Posts: 1240
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [0.17.21] Infinite research missing when queued

Post by Twinsen »

See also viewtopic.php?f=182&t=68491.
Duplicate?

n_slash_a
Inserter
Inserter
Posts: 31
Joined: Wed Feb 27, 2019 1:05 am
Contact:

Re: [0.17.21] Infinite research missing when queued

Post by n_slash_a »

Twinsen wrote:
Wed Mar 27, 2019 11:17 am
See also viewtopic.php?f=182&t=68491.
Duplicate?
Yes, duplicate of item #1 in that post. Sorry about that.

Oxyd
Former Staff
Former Staff
Posts: 1428
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [Oxyd] [0.17.21] Infinite research missing when queued

Post by Oxyd »

Thanks, should be fixed in 0.17.24.

n_slash_a
Inserter
Inserter
Posts: 31
Joined: Wed Feb 27, 2019 1:05 am
Contact:

Re: [Oxyd] [0.17.21] Infinite research missing when queued

Post by n_slash_a »

Oxyd wrote:
Mon Apr 01, 2019 1:24 pm
Thanks, should be fixed in 0.17.24.
Thank you!!!

Post Reply

Return to “Resolved Problems and Bugs”