[Rseding91] [15.33]Animated objects are jumping very far from start area

This subforum contains all the issues which we already resolved.
Post Reply
kapaer
Burner Inserter
Burner Inserter
Posts: 9
Joined: Wed Jun 07, 2017 10:53 am
Contact:

[Rseding91] [15.33]Animated objects are jumping very far from start area

Post by kapaer » Mon Aug 28, 2017 1:20 am

Animated objects (player, assembling machines etc.) are jumping/shaking very far from start area (>262,144 tiles).
https://youtu.be/71wR30RM0wE

That happens: ABS(posX)>=0x40000 or ABS(posY)>=0x40000 .
It looks like a significant figure of a floating point was exceeded, and an error has occurred to the indication location of the Sprite.
Of course, an ordinary player doesn't go to such far place. :P

Rseding91
Factorio Staff
Factorio Staff
Posts: 9464
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [15.33]Animated objects are jumping very far from start area

Post by Rseding91 » Mon Aug 28, 2017 6:05 am

Can you upload a save file that shows the problem?
If you want to get ahold of me I'm almost always on Discord.

kapaer
Burner Inserter
Burner Inserter
Posts: 9
Joined: Wed Jun 07, 2017 10:53 am
Contact:

Re: [15.33]Animated objects are jumping very far from start area

Post by kapaer » Mon Aug 28, 2017 7:53 am

Rseding91 wrote:Can you upload a save file that shows the problem?
Ok, please show comments of map screen.
https://1drv.ms/u/s!AgBRHXHbvpGfh3AY6eASlLXpEpnU

Rseding91
Factorio Staff
Factorio Staff
Posts: 9464
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [15.33]Animated objects are jumping very far from start area

Post by Rseding91 » Mon Aug 28, 2017 10:14 am

Thanks for the report. It's now fixed for 0.16.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users