[0.11.20] [kovarex] Game returns error directly after being called

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Kayanor
Global Moderator
Global Moderator
Posts: 562
Joined: Sat May 10, 2014 7:20 am
Contact:

[0.11.20] [kovarex] Game returns error directly after being called

Post by Kayanor »

Hello,

a few days ago, someone asked, why his game won't load anymore. He also told me the error message, and today I wanted to start Factorio but then this:
Image

Code: Select all

<unspecified file>(1): '=' character not found in line
This happens when I open the Factorio.lnk in my start menu and even the Factorio.exe in the game files gives that error.

I don't know where it comes from, I just changed the F-mod version manually (editing info.json and renaming the .zip package) to test a new build of the F-mod but before that, everything worked fine.

User avatar
Kayanor
Global Moderator
Global Moderator
Posts: 562
Joined: Sat May 10, 2014 7:20 am
Contact:

Re: [0.11.20] Game returns error directly after being called

Post by Kayanor »

Oh, I just found out that the config.ini (that config file in the config directory) was completely empty.
Deleting it let the game start up normally.

kovarex
Factorio Staff
Factorio Staff
Posts: 8053
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.11.20] Game returns error directly after being called

Post by kovarex »

Yes, the fact that the error didn't contain the file name makes solving these problem harder, so I made a fix, that the error contain information about the file so it should be easier to solve next time.

(Fixed for 0.11.21.)

Post Reply

Return to “Resolved Problems and Bugs”