[Rseding91] [0.17.41] Updating mods doesn't install dependencies

This subforum contains all the issues which we already resolved.
Post Reply
Sergeant_Steve
Inserter
Inserter
Posts: 21
Joined: Tue Jun 28, 2016 10:24 pm
Contact:

[Rseding91] [0.17.41] Updating mods doesn't install dependencies

Post by Sergeant_Steve » Sat May 18, 2019 8:22 pm

So I was looking at mods for an old 0.16 save and decided to update them in game in preparation for a new Modded game, and I noticed after updating them that some were still red because they did not have a hard dependency installed. So I had to manually search for and install all the dependencies that the updated mods now required.

However if Factorio automatically installs a hard dependency alongside a mod when you first install it, then it should apply the same behaviour when updating a mod which also requires a dependency.

wolfram74
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat May 20, 2017 5:05 pm
Contact:

Re: [0.17.41] Updating mods doesn't install dependencies

Post by wolfram74 » Sun May 26, 2019 6:50 pm

I have also encountered this behavior, particularly in updating an old install of LTN.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9864
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.17.41] Updating mods doesn't install dependencies

Post by Rseding91 » Wed Jun 05, 2019 8:29 pm

Thanks for the report. I've added logic to the update mods tab so it will attempt to install new required dependencies when updating mods.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users