[0.10.9] Deconstructing Underground Belts deletion bug

This subforum contains all the issues which we already resolved.
Post Reply
Redominus
Inserter
Inserter
Posts: 46
Joined: Sun May 11, 2014 1:33 am
Contact:

[0.10.9] Deconstructing Underground Belts deletion bug

Post by Redominus » Thu Sep 04, 2014 2:48 pm

When a robot try to deconstruct the entry point of an underground belt with items inside it takes the items inside(all of them) and deconstruct it. The underground belt get erased from existence and only the items inside it get transported. The exit underground belt is deconstructed normally.

Explaining Gif:

http://gfycat.com/GrandUniqueChameleon
Last edited by Redominus on Fri Sep 05, 2014 1:08 am, edited 1 time in total.

Blackence
Fast Inserter
Fast Inserter
Posts: 109
Joined: Thu Jun 05, 2014 4:03 pm
Contact:

Re: Deconstructing Underground Belts deletion bug

Post by Blackence » Thu Sep 04, 2014 11:21 pm

Ah, so that explains what happened at 02:58 in the recent video by FKODGaming for the Hydra Dilemma:
https://www.youtube.com/watch?v=03gkdy_esRg

(Smart Inserters are not a bug, they were all delivered to create blue science packs.)

Rseding91
Factorio Staff
Factorio Staff
Posts: 9856
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.10.9] Deconstructing Underground Belts deletion bug

Post by Rseding91 » Fri Sep 05, 2014 2:48 am

Redominus wrote:When a robot try to deconstruct the entry point of an underground belt with items inside it takes the items inside(all of them) and deconstruct it. The underground belt get erased from existence and only the items inside it get transported. The exit underground belt is deconstructed normally.

Explaining Gif:

http://gfycat.com/GrandUniqueChameleon
I looked into it and actually the issue was worse than that :) only the first item the belt is holding gets picked up (up to a maximum of what the robot can hold). Everything else is erased: all other contents the belt holds + the belt.
If you want to get ahold of me I'm almost always on Discord.

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.10.9] Deconstructing Underground Belts deletion bug

Post by kovarex » Mon Sep 08, 2014 7:21 pm

Thanks to Rseding, the issue is now fixed for 0.10.10

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users