[0.15.10] [kovarex] Boiler doesn't work with electric energy source

This subforum contains all the issues which we already resolved.
Post Reply
GotLag
Filter Inserter
Filter Inserter
Posts: 510
Joined: Sat May 03, 2014 3:32 pm
Contact:

[0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by GotLag » Tue May 16, 2017 10:32 am

As per the 0.15.0 changelog:
Boiler has now dynamically specified energy source (as inserter and similar).
A boiler with an electric energy source won't consume power, it will flash the yellow "unplugged" icon at all times, whether or not it's in range of a power pole. It places no drain on any electrical network it's in range of.

Entity definition used:

Code: Select all

kettle = util.table.deepcopy(data.raw["boiler"]["boiler"])
kettle.name = "electric-boiler"
kettle.minable.result = "electric-boiler"
kettle.energy_source =
{
  type = "electric",
  usage_priority = "secondary-input",
  effectivity = 0.5,
  emissions = 0.1 / 6.5,
}

data:extend(
{
  kettle
})

kovarex
Factorio Staff
Factorio Staff
Posts: 7287
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by kovarex » Tue May 16, 2017 12:01 pm

Thanks for the report, fixed for 0.15.12

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6661
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by bobingabout » Tue May 16, 2017 12:52 pm

I found this a couple of days ago, and didn't report it.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.

Mobius1
Fast Inserter
Fast Inserter
Posts: 185
Joined: Thu Feb 09, 2017 12:05 am
Contact:

Re: [0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by Mobius1 » Fri May 19, 2017 12:55 am

Yay, my mod works now, but meh I gave up that idea since someone else already made an electric version and posted on the modportal anyways.

beaver
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri May 19, 2017 10:37 am
Contact:

Re: [0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by beaver » Fri May 19, 2017 11:35 am

I just registered, and I bought the game recently. I can not understand if in the beta 0.15.12, the steam turbine has been fixed or not, because it does not work for me in the free play, the current indicator flashes, but it should produce it! (Among other things, it does not work even in the normal version of the game). Can anyone explain me better if the bug has to be resolved or if it has been resolved? thank you

GotLag
Filter Inserter
Filter Inserter
Posts: 510
Joined: Sat May 03, 2014 3:32 pm
Contact:

Re: [0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by GotLag » Fri May 19, 2017 11:43 am

This bug has been resolved.

Make sure you have your boilers connected properly, with water coming in the ends, and steam coming out the sides, and make sure you have electrical poles around your steam engines. Here's an example picture: Image

Other than that, the Gameplay Help section is a better place to get answers.

beaver
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri May 19, 2017 10:37 am
Contact:

Re: [0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by beaver » Fri May 19, 2017 12:24 pm

I'm sure I did the right connections because the boiler is running but the turbine always flashes the signal as it appears from the screenshoot. I do not know how to proceed because assembling components seems right.
Attachments
Screenshot_1.jpg
Screenshot_1.jpg (115.52 KiB) Viewed 1710 times

GotLag
Filter Inserter
Filter Inserter
Posts: 510
Joined: Sat May 03, 2014 3:32 pm
Contact:

Re: [0.15.10] [kovarex] Boiler doesn't work with electric energy source

Post by GotLag » Fri May 19, 2017 12:27 pm

You need fuel in the boiler. Also, engines will flash that yellow icon until they are connected to machines that use power, such as miners, inserters or assemblers.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users