Saves destroyed when trying to install msi over gog install.

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
plugwash
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun May 07, 2017 6:48 pm
Contact:

Saves destroyed when trying to install msi over gog install.

Post by plugwash » Sun May 07, 2017 7:11 pm

I initially installed factorio and upgraded to 0.15.2 using the installers from gog.com, but I wanted a newer version so I downloaded the msi from the factorio website.

I told it to install in the same directory the gog installer had used expecting this to replace the program files while preserving my saves. However the result was a disaster, the msi claimed to have installed successfully but no factorio binary was left. Worse all my saves were gone. I tried data recovery software but to no avail.

Loewchen
Global Moderator
Global Moderator
Posts: 5135
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Saves destroyed when trying to install msi over gog install.

Post by Loewchen » Sun May 07, 2017 7:23 pm

Did you check in the directory of the saves if they are really gone? What directory did you expect to find the saves? I can not see how this would have happened.
Moved to technical help.

plugwash
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun May 07, 2017 6:48 pm
Contact:

Re: Saves destroyed when trying to install msi over gog install.

Post by plugwash » Sun May 07, 2017 9:12 pm

I was expecting to find my saves in C:\Users\plugwash\AppData\Roaming\Factorio\saves (which I think is where they were when I was using the gog install but I'm not 100% sure on that) but the directory is empty, I also searched for all .zip files on my c: drive and again did not find any of my factorio saves.

I'm just reporting what I saw, trying to install the msi over the gog install (same directory) resulted in a factorio install with many files (including the main exe) missing and all my factorio saves gone. I am assuming that installing the msi over the gog install made the installer go haywire somehow but I don't know exactly how.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users