[0.12.35] take_screenshot with zoom=0 produces weird output

This subforum contains all the issues which we already resolved.

[0.12.35] take_screenshot with zoom=0 produces weird output

Postby Gandalf » Fri Jun 03, 2016 1:39 am

Like the title says, specifying a 0 value for zoom when taking a screenshot via the lua console produces unexpected output. Here's the full command:
Code: Select all
/c game.take_screenshot{zoom=0}

And here's the result
Screenshot
screenshot.png
screenshot.png (3.51 MiB) Viewed 426 times

It doesn't always happen, sometimes it'll just render a random area of the map (not where the player is standing). It helps to run around or move some other windows around. It looks like the game is just reading whatever it finds in some kind of graphics buffer. At some point I found things in the output that don't even belong to the game (google maps).

Note: I'm running Linux (x64) and I have two monitors (game is maximized on one). Dunno if that matters.

Long story short it's probably best to just error out when a user specifies 0 as a zoom level (I did it by mistake and was confused).
OS: Linux Mint 18.1 x64 | desktop: Awesome 3.5  | CPU: Intel Core i7 960  | RAM: 12GB DDR3  |  graphics: NVidia GeForce GTX 560  |  nvidia driver version: 375.39    (2017-04)
User avatar
Gandalf
Filter Inserter
Filter Inserter
 
Posts: 290
Joined: Fri Dec 19, 2014 10:15 pm

Re: [0.12.35] take_screenshot with zoom=0 produces weird output

Postby Neemys » Fri Jun 03, 2016 7:14 am

Indeed I don"t think the zoom can take 0 as a value. Better output an error.

I test it on windows it just make black screenshot. (Windows 7 64bit, dual screen, 1080x920 (X2), game on fullscreen on one monitor).
Want more space restriction ? Or maybe you want to be forced to use train for other thing than ore and oil ? Try Building Platform Mod !
Neemys
Filter Inserter
Filter Inserter
 
Posts: 378
Joined: Sat Apr 09, 2016 6:16 pm

Re: [0.12.35] take_screenshot with zoom=0 produces weird output

Postby Oxyd » Fri Jun 03, 2016 1:50 pm

Fixed in 0.13.0.
Oxyd
Factorio Staff
Factorio Staff
 
Posts: 959
Joined: Thu May 07, 2015 8:42 am


Return to Resolved Problems and Bugs

Who is online

Users browsing this forum: No registered users and 3 guests