big map, desync problem

Arrange meetings with other people to play MP, announce your servers.

big map, desync problem

Postby antimate » Sun Feb 07, 2016 11:25 am

hey. have played factorio for quite some hours now.
started an map up with a friend with a bobs mod aswell some other mods. in an mods pack i found.
it worked. did some singleplayer on it some further and today when we wanted to play it again. it started up as we are used to. but as my friend got onto my server. we got an desync so he felt off just as he entered.

so what now? we tried to give the sync some more time. up to 1000 ms didn't work (beside help a bit)
then we tried both to get onto the ethernet. so no wifi. didn't improve much eighter.
so as it is for now. we are stuck playing singleplayer. or do it all over, just to get stuck again

my pc is a bit low on RAM (4GB) sins my 8 gigs is borred out at this time. but els with my core i7 2700k, gtx570. i shouldn't have any hardware problems. runs most games at max.

so what now? faster internet? more ram? or give up, sins it's a bad code? is it the mods? something els??? whats your experience???

great game! much fun! good product for a low cost for sure! :) keep it up!
antimate
Burner Inserter
Burner Inserter
 
Posts: 6
Joined: Sun Feb 07, 2016 11:15 am

Re: big map, desync problem

Postby Loewchen » Sun Feb 07, 2016 3:58 pm

Could you upload the complete Desync Report (should be in the archive folder, either in your installation directory or somewhere here: C:/Users/user/AppData/Roaming/Factorio it looks like this:
desync-report-2016-02-03-12-41-22.zip) somewhere publicly accessible like dropbox or googleDrive. Thx.
  • A link to the mod-pack and all mods you have installed additionally would be helpful as well.
  • Is the desync instant after connecting or is there a time-window that you can play together in?
  • Just to make sure: the other player is not cybrox by any chance? (he opened a similar thread)

Some things to try:
  • make sure you removed all unused mods from the mod-folder and don't just deactivate them inside of factorio, deactivating mods is known to cause problems.
  • or better copy the folder of one of the players to the other and the server to make sure they are completely identical.
Greetings, Loewchen
Loewchen
Global Moderator
Global Moderator
 
Posts: 4308
Joined: Wed Jan 07, 2015 5:53 pm

Re: big map, desync problem

Postby antimate » Sun Feb 07, 2016 6:25 pm

i cannot find the repport sadly

the mods is here:
viewtopic.php?f=171&t=18337
Version 0.3.0 on 0.12.20

my computer froze as the map was loading onto my friends computer. and as it was done, my pc froze again, and started to reload the map again and again. between 2-5 time before we had a desync. he never had a chance to move his charractor, but had a chance to move just a few second after the upload of the map was done. before et froze again. totally unplayable els way.

it's not cybrox. :) my friend does not use the forum. he just bought the game to play with me. :)

have 3 mods disabled
-pollution detector
-roadworks
-speedbuttoms

pollution detector and roadworks was disabled as default for some reason. and speedbuttoms i had to disable to play multiplayer.
antimate
Burner Inserter
Burner Inserter
 
Posts: 6
Joined: Sun Feb 07, 2016 11:15 am

Re: big map, desync problem

Postby Loewchen » Sun Feb 07, 2016 8:11 pm

antimate wrote:my computer froze as the map was loading onto my friends computer.

That is completely normal.

Chances are that this is mod related especially since you have some deactivated and not removed, but w/o the report there is nothing to go on sadly.
Greetings, Loewchen
Loewchen
Global Moderator
Global Moderator
 
Posts: 4308
Joined: Wed Jan 07, 2015 5:53 pm

Re: big map, desync problem

Postby judos » Thu Feb 11, 2016 9:45 am

Just to make sure: You have the same version of factorio as your friend?
And are you sure that you disabled exactly the same mods as your friend? Check again that the whole mod list appearing in the game menu is perfectly the same. Also do you have the scenario pack and your friend doesn't ?

If this is all perfect then you might ask in the mod-pack threat whether other people are having the same problem maybe?

If the game itself shows desync problems and will redownload the map there has to be a report saved on your disk somewhere. Maybe search the whole harddrive for it. The folder where factorio is installed and where the data is saved might differ depending on how you installed it (zip extracted vs installed)...

Hope this helps
Cheers
judos
Filter Inserter
Filter Inserter
 
Posts: 254
Joined: Mon Dec 08, 2014 11:17 am

Re: big map, desync problem

Postby antimate » Fri Feb 12, 2016 4:06 pm

we have the same version of factorio yes. 0.12.20
and double chekked the mods. to see if we had the same mods on or not. and all the mods was the same.
could try ask or just wait untill the next season of mods is up.
antimate
Burner Inserter
Burner Inserter
 
Posts: 6
Joined: Sun Feb 07, 2016 11:15 am

Re: big map, desync problem

Postby 09edwarc » Fri Jun 30, 2017 10:06 pm

Similar issue to the above, though I'm not allowed to post links to my desync report yet since this is my first post
Edit: Now that my post has been approved, here is the link: https://www.dropbox.com/sh/hpny9am5cy18 ... swgxa?dl=0
09edwarc
Burner Inserter
Burner Inserter
 
Posts: 5
Joined: Fri Jun 30, 2017 10:01 pm

Re: big map, desync problem

Postby Nexela » Sat Jul 01, 2017 5:50 am

Remove the Axial Tilt mod, it is not MP safe. Additionally for the future please make a new post as your desync/mod pack is not the same as the original one in this post :)
Nexela
Smart Inserter
Smart Inserter
 
Posts: 1746
Joined: Wed May 25, 2016 11:09 am

Re: big map, desync problem

Postby l4m3r » Sat Jul 01, 2017 6:25 am

If it work with previos version of factorio just patch back.. with the newest one i also have desyncs.
l4m3r
Burner Inserter
Burner Inserter
 
Posts: 16
Joined: Sat Jul 18, 2015 11:31 am


Return to Multiplayer

Who is online

Users browsing this forum: No registered users and 3 guests