[0.12.21] Splitters don't stop when deconstructing

This subforum contains all the issues which we already resolved.

[0.12.21] Splitters don't stop when deconstructing

Postby daniel34 » Sat Jan 09, 2016 1:13 pm

If you deconstruct a splitter using construction robots the splitter doesn't stop working, the construction robots instead remove the iron ore first, which leads to a loop.
Expected behavior: The belt and underground belt already stop when deconstructing it, I was expecting the same behavior for the splitter.
Mods: only YARM and EvoGUI, nothing game changing

Image: (fraps really makes the performance go < 10fps in a 60fps game, sorry about that)
Image

This is just the end part of the deconstruction, I ended up with > 10 stacks iron ore in the inventory.

EDIT: Looking at the image again it seems the splitter actually does stop outputting items but is still accepting new items which have to be removed by the robots before deconstruction.
daniel34
Global Moderator
Global Moderator
 
Posts: 2649
Joined: Thu Dec 25, 2014 7:30 am
Location: Austria

Re: [0.12.21] Splitters don't stop when deconstructing

Postby kovarex » Tue Jan 12, 2016 4:00 pm

This is actually also problems with belts or belts to ground, but it can be easily hidden by different logic.

I solved this, by disconnecting all belts when marked for deconstruction, so additional items won't be inserted into it. The change is simple but it could cause some problems, so I fixed it for 0.13 version.
kovarex
Factorio Staff
Factorio Staff
 
Posts: 6261
Joined: Wed Feb 06, 2013 12:00 am
Location: Prague


Return to Resolved Problems and Bugs

Who is online

Users browsing this forum: No registered users and 2 guests