[0.12.11+] Burner inserter refueling itself still not fixed

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Tev
Fast Inserter
Fast Inserter
Posts: 148
Joined: Sun Aug 02, 2015 7:42 pm
Contact:

[0.12.11+] Burner inserter refueling itself still not fixed

Post by Tev »

0.12.11 patchnotes wrote:Burner inserter now grabs fuel for itself even if the target doesn't need it (https://forums.factorio.com/forum/vie ... p?p=111765).
Well I counted on that when feeding turrets with ammo with burner inserters. Didn't work, see screenshot.

I used 0.12.12 then upgraded to 0.12.14, same problem.
I tested both coal and solid fuel.
When trying that quickly in campaign (New hope first mission, 0.12.12) it behaved strangely - first it didn't work (stone furnace fed by belt with iron ore/coal), but when I filled the belt to max and filled furnace with coal then newly placed burner inserter started loading itself and only after that the furnace . . .

Map was started on 0.12.10 (I think, maybe earlier).

Save attached.

EDIT:
+log file
Specs: 5yo Thinkpad, Win7 64bit, Intel Duo 2x 2.0GHz P7370, 4GB RAM, Ati Mobility Radeon 3400
Attachments
factorio-current.log
(4.6 KiB) Downloaded 315 times
rocketBase.zip
(7.45 MiB) Downloaded 166 times
burner inserter bug.jpg
burner inserter bug.jpg (669.94 KiB) Viewed 6082 times

daniel34
Global Moderator
Global Moderator
Posts: 2761
Joined: Thu Dec 25, 2014 7:30 am
Contact:

Re: [0.12.11+] Burner inserter refueling itself still not fixed

Post by daniel34 »

This problem only happens when the fuel is on the far side of the belt, like it is in your example.

The picture on the left shows your setup with an additional turret at the top (the other side of the belt), which seems to work.
The right picture shows the same bug with furnaces: the left furnace works as expected, the right one first loads two iron ore into the furnace and then runs out of energy when trying to load one solid fuel.

Image
quick links: log file | graphical issues | wiki

User avatar
Tev
Fast Inserter
Fast Inserter
Posts: 148
Joined: Sun Aug 02, 2015 7:42 pm
Contact:

Re: [0.12.11+] Burner inserter refueling itself still not fixed

Post by Tev »

Actually I found out it (inserter refueling) works around 20% of time, when I tested it on large scale (finishing up the perimeter defense).
But maybe it worked when only fuel was on the belt. I don't know for sure, but it's possible as some turrets down the line were fed by manually jumpstarted inserters and ammo wasn't placed on belt evenly - my production couldn't keep up :D

EDIT:
"success" rate is definitely higher when fuel is closer to inserters :D
Attachments
burnerinsertersagain.jpg
burnerinsertersagain.jpg (485.69 KiB) Viewed 6037 times

Oxyd
Factorio Staff
Factorio Staff
Posts: 1385
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [0.12.11+] Burner inserter refueling itself still not fixed

Post by Oxyd »

Okay, tweaked for 0.12.16.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: AlternativeFFFF