[0.18.39] Failed to load mod "base": __base__/data.lua:5

This subforum contains all the issues which we already resolved.
Post Reply
san
Burner Inserter
Burner Inserter
Posts: 12
Joined: Sat Apr 06, 2019 11:22 am
Contact:

[0.18.39] Failed to load mod "base": __base__/data.lua:5

Post by san »

After updating from 0.18.38 to 0.18.39 the base mod fails to load

Code: Select all

   0.001 2020-08-01 08:37:29; Factorio 0.18.39 (build 54023, win64, alpha)
   0.002 Operating system: Windows 10 (version 2004) 
   0.002 Program arguments: "R:\spiele\Factorio\bin\x64\factorio.exe" "--wait-to-close" "28572" 
   0.002 Read data path: R:/spiele/Factorio/data
   0.002 Write data path: C:/Users/CastaS.SAN/AppData/Roaming/Factorio [134695/952200MB]
   0.002 Binaries path: R:/spiele/Factorio/bin
   0.016 System info: [CPU:         Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz, 8 cores, RAM: 18604/32705 MB, page: 40983/69569 MB, virtual: 4245/134217727 MB, extended virtual: 0 MB]
   0.017 Display options: [FullScreen: 1] [VSync: 1] [UIScale: custom (125.0%)] [Native DPI: 1] [Screen: 255] [Special: lmw] [Lang: en]
   0.029 Available displays: 2
   0.030  [0]: \\.\DISPLAY19 - NVIDIA GeForce RTX 2080 SUPER {0x05, [0,0], 3840x2160, 32bit, 60Hz}
   0.035  [1]: \\.\DISPLAY20 - NVIDIA GeForce RTX 2080 SUPER {0x01, [-1920,331], 1920x1200, 32bit, 59Hz}
   0.385 [Direct3D11] Display: 0, Output: 0, DisplayAdapter: 0, RenderingAdapter: 0; d3dcompiler_47.dll
   0.639 Initialised Direct3D[0]: NVIDIA GeForce RTX 2080 SUPER; id: 10de-1e81; driver: nvldumdx.dll 27.21.14.5167
   0.639   D3D Feature Level: 11.1, DXGI 1.5+, SwapChain: 3,flip-discard,-,-,-,none
   0.639   [Local Video Memory] Budget: 7242MB, CurrentUsage: 2MB, Reservation: 0/3749MB
   0.639   [Non-Local Vid.Mem.] Budget: 15584MB, CurrentUsage: 0MB, Reservation: 0/7920MB
   0.639   Tiled resources: Tier 2
   0.639   Unified Memory Architecture: No
   0.639   BGR 565 Supported: Yes
   0.639   MaximumFrameLatency: 3, GPUThreadPriority: 0
   0.639 Graphics settings preset: very-high
   0.639   Dedicated video memory size 8010 MB
   0.752 Desktop composition is active.
   0.752 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 100%] [DXT: high-quality] [Color: 32bit]
   0.752                   [Max threads (load/render): 32/8] [Max texture size: 0] [Tex.Stream.: 0] [Rotation quality: normal] [Other: STDCWT] [B:0,C:0,S:100]
   0.876 DSound: Starting _dsound_update thread
   0.876 [Audio] Backend:default; Depth:16, Channel:2, Frequency:44100; MixerQuality:linear
   0.877 DSound: Enter _dsound_update; tid=48364
   1.191 Info ModManager.cpp:253: Found duplicate mod RadarGridGuide, using higher version (2.17.0 > 0.17.0).
   1.391 Data stage cache not used.
   1.394 Loading mod settings aai-industry 0.4.14 (settings.lua)
   1.394 Loading mod settings beltSorter 0.7.0 (settings.lua)
   1.395 Loading mod settings Bottleneck 0.11.4 (settings.lua)
   1.395 Script @__Bottleneck__/settings.lua:131: working - green none
   1.395 Script @__Bottleneck__/settings.lua:131: no_power - red alert
   1.395 Script @__Bottleneck__/settings.lua:131: no_fuel - red alert
   1.395 Script @__Bottleneck__/settings.lua:131: no_recipe - off none
   1.395 Script @__Bottleneck__/settings.lua:131: no_input_fluid - red alert
   1.395 Script @__Bottleneck__/settings.lua:131: no_research_in_progress - white pause small
   1.395 Script @__Bottleneck__/settings.lua:131: no_minable_resources - red stop
   1.395 Script @__Bottleneck__/settings.lua:131: low_input_fluid - yellow alert
   1.395 Script @__Bottleneck__/settings.lua:131: low_power - yellow alert
   1.395 Script @__Bottleneck__/settings.lua:131: disabled_by_control_behavior - white stop small
   1.395 Script @__Bottleneck__/settings.lua:131: disabled_by_script - white stop small
   1.395 Script @__Bottleneck__/settings.lua:131: fluid_ingredient_shortage - red alert
   1.395 Script @__Bottleneck__/settings.lua:131: fluid_production_overload - yellow pause
   1.395 Script @__Bottleneck__/settings.lua:131: item_ingredient_shortage - red alert
   1.395 Script @__Bottleneck__/settings.lua:131: item_production_overload - yellow pause
   1.395 Script @__Bottleneck__/settings.lua:131: marked_for_deconstruction - off none
   1.395 Script @__Bottleneck__/settings.lua:131: missing_required_fluid - red alert
   1.395 Script @__Bottleneck__/settings.lua:131: missing_science_packs - red alert
   1.395 Script @__Bottleneck__/settings.lua:131: waiting_for_source_items - red alert
   1.396 Script @__Bottleneck__/settings.lua:131: waiting_for_space_in_destination - yellow pause
   1.396 Script @__Bottleneck__/settings.lua:131: waiting_to_launch_rocket - off none
   1.396 Loading mod settings Construction_Drones 0.6.8 (settings.lua)
   1.397 Loading mod settings factoryplanner 0.18.46 (settings.lua)
   1.397 Loading mod settings Fill4Me 0.9.4 (settings.lua)
   1.398 Loading mod settings informatron 0.1.8 (settings.lua)
   1.399 Loading mod settings Mining_Drones 0.3.23 (settings.lua)
   1.399 Loading mod settings ModuleInserter 5.0.8 (settings.lua)
   1.400 Loading mod settings Repair_Turret 0.5.5 (settings.lua)
   1.400 Loading mod settings robot_attrition 0.4.4 (settings.lua)
   1.401 Loading mod settings SchallPickupTower 0.18.1 (settings.lua)
   1.402 Loading mod settings SchallRadarAlignment 0.18.2 (settings.lua)
   1.402 Loading mod settings alien-biomes 0.5.5 (settings.lua)
   1.404 Loading mod settings LoaderRedux 1.5.2 (settings.lua)
   1.405 Loading mod settings MultipleUnitTrainControl 0.2.4 (settings.lua)
   1.406 Loading mod settings PickerAtheneum 1.2.2 (settings.lua)
   1.407 Loading mod settings PickerDollies 1.1.1 (settings.lua)
   1.408 Loading mod settings PickerInventoryTools 1.1.6 (settings.lua)
   1.410 Loading mod settings PickerTweaks 2.2.2 (settings.lua)
   1.421 Loading mod settings space-exploration 0.3.100 (settings.lua)
   1.423 Loading mod settings miniloader 1.11.3 (settings.lua)
   1.434 Loading mod settings Transport_Drones 0.7.11 (settings.lua)
   1.441 Loading mod settings beltSorter 0.7.0 (settings-final-fixes.lua)
   1.443 Loading mod settings PickerTweaks 2.2.2 (settings-final-fixes.lua)
   1.455 Loading mod core 0.0.0 (data.lua)
   1.732 Loading mod base 0.18.39 (data.lua)
   1.797 Error ModManager.cpp:1514: Failed to load mod "base": __base__/data.lua:5: __base__/prototypes/entity/demo-entities.lua:13: module prototypes.entity.assemblerpipes not found;  no such file __base__/prototypes/entity/prototypes/entity/assemblerpipes.lua no such file __base__/prototypes/entity/assemblerpipes.lua no such file __core__/lualib/prototypes/entity/assemblerpipes.lua
stack traceback:
	[C]: in function 'require'
	__base__/prototypes/entity/demo-entities.lua:13: in main chunk
	[C]: in function 'require'
	__base__/data.lua:5: in main chunk
stack traceback:
	[C]: in function 'require'
	__base__/data.lua:5: in main chunk
   1.802 Loading mod core 0.0.0 (data.lua)
   2.022 Checksum for core: 2333664729
   2.187 Error ModManager.cpp:1514: Error in assignID: recipe-category with name 'crafting' does not exist.

Source: default (utility-sprites).
   2.407 Initial atlas bitmap size is 16384
   2.408 Created atlas bitmap 2048x528 [icon, not-compressed, mipmap, linear-minification, linear-magnification, linear-mip-level]
   2.409 Atlases were not loaded from disk cache.
   2.470 Texture processor created (2048). GPU accelerated compression Supported: yes, Enabled: yes/yes. Test passed. YCoCgDXT PSNR: 35.83, BC3 PSNR: 33.82
   3.096 Parallel Sprite Loader initialized (threads: 7)
   3.379 Sprites loaded
   3.404 Generated mipmaps (5) for atlas [0] of size 2048x528   
   3.404 Custom mipmaps uploaded.
   3.409 Factorio initialised
   3.458 Mods to disable:Failed to load mods: __base__/data.lua:5: __base__/prototypes/entity/demo-entities.lua:13: module prototypes.entity.assemblerpipes not found;  no such file __base__/prototypes/entity/prototypes/entity/assemblerpipes.lua no such file __base__/prototypes/entity/assemblerpipes.lua no such file __core__/lualib/prototypes/entity/assemblerpipes.lua
stack traceback:
	[C]: in function 'require'
	__base__/prototypes/entity/demo-entities.lua:13: in main chunk
	[C]: in function 'require'
	__base__/data.lua:5: in main chunk
stack traceback:
	[C]: in function 'require'
	__base__/data.lua:5: in main chunk

Mods to be disabled:
Edit: i just checked: the file assemblepipes.lua is indeed missing, as are other non many other non demo* files. this is compared to the downloaded zip version .
Attachments
factorio-previous.log
(16.7 KiB) Downloaded 14 times
factorio-current.log
(7.82 KiB) Downloaded 15 times

rt89
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Aug 01, 2020 7:25 am
Contact:

Re: [0.18.39] Failed to load mod "base": __base__/data.lua:5

Post by rt89 »

Can confirm the bug.
Attachments
factorio-current.log
(4.25 KiB) Downloaded 16 times

posila
Factorio Staff
Factorio Staff
Posts: 5076
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.18.39] Failed to load mod "base": __base__/data.lua:5

Post by posila »

Hello, our deploy bugged out and Windows standalone version of 0.18.39 contains only demo data. Since it is not possible to launch the game in this state, you need to redownload zip/installer. I am sorry for inconvenience.

Post Reply

Return to “Resolved Problems and Bugs”