[MOD] cargo ships: game abort with message "Logic error in rail direction choosing"

This subforum contains all the issues which we already resolved.
Post Reply
slippycheeze
Filter Inserter
Filter Inserter
Posts: 587
Joined: Sun Jun 09, 2019 10:40 pm
Contact:

[MOD] cargo ships: game abort with message "Logic error in rail direction choosing"

Post by slippycheeze »

Reproducible crash to desktop using rail planner with cargo ships mod. Failure mode is a white dialog with "Logic error in rail direction choosing", logs contain a location and nothing else. Save game, logs, dump, and reproduction instructions attached, please enjoy this next rail bug.
Step one: delete some "rails" in the water.
Not certain if this is necessary or not, other than making placing new ones possible, didn't try repro from a save/load with them gone.
1. cargo ships CTD step one.png
1. cargo ships CTD step one.png (1.94 MiB) Viewed 1179 times
Step two: select rails from quickbar and start rail planner.
Not sure if selecting from quickbar is necessary, but there are some really strange behaviours with entity ghosts, construction bots, and straight rails from the mod for me, so didn't bother testing if, eg, pipette the rails up worked.
2. cargo ships CTD step two.png
2. cargo ships CTD step two.png (2.85 MiB) Viewed 1179 times
Step three: use the ghost planner to lay out some rails...
3. cargo ships CTD step three.png
3. cargo ships CTD step three.png (1.85 MiB) Viewed 1179 times
Step four: ...boom. Exit to desktop, do not pass go, do not collect $200.
4. cargo ships CTD step four.png
4. cargo ships CTD step four.png (128.91 KiB) Viewed 1179 times
Attachments
cargo ship rail planner CTD.zip
(7.33 MiB) Downloaded 73 times
factorio-dump-previous.dmp
(758.75 KiB) Downloaded 62 times
factorio-previous.log
(235.35 KiB) Downloaded 60 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 12282
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [MOD] cargo ships: game abort with message "Logic error in rail direction choosing"

Post by Rseding91 »

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”