[0.17.43][minor] GUI debug info (ctrl F6) stuck to guiElement instead of cursor

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
lovely_santa
Filter Inserter
Filter Inserter
Posts: 397
Joined: Sat Feb 18, 2017 9:41 pm
Contact:

[0.17.43][minor] GUI debug info (ctrl F6) stuck to guiElement instead of cursor

Post by lovely_santa »

Hi,

When you click on a slider, the small slider button will move and your new slider value becomes the value at the position you clicked. When you do this with the debug menu (ctrl +F6) open, the debug options get stuck to the slider element, and a new set of debug options appear on your cursor, as shown in the picture below:
screenshot.PNG
screenshot.PNG (1.32 MiB) Viewed 767 times
To reproduce in vanilla:
  • Start a game, open a locomotive and use the color tool, to select a color for your train.
  • Make sure your debug menu (ctrl + F6) is active. When you hover over a guiElement, the info about the gui and the style appear next to your cursor.
  • Click on the slider (not sweep the value) and the debug info is stuck on the slider, and a new set for you will apear on your cursor.
After repeating this process for all the sliders:
screenshot.PNG
screenshot.PNG (682.53 KiB) Viewed 767 times
Kind regards
lovely_santa
You can find all my mods on the mod portal. Also helping on Arch666Angel's mods.
Image

Rseding91
Factorio Staff
Factorio Staff
Posts: 10973
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.43][minor] GUI debug info (ctrl F6) stuck to guiElement instead of cursor

Post by Rseding91 »

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Bing [Bot]