[MOD 0.13.17+] Rampant

Topics and discussion about specific mods
Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by Veden » Wed Mar 20, 2019 2:17 pm

Nedreow wrote:
Wed Mar 20, 2019 12:22 pm
What is the minimal evo for the biters to start attacking?

I have been looking through the code but I can't find it.
BlueTemplar wrote:
Wed Mar 20, 2019 1:43 pm
0% ? (Though it's probably going to be very unlikely for biters to switch to Aggressive mode at 0%...)
0% is correct and as BlueTemplar said unlikely to be attacked.
4% is when raiding starts.

beelzerob
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri Mar 03, 2017 3:34 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by beelzerob » Mon Mar 25, 2019 2:07 am

I'm using Rampant16.42 with Factorio latest stable (16) and with all of Bob's mods. We're playing with the game running on a dedicated server on Linux.

I've gone into the mod settings and set all rail to safe from biters. I set the mod settings before generating the map. We laid out a section of track near a base and it didn't take long before they attacked it. This promises to be really annoying. Did I set up something wrong?

Thanks.

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by Veden » Mon Mar 25, 2019 8:15 pm

beelzerob wrote:
Mon Mar 25, 2019 2:07 am
I'm using Rampant16.42 with Factorio latest stable (16) and with all of Bob's mods. We're playing with the game running on a dedicated server on Linux.

I've gone into the mod settings and set all rail to safe from biters. I set the mod settings before generating the map. We laid out a section of track near a base and it didn't take long before they attacked it. This promises to be really annoying. Did I set up something wrong?

Thanks.
Did you enable the global toggle

Safety: Enable Building Safety

beelzerob
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri Mar 03, 2017 3:34 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by beelzerob » Mon Mar 25, 2019 8:17 pm

I'm fairly certain I did not. I think I saw that and thought it was some kind of overall safety for buildings, which I did not want.

Do I need to set that and then generate a new map?

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by Veden » Mon Mar 25, 2019 9:12 pm

beelzerob wrote:
Mon Mar 25, 2019 8:17 pm
I'm fairly certain I did not. I think I saw that and thought it was some kind of overall safety for buildings, which I did not want.

Do I need to set that and then generate a new map?
no need to make a new map

beelzerob
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri Mar 03, 2017 3:34 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by beelzerob » Tue Mar 26, 2019 12:39 am

That's what's confusing me, though.

The first time they were destroying rails, I searched through the mod settings and found the Map/Safety: make rails safe settings. And on my map (local, not on a server), I tried setting those. I would check the boxes and click Apply. Then go straight back into the Mod Settings, and they were still cleared.

I finally set the boxes in my Options and then created a new map from scratch, and then the boxes were checked.

The same thing is happening now with the Enable Building Safety setting. I check it, and click Apply, and then go right back into the settings and it's still cleared.

Edit: Interesting. I think what I'm seeing is that even if you click Apply, it doesn't actually apply unless you Resume the game. You can't just Apply and then click Mod Settings again or it won't appear changed. That's annoying.

TheTom
Fast Inserter
Fast Inserter
Posts: 161
Joined: Tue Feb 09, 2016 8:33 am
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by TheTom » Thu Mar 28, 2019 7:58 am

And issue, crash on on_nth_tick(5)
RampantCrash.PNG
RampantCrash.PNG (34.31 KiB) Viewed 885 times
Reliable, game exits.

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by Veden » Thu Mar 28, 2019 3:15 pm

TheTom wrote:
Thu Mar 28, 2019 7:58 am
And issue, crash on on_nth_tick(5)

RampantCrash.PNG

Reliable, game exits.
This will be fixed later today. I seem to always forget about NE and Bobs

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.10

Post by Veden » Fri Mar 29, 2019 12:29 am

TheTom wrote:
Thu Mar 28, 2019 7:58 am
And issue, crash on on_nth_tick(5)

RampantCrash.PNG

Reliable, game exits.
This should be fixed in 0.17.13

Vilkra
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Apr 06, 2019 11:16 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.15

Post by Vilkra » Sun Apr 07, 2019 5:29 pm

Hey,

playing on the current experimental version my biters are completely frozen unless I uncheck "disable vanilla ai". If I uncheck all rampant ai options below that, they are still frozen. Am I misunderstanding that rampant is just additions instead of replacements?

Also, expansion is not working. I'm using complete angel bobs.
https://i.imgur.com/LSYTmGy.jpg

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.15

Post by Veden » Sun Apr 07, 2019 5:58 pm

Vilkra wrote:
Sun Apr 07, 2019 5:29 pm
Hey,

playing on the current experimental version my biters are completely frozen unless I uncheck "disable vanilla ai". If I uncheck all rampant ai options below that, they are still frozen. Am I misunderstanding that rampant is just additions instead of replacements?

Also, expansion is not working. I'm using complete angel bobs.
https://i.imgur.com/LSYTmGy.jpg
Was Rampant added to an existing save? Do you have map expansion enabled?

You have very little pollution covering nests. What is your evolution at?

Are you running just angels and bobs and nothing else?

Rampant by default replaces the vanilla AI, but it can also run alongside the vanilla AI.

Vilkra
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Apr 06, 2019 11:16 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.15

Post by Vilkra » Sun Apr 07, 2019 6:39 pm

Forgot to mention resource spawner overhaul. That and bobs, rampant are the only mods that concern enemies.
Rampant was used from the start. I used tree growth mods at the start, so that reduces pollution spread (evo 70%). Anyway, I waited for some time with 64x speed and refreshing map via console I don't see expansion (it's enabled).

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.15

Post by Veden » Sun Apr 07, 2019 6:41 pm

Vilkra wrote:
Sun Apr 07, 2019 6:39 pm
Forgot to mention resource spawner overhaul. That and bobs, rampant are the only mods that concern enemies.
Rampant was used from the start. I used tree growth mods at the start, so that reduces pollution spread (evo 70%). Anyway, I waited for some time with 64x speed and refreshing map via console I don't see expansion (it's enabled).
Do you have a save?

Vilkra
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Apr 06, 2019 11:16 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.15

Post by Vilkra » Sun Apr 07, 2019 6:53 pm

Sure.
Attachments
Factory2.zip
(15.76 MiB) Downloaded 14 times

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.15

Post by Veden » Sun Apr 07, 2019 9:19 pm

Vilkra wrote:
Sun Apr 07, 2019 6:53 pm
Sure.
Only issue I see with your save is the melee biters not killing trees and a new version should be up to fix that.

Otherwise your save seemed fine and had new nests and worm appearing

Vilkra
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Apr 06, 2019 11:16 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.16

Post by Vilkra » Sun Apr 07, 2019 9:25 pm

Hmm, so it's something wrong on my end. Damn I have no idea atm.
Thank you for looking into it.

Veden
Filter Inserter
Filter Inserter
Posts: 267
Joined: Wed Jul 13, 2016 3:54 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.16

Post by Veden » Mon Apr 08, 2019 5:24 am

Vilkra wrote:
Sun Apr 07, 2019 9:25 pm
Hmm, so it's something wrong on my end. Damn I have no idea atm.
Thank you for looking into it.
I did end up finding some issues with the settlers, try 0.17.17 and let me know.

WildBraas
Burner Inserter
Burner Inserter
Posts: 17
Joined: Sat Feb 16, 2019 6:25 am
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.17

Post by WildBraas » Mon Apr 08, 2019 7:02 am

Duplicate from mods portal.
17.17 crash after loading
https://imgur.com/G1EOw4c
Save https://drive.google.com/open?id=1Nbb_U ... R2Ln4t7VyH

ddoarn
Manual Inserter
Manual Inserter
Posts: 4
Joined: Wed Apr 03, 2019 9:42 am
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.17

Post by ddoarn » Mon Apr 08, 2019 9:05 am

WildBraas wrote:
Mon Apr 08, 2019 7:02 am
Duplicate from mods portal.
17.17 crash after loading
Same story.

Vilkra
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Apr 06, 2019 11:16 pm
Contact:

Re: [MOD 0.13.17+] Rampant - 0.17.16

Post by Vilkra » Mon Apr 08, 2019 5:27 pm

Veden wrote:
Mon Apr 08, 2019 5:24 am
Vilkra wrote:
Sun Apr 07, 2019 9:25 pm
Hmm, so it's something wrong on my end. Damn I have no idea atm.
Thank you for looking into it.
I did end up finding some issues with the settlers, try 0.17.17 and let me know.
Now enemies attack, but expansion is extremely slow (notice the clock).

https://i.imgur.com/Sk5O77q.jpg
https://i.imgur.com/akqpV8Z.jpg

This is with default settings.

On a new map I set evolution to 1, 128x speed and can't see any expansion even with ludicrous map settings.
I'll try disabling RSO in a bit. -Nevermind, I must have pollution for them to spread and my factory is dead.

--------------

Another question. What map/mod settings should I use as a beginner angel bobs player (and factorio in general)?
Should I use bob enemies? Seems like it just spawns nigh unkillable damage sponges at the end. Then what about default settings rampant enemies ending up with ~240 health at the end compared to a regular behemoth with 3k. How does that balance out in the end playing with angel bobs?

Post Reply

Return to “Mods”

Who is online

Users browsing this forum: frugal10191