[MOD 0.16] Vehicle Wagon 1.2.5

Topics and discussion about specific mods
User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2283
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.3

Post by steinio » Fri Apr 27, 2018 10:03 pm

Supercheese wrote:I'll add a special case for it in the next update.
Very kindly. Thx.
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.4

Post by Supercheese » Tue May 08, 2018 5:30 pm

Aforementioned special case added in version 1.2.4, now available.

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2283
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.4

Post by steinio » Tue May 08, 2018 5:57 pm

Supercheese wrote:Aforementioned special case added in version 1.2.4, now available.
Thank you.
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

ShinoHarvest
Inserter
Inserter
Posts: 43
Joined: Tue May 08, 2018 3:29 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.4

Post by ShinoHarvest » Wed May 23, 2018 2:02 pm

bug if 2 player try load or unload wagon simultaneously

Error while running event Vehicle Wagon::on_tick (ID 0)
LuaEntity API call when LuaEntity was invalid.
stack traceback:
__Vehicle Wagon__/control.lua:174: in function <__Vehicle Wagon__/control.lua:116>

User avatar
SuperSandro2000
Filter Inserter
Filter Inserter
Posts: 693
Joined: Sun Jan 12, 2014 3:54 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.4

Post by SuperSandro2000 » Sat Jun 02, 2018 7:17 am

When unloading the crawler vehicle from angels on a diagonal tile errors and save game closes.

Error while running event Vehicle Wagon::on_tick (ID 0)
__Vehicle Wagon__/control.lua:210: attempt to index local 'wagon' (a nil value)

immortal_sniper1
Filter Inserter
Filter Inserter
Posts: 561
Joined: Sun Jun 03, 2018 8:54 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.4

Post by immortal_sniper1 » Fri Jun 08, 2018 5:00 pm

sometimes the lifring item dissapears
note: using all PY mods and i was lifting a pickup truck

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.4

Post by Supercheese » Sun Jun 17, 2018 9:51 pm

SuperSandro2000 wrote:When unloading the crawler vehicle from angels on a diagonal tile errors and save game closes.

Error while running event Vehicle Wagon::on_tick (ID 0)
__Vehicle Wagon__/control.lua:210: attempt to index local 'wagon' (a nil value)
I've not had much time for developing my Factorio mods lately, but I incorporated a Pull Request from narc and I stopped the above error from crashing in 1.2.5, freshly released (it now fails gracefully instead).
Try to always have extra rails extended beyond any Vehicle Wagon you're loading or unloading, especially if the rails are diagonal; the crash quoted above occurred when the Vehicle Wagon was at the terminal end of a diagonal rail.

liirge
Manual Inserter
Manual Inserter
Posts: 3
Joined: Mon Jul 16, 2018 9:52 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by liirge » Mon Jul 16, 2018 9:57 am

I think I've found a bug in either this mod or the AAI mod.
I am currently running the AAI mods in conjunction with bobs and angels and I have found a problem when trying to get my car onto a transport wagon.

I am not in the car nor am in the train, but when i have the winch tool in my hand, and I'm in range if I select the car and then the train it says that I cannot load the car whilst there is a passenger on board. There is no passenger on board at all. I have tried emptying both the car and the train, and it makes no difference it still seems to think there is a passenger in the car.

I have not built any of the AAI structures to control vehicles yet or even fiddled with the autonomous vehicle part of that mod yet.


Any idea as to what is going on?

Hyratel
Inserter
Inserter
Posts: 34
Joined: Sun May 15, 2016 10:35 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by Hyratel » Tue Jul 17, 2018 6:33 pm

liirge wrote:I think I've found a bug in either this mod or the AAI mod.
I am currently running the AAI mods in conjunction with bobs and angels and I have found a problem when trying to get my car onto a transport wagon.

I am not in the car nor am in the train, but when i have the winch tool in my hand, and I'm in range if I select the car and then the train it says that I cannot load the car whilst there is a passenger on board. There is no passenger on board at all. I have tried emptying both the car and the train, and it makes no difference it still seems to think there is a passenger in the car.

I have not built any of the AAI structures to control vehicles yet or even fiddled with the autonomous vehicle part of that mod yet.


Any idea as to what is going on?
if the vehicle has In-use colors, you might need to turn it off completely - either get in or use the Vehicle Remote and click the [power logo] button till it turns Red to disable all Autonomous features. if this doesn't work, then it's something else going on.

jokru
Burner Inserter
Burner Inserter
Posts: 11
Joined: Sun May 13, 2018 10:34 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by jokru » Sun Aug 26, 2018 1:49 pm

Is it intentional that the wagon cannot exceed speeds of about 372,6 km/h with nuclear fuel?
It's really annoying to have to go almost half as slow as I could because I want my vehicle(s) with me :(

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by Supercheese » Tue Aug 28, 2018 4:30 am

jokru wrote:Is it intentional that the wagon cannot exceed speeds of about 372,6 km/h with nuclear fuel?
It's really annoying to have to go almost half as slow as I could because I want my vehicle(s) with me :(
Vehicle wagons should have exactly the same speed properties as vanilla cargo wagons, since the code simply copies its baseline data from vanilla, and does not touch the maximum speed property.

jokru
Burner Inserter
Burner Inserter
Posts: 11
Joined: Sun May 13, 2018 10:34 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by jokru » Fri Aug 31, 2018 6:09 pm

Supercheese wrote:
jokru wrote:Is it intentional that the wagon cannot exceed speeds of about 372,6 km/h with nuclear fuel?
It's really annoying to have to go almost half as slow as I could because I want my vehicle(s) with me :(
Vehicle wagons should have exactly the same speed properties as vanilla cargo wagons, since the code simply copies its baseline data from vanilla, and does not touch the maximum speed property.
How could I make it copy a mod items properties instead?
Nvm, I just added a max speed multiplier to the wagons, that seems to work.
Now do you know how I could edit the existing artillery wagon (as it has the same issue)? I'd rather not replace it fully.

HammerPiano
Fast Inserter
Fast Inserter
Posts: 228
Joined: Thu Dec 31, 2015 7:36 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by HammerPiano » Sat Jan 19, 2019 7:45 pm

Hi,
I found a bug, where the winch can disappear sometimes.
Steps to reproduce:
1. fill inventory so there is no more space in main inventory
2. try to use the winch (load/unload)
3. Winch will disappear

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2283
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by steinio » Sat Jan 19, 2019 7:46 pm

HammerPiano wrote:
Sat Jan 19, 2019 7:45 pm
Hi,
I found a bug, where the winch can disappear sometimes.
Steps to reproduce:
1. fill inventory so there is no more space in main inventory
2. try to use the winch (load/unload)
3. Winch will disappear
It drops to the ground.
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

MisterFister
Long Handed Inserter
Long Handed Inserter
Posts: 73
Joined: Tue Jun 27, 2017 1:12 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by MisterFister » Sun Mar 03, 2019 9:04 am

Is this mod actively supported? Should we anticipate v0.17 compatibility in the future?

brokenshakles
Inserter
Inserter
Posts: 31
Joined: Fri Oct 30, 2015 2:52 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by brokenshakles » Tue Mar 05, 2019 9:20 pm

Earendel has not yet completed the AAI 0.17 update, considering this is dependent on that, you will have to wait for the prerequisite.

dgw
Fast Inserter
Fast Inserter
Posts: 189
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by dgw » Tue Mar 05, 2019 9:24 pm

brokenshakles wrote:
Tue Mar 05, 2019 9:20 pm
Earendel has not yet completed the AAI 0.17 update, considering this is dependent on that, you will have to wait for the prerequisite.
This is incorrect.

Vehicle Wagon works with AAI, but does not require it. (Source: I do not have AAI in my 0.16 map, but Vehicle Wagon is installed and works just fine.)

brokenshakles
Inserter
Inserter
Posts: 31
Joined: Fri Oct 30, 2015 2:52 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by brokenshakles » Tue Mar 05, 2019 10:50 pm

Forgive me, I thought it was a strict dep. I stand corrected.

julius1701
Inserter
Inserter
Posts: 21
Joined: Sun Dec 17, 2017 8:33 pm
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by julius1701 » Fri Mar 08, 2019 7:31 pm

I wrote an quick update for 0.17. It is working but for some reason it unequibs the winch after clicking the car. You must have 2 winches in your inventory.
Attachments
Vehicle Wagon_1.2.6.zip
(7.99 MiB) Downloaded 33 times

robot256
Long Handed Inserter
Long Handed Inserter
Posts: 63
Joined: Sun Mar 17, 2019 1:52 am
Contact:

Re: [MOD 0.16] Vehicle Wagon 1.2.5

Post by robot256 » Sun Mar 31, 2019 2:18 pm

Looks like this code was posted on the Mod Portal as Vehicle Wagon 2 by Artanis_Mattias, is that you julius1701? There are some major bugs left that I'd like to help sort out, since the mod's operation is very similar to my Multiple Unit Train Control mod. But where should we host the source and where should we post the results on the Mod Portal? Has anyone heard from SuperCheese lately? I know the license is MIT, but I don't want to make a yet another fork if I can help it.

Edit: Just noticed he was active on GitHub a month ago. julius1701, you might send your update as a pull request to kick things off.

Post Reply

Return to “Mods”

Who is online

Users browsing this forum: Dudy99, san