thumbnail.png not showing if the mod file is zipped and placed in the mod directory

This subforum contains all the issues which we already resolved.
Post Reply
themightygugi
Burner Inserter
Burner Inserter
Posts: 13
Joined: Sat Nov 28, 2015 11:08 am
Contact:

thumbnail.png not showing if the mod file is zipped and placed in the mod directory

Post by themightygugi » Wed Feb 27, 2019 8:26 am

When upgrading my mod to the new 0.17 standard, I placed a file called thumbnail.png in the root of my mod zip file.

If the file is placed in the mod folder, the thumbnail.png does not show when browsing the mod ingame.

If the file is UNPACKED and placed in the mod folder, the thumbnail.png shows correctly.

See more in the attached image. I have also attached the mod zip file.


Steps to reproduce is:

1. Place the mod zip file in the mod folder
2. load the game and see the thumbnail is not showing



Workaround:

1. unzip the mod into the mod folder

2. load the game and see that the thumbnail is showing correctly
Thumbnail png in mods are not unpacked.png
Thumbnail png in mods are not unpacked.png (98.64 KiB) Viewed 361 times
Attachments
themightygugi_alwaysday_1.17.0.zip
(32.55 KiB) Downloaded 22 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9975
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: thumbnail.png not showing if the mod file is zipped and placed in the mod directory

Post by Rseding91 » Wed Feb 27, 2019 8:40 am

Thanks for the report. It's now fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users