[MOD 0.17.x] Natural Evolution - All things Alien!

Topics and discussion about specific mods
TheBrain0110
Inserter
Inserter
Posts: 29
Joined: Fri Dec 22, 2017 4:43 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheBrain0110 » Mon Aug 20, 2018 5:26 am

After playing a while more and paying closer attention to the groups on the map, I can confirm that there is expansion taking place (Although it appears more like one new group every hour almost, instead of every 10 mins as I had it set...), but only worms appear, no spawners.

Now I'm just not sure whether to report the bug here or to Rampant or something else...

foodfactorio
Filter Inserter
Filter Inserter
Posts: 445
Joined: Tue Jun 20, 2017 1:56 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by foodfactorio » Wed Sep 05, 2018 2:13 am

hi, i was looking at the starting page of this thread, but some images stopped working.
if you get a chance to change your 1st post, maybe changing postimage.org into .cc will fix the images as they seem to have changed servers.
(also me from the mod portal - im not dustine lol) = https://mods.factorio.com/mods/Dustine/ ... ssion/9108
my 1st Mod Idea :) viewtopic.php?f=33&t=50256

Astree
Manual Inserter
Manual Inserter
Posts: 4
Joined: Tue Jul 24, 2018 2:32 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Astree » Sun Oct 07, 2018 12:29 pm

Strange spam spawn of lvl 6 speedy biters : https://steamuserimages-a.akamaihd.net/ ... 393E8CBD1/

It's right in the middle of this screenshot, so quite far from anything : https://steamuserimages-a.akamaihd.net/ ... F0404CAD8/

They're all moving, trying to get oversees : https://steamuserimages-a.akamaihd.net/ ... 67D463C10/

I believe it's why I get a lot of lag, and a very long time on each save. Going to wipe them all to see if it helps on lag. Making a save of the game if needed.

Edit : I killed all of them, I'm back to 60 FPS :-)

empcris
Manual Inserter
Manual Inserter
Posts: 2
Joined: Tue Jun 28, 2016 3:30 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by empcris » Wed Oct 10, 2018 8:05 pm

I had the same problem, a lot of lag, fps went down to 29, I removed natural evolution enemies, fps returned to 60

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1350
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Tue Oct 16, 2018 5:21 pm

empcris wrote:
Wed Oct 10, 2018 8:05 pm
I had the same problem, a lot of lag, fps went down to 29, I removed natural evolution enemies, fps returned to 60
Well, the mod does add a lot more enemies.
Try using "Thumpers" From NE Buildings, to call them to you, this should prevent them from forming huge groups that just sit there.

donkeystealing
Burner Inserter
Burner Inserter
Posts: 13
Joined: Mon Mar 21, 2016 11:40 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by donkeystealing » Mon Oct 22, 2018 5:45 pm

What kind of settings do I have to use for aggressive expansion? Nearly every new run I've done with Bobs, RSO, Rampant, FARL, Robot Army and expansion is simply too low. I've played between 3-10 hours several runs, and I've double-checked that expansion is enabled every time (biters do expand sometimes). At most I've gotten to 30% evolution, give or take.
Min cooldown: 4min & max cooldown: 20min. There are a lot of large biter bases on each map. There are plenty of green expansion-candidate-chunks around (haven't seen one blinking in a long time though, if that's still a thing?) Difficulty setting: 2 & "Can NE expansion turn on Enemy Expansion: yes".

Evolution state is almost always on peaceful, sometimes it's awakening. I'm sorry I already asked this question itt before and I looked at your RSO test posts, but I'm not sure where it's going wrong in my Factorio. Any settings I have to tweak, enable/disable?

orzelek
Smart Inserter
Smart Inserter
Posts: 3550
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by orzelek » Mon Oct 22, 2018 9:09 pm

donkeystealing wrote:
Mon Oct 22, 2018 5:45 pm
What kind of settings do I have to use for aggressive expansion? Nearly every new run I've done with Bobs, RSO, Rampant, FARL, Robot Army and expansion is simply too low. I've played between 3-10 hours several runs, and I've double-checked that expansion is enabled every time (biters do expand sometimes). At most I've gotten to 30% evolution, give or take.
Min cooldown: 4min & max cooldown: 20min. There are a lot of large biter bases on each map. There are plenty of green expansion-candidate-chunks around (haven't seen one blinking in a long time though, if that's still a thing?) Difficulty setting: 2 & "Can NE expansion turn on Enemy Expansion: yes".

Evolution state is almost always on peaceful, sometimes it's awakening. I'm sorry I already asked this question itt before and I looked at your RSO test posts, but I'm not sure where it's going wrong in my Factorio. Any settings I have to tweak, enable/disable?
It might be a known effect of RSO - making bases more rare will cause expansion to go all around the place so they expand less in your base direction. It can help setting base chance in RSO settings to 1 to make more of them.

Bilka
Factorio Staff
Factorio Staff
Posts: 1740
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Bilka » Wed Jan 09, 2019 9:06 pm

You are conditionally requiring files based on mod settings.
Image
Image

This changes the CRC which breaks multiplayer:
Image

These places tell you to NOT DO THIS:
The first existing documentation of mod settings: viewtopic.php?p=207275
The wiki which is a more complete documentation: https://wiki.factorio.com/Tutorial:Mod_settings#Tips

Please fix your mod. Thank you.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1350
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Thu Jan 10, 2019 7:28 pm

Thanks for letting me know Bilka,
I've made the changes.

Nerchio
Burner Inserter
Burner Inserter
Posts: 8
Joined: Fri Apr 14, 2017 8:52 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Nerchio » Sun Jan 20, 2019 6:04 pm

Hello do you have any idea why biters are 'turned off'? I started playing with NE and Rampant AI and now turned off Rampant and used a command to kill all biters but they just spawn and they are not doing anything. There were a few attacks before but at some point they stopped moving and I started investigating.

https://imgur.com/a/Cwe2e2C

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1350
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Tue Jan 22, 2019 4:38 pm

Nerchio wrote:
Sun Jan 20, 2019 6:04 pm
Hello do you have any idea why biters are 'turned off'? I started playing with NE and Rampant AI and now turned off Rampant and used a command to kill all biters but they just spawn and they are not doing anything. There were a few attacks before but at some point they stopped moving and I started investigating.

https://imgur.com/a/Cwe2e2C
Hmm, I'm not sure.
That looks like there is no pollution by that nest. I know Rampant does a lot to biters and not sure how removing it mid game could affect stuff.
I'm pretty sure NE does nothing to "turn off" biters :)
Maybe they will start up once you get near or something.

Porter65
Long Handed Inserter
Long Handed Inserter
Posts: 78
Joined: Sun Mar 06, 2016 10:32 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Porter65 » Sun Mar 31, 2019 4:19 pm

Sorry to say that for me too, the mod was killing FPS. This was fairly early in the game, and I have an Intel i7 with 32 Gigs of RAM and a very decent CGU.

Steave
Burner Inserter
Burner Inserter
Posts: 8
Joined: Tue Jul 25, 2017 2:50 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Steave » Sun Apr 14, 2019 12:07 pm

Copying this from the Rampant mod page. We originally thought it was theirs since we thought the "fast biters" were from there, but as he points out, his fast biters do not have that name in game.
Image
Image
Image
Well, this doesn't seem right.
I'm not 100% sure if this is base Factorio or Rampant, but I strongly suspect it's Rampant since it's only happening with the fast biter faction from the mod.
The fast biter 2s in the screenshot are duplicating at a massive rate (not getting reinforcement from home or anything, duplicating on the spot), and getting trough the walls even before they destroy them. They were moving too fast to tell for sure, but our suspicion is that they got trough thanks to the duplicated biters spawning with an offset, and that offset sometimes being inside the wall.
For obvious reasons, it's unplayable atm with that kind of spawns. We've tried disabling the "enable the swarm" setting, to see if the collision changes had anything to do with it, but that did not help.

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1350
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Sun Apr 14, 2019 1:27 pm

Steave wrote:
Sun Apr 14, 2019 12:07 pm
Copying this from the Rampant mod page. We originally thought it was theirs since we thought the "fast biters" were from there, but as he points out, his fast biters do not have that name in game.
Image
Image
Image
Well, this doesn't seem right.
I'm not 100% sure if this is base Factorio or Rampant, but I strongly suspect it's Rampant since it's only happening with the fast biter faction from the mod.
The fast biter 2s in the screenshot are duplicating at a massive rate (not getting reinforcement from home or anything, duplicating on the spot), and getting trough the walls even before they destroy them. They were moving too fast to tell for sure, but our suspicion is that they got trough thanks to the duplicated biters spawning with an offset, and that offset sometimes being inside the wall.
For obvious reasons, it's unplayable atm with that kind of spawns. We've tried disabling the "enable the swarm" setting, to see if the collision changes had anything to do with it, but that did not help.
Could I get a save to help me investigate?
I think it’s the unit launching spitters that are attacking something and spawning all the units.

T-Blade
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun Apr 14, 2019 11:18 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by T-Blade » Sun Apr 14, 2019 1:33 pm

Hey TheSAguy,

i am the one hosting this server, and have made all files available for you here:

http://bladeinc.be/downloads/overrun_pack.rar

To verify i am part of this, you can follow up the original here:

viewtopic.php?f=190&t=31445&start=480

My pack is about 1.2GB but includes all mods we are using, the mod config file and the save games that were used.

Also not sure if it matters, we use a server and the lastest factorio .17.31 + all mods up to date

The "MPserv" load game should give you the game about 5 minutes before this happened, But if you go a bit south-West there is a massive army already waiting for you. It was that army that destroyed us after about 5-10 minutes. This was also not the first time. We had a massive overrun that almost wiped us out before but barley managed to survive. this one was final though. Spawning is not even possible :D

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1350
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Sun Apr 14, 2019 1:37 pm

T-Blade wrote:
Sun Apr 14, 2019 1:33 pm
Hey TheSAguy,

i am the one hosting this server, and have made all files available for you here:

http://bladeinc.be/downloads/overrun_pack.rar

To verify i am part of this, you can follow up the original here:

viewtopic.php?f=190&t=31445&start=480

My pack is about 1.2GB but includes all mods we are using, the mod config file and the save games that were used.

Also not sure if it matters, we use a server and the lastest factorio .17.31 + all mods up to date

The "MPserv" load game should give you the game about 5 minutes before this happened, But if you go a bit south-West there is a massive army already waiting for you. It was that army that destroyed us after about 5-10 minutes. This was also not the first time. We had a massive overrun that almost wiped us out before but barley managed to survive. this one was final though. Spawning is not even possible :D
The Issue is with NE Enemies.
You have a bunch of Green Spitters. (Unit Launchers) attacking walls and thus creating hordes of units.
Seeing what can be done...

T-Blade
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun Apr 14, 2019 11:18 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by T-Blade » Sun Apr 14, 2019 2:27 pm

i can tell you in that case that the launcher units are OP :) might need some changes / modifications there.
Depending on when you reply i think i will just have to disable the green spawners i assume. Unless you find a good solution (i like the fast biter type, but not when a pack of 20 becomes 1000 in a matter of 1 minute).

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1350
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Mon Apr 15, 2019 4:51 pm

T-Blade wrote:
Sun Apr 14, 2019 2:27 pm
i can tell you in that case that the launcher units are OP :) might need some changes / modifications there.
Depending on when you reply i think i will just have to disable the green spawners i assume. Unless you find a good solution (i like the fast biter type, but not when a pack of 20 becomes 1000 in a matter of 1 minute).
I just released version 0.17.9.
Added two safety measures for the unit launcher.
1 - Launched units will die after some time.
2 - Won't create new units if there are 20 or more already in the immediate area.

Hope this helps :)

Steave
Burner Inserter
Burner Inserter
Posts: 8
Joined: Tue Jul 25, 2017 2:50 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Steave » Mon Apr 15, 2019 7:15 pm

TheSAguy wrote:
Mon Apr 15, 2019 4:51 pm
T-Blade wrote:
Sun Apr 14, 2019 2:27 pm
i can tell you in that case that the launcher units are OP :) might need some changes / modifications there.
Depending on when you reply i think i will just have to disable the green spawners i assume. Unless you find a good solution (i like the fast biter type, but not when a pack of 20 becomes 1000 in a matter of 1 minute).
I just released version 0.17.9.
Added two safety measures for the unit launcher.
1 - Launched units will die after some time.
2 - Won't create new units if there are 20 or more already in the immediate area.

Hope this helps :)
Thanks, we'll try again with that :)

mrvn
Smart Inserter
Smart Inserter
Posts: 3112
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by mrvn » Sun Apr 21, 2019 8:35 pm

TheSAguy wrote:
Mon Apr 15, 2019 4:51 pm
T-Blade wrote:
Sun Apr 14, 2019 2:27 pm
i can tell you in that case that the launcher units are OP :) might need some changes / modifications there.
Depending on when you reply i think i will just have to disable the green spawners i assume. Unless you find a good solution (i like the fast biter type, but not when a pack of 20 becomes 1000 in a matter of 1 minute).
I just released version 0.17.9.
Added two safety measures for the unit launcher.
1 - Launched units will die after some time.
2 - Won't create new units if there are 20 or more already in the immediate area.

Hope this helps :)
20 in total or 20 from the same unit launcher? Because 20 total would serious limit groups of unit launchers.

Post Reply

Return to “Mods”

Who is online

Users browsing this forum: Bing [Bot]