[0.12.27] Behavior of LuaPlayer.game_view_settings

This subforum contains all the issues which we already resolved.
Post Reply
daniel34
Global Moderator
Global Moderator
Posts: 2761
Joined: Thu Dec 25, 2014 7:30 am
Contact:

[0.12.27] Behavior of LuaPlayer.game_view_settings

Post by daniel34 »

I don't know if these are errors in the game or in the documentation, but

(1) trying to read showentityinfo gives the error LuaStruct::luaIndex: unknown path showentityinfo

(2) trying to set showentityinfo to true or false will disable showentityinfo (the alt-mode)

(3) The other parameters (showcontrollergui, showminimap, showresearchinfo, showalertgui, updateentityselection) work as described, but will also disable the overlay icons (alt-mode) when set to true or false.
quick links: log file | graphical issues | wiki

Rseding91
Factorio Staff
Factorio Staff
Posts: 12231
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.12.27] Behavior of LuaPlayer.game_view_settings

Post by Rseding91 »

Thanks for the report. All of those issues are now fixed for the next version.
If you want to get ahold of me I'm almost always on Discord.

Supercheese
Filter Inserter
Filter Inserter
Posts: 841
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [0.12.27] Behavior of LuaPlayer.game_view_settings

Post by Supercheese »

Rseding91 wrote:Thanks for the report. All of those issues are now fixed for 0.12.27.
Uhh, do you mean 0.12.28...? ;)

Rseding91
Factorio Staff
Factorio Staff
Posts: 12231
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.12.27] Behavior of LuaPlayer.game_view_settings

Post by Rseding91 »

Supercheese wrote:
Rseding91 wrote:Thanks for the report. All of those issues are now fixed for 0.12.27.
Uhh, do you mean 0.12.28...? ;)
yes :P
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”