[0.17.79] High latency when friend joins my game, and vice versa

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri May 22, 2020 12:05 pm

[0.17.79] High latency when friend joins my game, and vice versa

Post by Blazzok »

So this problem only started 2 days ago, before that we had no issues at all. Two friends and myself have been playing a map together, with two of us living in South Africa (SA) and one in Australia. One of us in SA will usually host the saved game and the other two will join and everything would be fine, and of course the guy in Australia would have some higher latency (around 40 to 50 ticks), but it would be playable.

Then all of a sudden, 2 days ago, if either me or my other friend in SA (KeizerSoze in the attached logs) host the map, the other one would have horrible latency (in-game tick counter seems to max out at 254) which renders it unplayable. We tried hosting a different map, same story. We tried a new map, also the same. Both of our UPS/FPS remained at 60. We both ran speed tests and both our connections seemed to be working without issues. We then both searched for the issue all over the place, but couldn't find a similar problem for other people, where they played together and it was fine initially and then got bad all of a sudden. We also decided to join a random, publicly hosted game. When we did that, we both had normal latency and no issues at all.

Today we did some more testing. First Keizer hosted the game and I joined, and I had high latency (254+ ticks). Our friend from Australia (Kopertoon in the attached logs) then joined and had no problems, his latency was about normal (between 50 to 60 ticks). We quit, and then I hosted the same map. Kopertoon joined my game and his latency was fine (lower than normal actually, around 42), but when Keizer joined his latency was high (254+) and unplayable. In both instances Kopertoon could play on, his game was not being affected.
We then had Kopertoon host the game, and we both joined him. Our latencies were both normal (around the 40-ish mark) and we could play the game fine and the latency never shot up to 250.
I hosted again, Kopertoon joined my game and had normal latency, and Keizer swapped to another internet connection (swapped to his cellphone's mobile internet instead of his fibre) and still had the same issue with very high latency.

We didn't change hosting settings at all, we both did multiple router restarts. I also tried to host a dedicated server on my PC, and Keizer then joined the dedicated server and still had the high latency. I made sure that the game is allowed through the firewall, etc. I also forwarded the port on my router, just in case, but that also didn't help. I removed it again after doing the test.

So we are kind of out of ideas at the moment, because we thought it was one of our internet connections being iffy, but even swapping to another source of internet didn't resolve the issue.

We don't play with any mods. The previous.log file was the last try for all 3 of us to play together. The current.log file was the last game only Kopertoon and myself played, and had no issues at all. The attached map is the one we play together, but as mentioned previously, we tried different maps as well as a completely new map.

Edit1: Keizer and me tried one more time, with the same result of crazy high latency. I have added the log file for this last attempt as well (last.log). I have also added a screenshot from his side with the "debug" info visible and the latency and stuff top right.

Edit2: We both updated to the latest version of the game (0.18.26) just to try that, but it also didn't work. We still had the same problem.
Factorio Screenshot Host2.png
Factorio Screenshot Host2.png (6.46 MiB) Viewed 106 times
(20.51 KiB) Downloaded 6 times
(11.26 MiB) Downloaded 9 times
(25.18 KiB) Downloaded 7 times
(14.74 KiB) Downloaded 8 times

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users