[kovarex] [0.17.56] Crash on loading save, train signal issue

This subforum contains all the issues which we already resolved.
Post Reply
scrouds
Manual Inserter
Manual Inserter
Posts: 1
Joined: Thu Jul 11, 2019 11:06 pm
Contact:

[kovarex] [0.17.56] Crash on loading save, train signal issue

Post by scrouds » Thu Jul 11, 2019 11:17 pm

Just updated game and game crashes on load.

Save file: https://we.tl/t-mHU0k7NFfM

No mods.
Attachments
factorio-dump-current.dmp
(847.73 KiB) Downloaded 5 times
factorio-current.log
(7.28 KiB) Downloaded 10 times

bnvy
Burner Inserter
Burner Inserter
Posts: 6
Joined: Fri Dec 05, 2014 5:50 pm
Contact:

Re: [0.17.56] Crash on loading save, train signal issue

Post by bnvy » Fri Jul 12, 2019 1:30 am

Here's another one, "Error RailSignalBase.cpp:361: outgoingBlock->getInboundSignals().count(const_cast<RailSignalBase*>(this)) was not true".

Tried to load a save, see your error dialog offering to open the log folder, cancel that and then the game exits. No dump for me, but log and save attached. No mods at this time. I did have a small set of QoL mods enabled last night, but nothing that should matter. I have *not* been playing with any of the recent rail signal anomalies, however this is test world with a lot of garbage laying around (I would like to recover it...).
Attachments
sandbox later.zip
(24.2 MiB) Downloaded 3 times
factorio-current.log
(6.45 KiB) Downloaded 2 times

User avatar
Manny_White
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Jul 12, 2019 4:03 am
Contact:

Re: [0.17.56] Crash on loading save, train signal issue

Post by Manny_White » Fri Jul 12, 2019 4:29 am

I'm getting the same error with 0.17.56 only with a save file generated from the more recent updates. Any saves from the stable version convert OK. Thinking it was a complex train signal issue I loaded up another, older experimental save I have with a complex signal and schedule setup. No error. Saving, exiting, reloading the working save does not error. It seems to be an issue with a more recent version of the game. Perhaps it's specific to the rail signal fixes?

Error in log:
Error RailSignalBase.cpp:363: incomingBlock->getOutboundSignals().count(const_cast<RailSignalBase*>(this)) was not true

EDIT:
I am not using, nor have I ever used, any mods.
Reverting to 0.17.55 allows the save to load. Still crashes after saving in 0.17.55, updating back to 0.17.56, and loading the save.
Attachments
factorio-dump-current.dmp
(693.29 KiB) Downloaded 2 times
0.17.x NG.zip
(38.08 MiB) Downloaded 4 times
factorio-current.log
(7.49 KiB) Downloaded 3 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.56] Crash on loading save, train signal issue

Post by kovarex » Fri Jul 12, 2019 2:29 pm

Thanks for the report, this was another corner case I didn't thought about. (I added that to the tests)

Fixed for the next release.
Attachments
another-cornercase.jpg
another-cornercase.jpg (393.68 KiB) Viewed 527 times

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users