Version 0.11.9

Information about releases and roadmap.
kovarex
Factorio Staff
Factorio Staff
Posts: 8058
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Version 0.11.9

Post by kovarex »

The 0.11.7 and 0.11.8 was quite disastrous, lets hope we are finally getting over the worst.
  • Features
  • Optimisations
    • Reduced the cpu load caused by big count of inserters loading/unloading transport belts.
      Can reduce the update time on big factories by about 30%.
  • Bugfixes
    • Fixed the save corruption related to saving the game while having electric-pole selected.
    • Fixed possible crashes and save game corruption when saving while having blueprint in cursor.
    • Fixed the crash/desync problems when someone died in the multiplayer game.
    • Added engine as prerequisite for railway, as the diesel locomotive needs engine to be built.
      Added electric engine technology as prerequisite for power armor technology.
      Added Speed module 3 and Efficiency module 3 technologies as prerequisite for power armor 2 technology.
    • Fixed desync issue related to mods adding inputs/outputs to assembling machines in a way, that
      input/output definition order is mixed.
    • Fixed the crash when you kill your car/tank using the car/tank weapon.
    • Fixed the crash (trying to make chunk at unreasonable position) related to creation two members
      of unit group on the exact same position (mod related).
    • Fixed issues with the train schedule gui. (https://forums.factorio.com/forum/vie ... php?t=7790).
    • Fixed the text selection issues (Going back and forth while selecting the text reset the selection).
    • Fixed the problems related to blueprint selection cancellation by pressing q (to get the blueprint out of the cursor).
    • Fixed the crash related to item on the ground marked for deconstruction getting on transport belt -> underground
      belt and deconstructed underground. Items marked for deconstruction can't be moved by belts anymore.
    • Fixed the crash in map editor when removing currently opened entity.
    • Fixed that the First Steps script of level 03 could be broken by destroying one of the boilers or mining
      drill or steam engine in the tutorial part of the level.
    • Fixed the cluttered map from car/tank when it crashes something.
    • Green coral is affected by poison capsule (breaths-air flag is included).
    • The smart inserter is waken up (alarmed), when the circuit wire is connected.
    • Fixed that it wasn't possible to build on the top of the grenade crater.
    • Moved the picture of spawner to the left to match the collision bounding box.
    • Fixed crashes (mainly while saving) related to train with lost path trying to unlock gates on the path.
    • Solved that inventory was not sorted after crafting in god mode.
    • Solved that inventory was not sorted after another stack of items was moved to cursor when building, or
      when ammo stack was moved to gun slots from inventory when the previous slot was depleted.
    • Fixed that transport belts were still animating and emitting sounds even when they were stopped and prepared
      for deconstruction.
    • Fixed that construction robots, when deconstructing splitters/belts to ground didn't remove the items on these
      the same way as on regular transport belts first. The result was random items leftovers after deconstruction.
  • Scripting
    • Fixed various problems in the lua blueprint interface.
    • All the entity specific settings that can be specified in blueprint creation are now
      specifiable also at entity creation like game.createentity{name="wooden-chest", bar=5, position = {0, 0}}
    • Fixed the problems related to setting the blueprint icons from script.
  • Modding
    • Disabled adding empty string as prerequisite of technology.
    • Fixed the buildability check for rails.
Use the automatic updater if you can (check experimental updates in other settings) or download full installation at http://www.factorio.com/download/experimental.

DRBLN
Filter Inserter
Filter Inserter
Posts: 411
Joined: Sat Mar 23, 2013 12:44 pm
Contact:

Re: Version 0.11.9

Post by DRBLN »

Grats!

Thank you for such a massive update.
We are already playing MP.

We experience a slight bug with research icons in MP :)
Dat hardcore mod.

Image


Serious bug found 5 minutes after the bugfix release. ©Developers
Image

Eifel
Burner Inserter
Burner Inserter
Posts: 8
Joined: Mon Jan 05, 2015 9:13 pm
Contact:

Re: Version 0.11.9

Post by Eifel »

Bug: When i want start new campaign (or load from 0.11.7), factorio stop working, in 0.11.7 it works.
clean game in zip downloaded
Last edited by Eifel on Mon Jan 05, 2015 9:29 pm, edited 1 time in total.

DRBLN
Filter Inserter
Filter Inserter
Posts: 411
Joined: Sat Mar 23, 2013 12:44 pm
Contact:

Re: Version 0.11.9

Post by DRBLN »

And due to some reason it's possible to start new MP game, but the game crashes if we start free SP game.

Clean Win x64 exe game was downloaded.
Last edited by DRBLN on Mon Jan 05, 2015 9:30 pm, edited 1 time in total.

sillyfly
Smart Inserter
Smart Inserter
Posts: 1099
Joined: Sun May 04, 2014 11:29 am
Contact:

Re: Version 0.11.9

Post by sillyfly »

That tech screen looks very interesting. I think it is a feature, so you don't get bored by the same old technologies :D :lol:

Kanapka
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Jun 23, 2014 9:18 pm
Contact:

Re: Version 0.11.9

Post by Kanapka »

So b4 that update me and my friends played a bit multiplayer (to be honest 16:40 h on very hard) and then suddenly smthn happened which made crashes after 2 mins of playing, we were waiting for that update 11.9 to continue playing cause we read that this issue will be solved which wasn't. now after i loading any save game crashes, starting new game, it crashes plz repair that somehow plz.

DRBLN
Filter Inserter
Filter Inserter
Posts: 411
Joined: Sat Mar 23, 2013 12:44 pm
Contact:

Re: Version 0.11.9

Post by DRBLN »

Kanapka wrote:So b4 that update me and my friends played a bit multiplayer (to be honest 16:40 h on very hard) and then suddenly smthn happened which made crashes after 2 mins of playing, we were waiting for that update 11.9 to continue playing cause we read that this issue will be solved which wasn't. now after i loading any save game crashes, starting new game, it crashes plz repair that somehow plz.
1) Looks like you saved, while holding an electric pole.
We had such an issue.
Try using another save.

2) 11.9 doesn't allow us to load any save we made in 11.8

Telarin
Long Handed Inserter
Long Handed Inserter
Posts: 62
Joined: Tue Mar 05, 2013 2:17 pm
Contact:

Re: Version 0.11.9

Post by Telarin »

Cannot seem to load any of my 0.11.8 saves. Tried several just to be sure, and none of them will load. Factorio crashes to desktop when I try.

sillyfly
Smart Inserter
Smart Inserter
Posts: 1099
Joined: Sun May 04, 2014 11:29 am
Contact:

Re: Version 0.11.9

Post by sillyfly »

kovarex wrote: Fixed crashes (mainly while saving) related to train with lost path trying to unlock gates on the path.
I am guessing this is what fixed the bug I was having, as when I loaded the game now, after the autosave (which now worked flawlessly! thanks!) I have noticed all of my trains stopped, because one of them had a "no path" error. The weird thing is - the path was perfectly fine, and pausing and un-pausing the train fixed the "no path" error. And I wasn't doing anything having to do with trains before the autosave that did work in 0.11.8 and the one that didn't.

That brings me to the conclusion that there is a bug with the train path algorithm, which makes trains think they have no path when indeed they do have, and this only happens while in motion.
This could probably explain this as well: https://forums.factorio.com/forum/vie ... f=7&t=7794 , although I can't be sure.
For reference - this is my original problem: https://forums.factorio.com/forum/vie ... =11&t=7709 .

Clearly I can't file a bug report yet, as this is only a hypothesis about a bug that may exist :)

LordFedora
Filter Inserter
Filter Inserter
Posts: 310
Joined: Fri Nov 07, 2014 3:46 am
Contact:

Re: Version 0.11.9

Post by LordFedora »

Guys, they said that about half of the saves would be corrupted and unable to load...

User avatar
Zemerson
Long Handed Inserter
Long Handed Inserter
Posts: 51
Joined: Thu Nov 28, 2013 9:57 am
Contact:

Re: Version 0.11.9

Post by Zemerson »

DRBLN wrote:And due to some reason it's possible to start new MP game, but the game crashes if we start free SP game.

Clean Win x64 exe game was downloaded.
Same here can't start a new Single Player game in 0.11.9 :cry:

System Information:
i7 950, 12GB Ram, 2GB GDDR5 GTX 660
Windows 7 Pro
Last edited by Zemerson on Mon Jan 05, 2015 10:22 pm, edited 1 time in total.

Subway
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Jan 05, 2015 10:13 pm
Contact:

Re: Version 0.11.9

Post by Subway »

Hello!

First, many thanks for the update :-)

But I've an issue with the research icons too (after starting a new game in 0.11.9.):
factorio_bug_1109_1.jpg
factorio_bug_1109_1.jpg (255.65 KiB) Viewed 15935 times

Greetings,
Subway

User avatar
-root
Filter Inserter
Filter Inserter
Posts: 651
Joined: Tue Jul 01, 2014 11:24 pm
Contact:

Re: Version 0.11.9

Post by -root »

kovarex wrote:The 0.11.7 and 0.11.8 was quite disastrous, lets hope we are finally getting over the worst.
Quoted for the lulz. :lol:

Keep up the great work guys. We do appreciate how active you are. I'm really looking forward to some of these optimizations. 30% decrease in sim time is freaking HUGE! It might allow me to push up to 1080p for recording.

Also that reconnecting of power poles is a really nice touch.

sillyfly
Smart Inserter
Smart Inserter
Posts: 1099
Joined: Sun May 04, 2014 11:29 am
Contact:

Re: Version 0.11.9

Post by sillyfly »

-root wrote:
kovarex wrote:The 0.11.7 and 0.11.8 was quite disastrous, lets hope we are finally getting over the worst.
Quoted for the lulz. :lol:

Keep up the great work guys. We do appreciate how active you are. I'm really looking forward to some of these optimizations. 30% decrease in sim time is freaking HUGE! It might allow me to push up to 1080p for recording.

Also that reconnecting of power poles is a really nice touch.
Oi! root! Don't you think it's time you replaced that old toaster you call a computer with something more modern? :lol:

veslan
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Jan 05, 2015 10:49 pm
Contact:

Re: Version 0.11.9

Post by veslan »

The game also crashes for me when starting a new game. I deleted the old userdata and did a fresh install of 11.9 and tried to start without any option changes but still a crash. :cry:

intel i5
Windows 7 Home Premium (latest updates)
4 GB Ram
Nvidia GTX 570

edit: multiplayer works

westy
Burner Inserter
Burner Inserter
Posts: 12
Joined: Tue May 06, 2014 2:51 pm
Contact:

Re: Version 0.11.9

Post by westy »

Inserters will no longer place items onto underground belt entrances.

Image

This seems to have broken a fair few things in my factory ;)

(I also get the science visuals bug, but there's nothing game-breaking there)

User avatar
Xterminator
Filter Inserter
Filter Inserter
Posts: 980
Joined: Sun Jun 15, 2014 4:49 pm
Contact:

Re: Version 0.11.9

Post by Xterminator »

I hate to add to the list, but I have several issues.
- In addition to inserters not placing onto underground belts, fast inserters seem to no longer place onto the end of a belt.
- Had 2 crashes within 1 hour when dealing with electric poles. I thought this was something specifically being fixed in this version, but for me it seems to have made it worse. :o Can't really provide any further info, as it seemed somewhat random, but the first time was while placing a substation, and second time with a large electric pole. :/
- Also I have the same issue with the research tree being messed up as shown in the pictures.

Hope a hotfix comes out soon! :D
Image Image Image

rosswurst
Manual Inserter
Manual Inserter
Posts: 1
Joined: Tue Jan 06, 2015 12:57 am
Contact:

Re: Version 0.11.9

Post by rosswurst »

Nice patch but with my dsl2000 im still unable to play mp.
It even lags on a new map it worked for me the 2 first versions of the mp but then it laged always. :cry:

Unforeseen
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri May 02, 2014 5:06 pm
Contact:

Re: Version 0.11.9

Post by Unforeseen »

Just an update I get the same as the others, can't load old saves and can't create new Single Player games. Multiplayer new games work.

westy
Burner Inserter
Burner Inserter
Posts: 12
Joined: Tue May 06, 2014 2:51 pm
Contact:

Re: Version 0.11.9

Post by westy »

Image Yes, fast inserters sometimes get stuck placing on the end of a belt. It's not something that always happens though, they just get stuck every now and then. Manually rebuilding them will 'unstick' them.

EDIT: further testing shows that this happens after the belt has backed up, and then freed up again. The insterter doesn't wake from its rest state.

This has destroyed my factory, hope the next update comes soon ;)
Last edited by westy on Tue Jan 06, 2015 4:31 am, edited 1 time in total.

Post Reply

Return to “Releases”