Reached game limits on roboports ?

Bugs that we were not able to reproduce, and/or are waiting for more detailed info.
Post Reply
Burner Inserter
Burner Inserter
Posts: 13
Joined: Mon Nov 13, 2017 1:36 pm

Reached game limits on roboports ?

Post by brainiac »

I'm well over 1000 hours of gameplay on steam, and already had the game before it was on steam. I played many times, and usually stopped when the rocked was launched, cause there seemed to be no purpose to continue playing.
Now with the infinite science, I have tried to see how far I could push the game till my pc got into trouble. I must say, apart from a memory warning, I haven't got any issue despite the huge map and terrain.
Now I think I may have found a game limit, which is currently disrupting my game. I've been using the same design across the map, but in one area I fail to read the roboport statistics, which has far reaching consequences as in that area construction bots are being produced infinetely because the robot network does not detect any in the network.

How I got there? On the huge map the first feature that was crying for a solution was automated repair. Before I was using a utility train to run around occasionally, but then I moved on to fully automated repair, supplied by trains. Now also this was getting complicated and unpractical, so I moved on again to remote building, and a distribution network with robots.

Of course this required segmentation, as robot networks are not suited for huge areas. So the idea was to have everything everywhere, all the time. Resources are being passed on from one network to the next, and the next network is almost self-replicating, as it just needs a seed, and can then build up itself. The main area has around 400 robots, the segments have 50 logistics and 50 construction bots, and around 10 roboports, and there are 50 to 100 segments, So this would amount to 5000 to 10000 robots in total - I really have no idea.

Now, most of the time the robots are resting. I know the design works, cause I've been using it for 2 - 3 weeks. Now today I discovered that my last built segment does not get construction bots. Upon closer investigation it appears that the supplying segment before this is producing thousands of construction bots - where it should stop when 50 are in the network. It had already produced 4600 units, when I discovered this :o) How it works is, it adds one to the robot network, when there is less than 50. It does this ok for the logistics bots, but not for construction bots. Now since I have replicated this design around 50 to 100 times, I'm very confident it is a bug probably because some limit was reached.

So the phenomenon is, in this segment, construction bots are being produced continuously, because none are active in the network. However there are 4600 in chests. One is being requested correctly, so this is not bugged. Where it goes wrong is where this one bot needs to be supplied to the robot network. For some reason it does not do this in that segment, with the same design I used across the board.

My steam account is herssens, not sure you can access my save files, or I need to supply them.

EDIT : I fixed it with a workaround doing the following - Total number of logistics bots & construction bots had signal red and green resp. I changed those to purple and cyan to see what it does. Then had to reconstruct the robot arm and reconnect it back to the roboport (also rebuilt) Now it seems to work again in that segment, not sure what was happening - and I now have a spare 5000 construction bots :twisted:
A possible explanation could be that the design was modified after using the blueprint, or the blueprint was partly built over an existing roboport setup - there is no way of telling, anyway I had to remove all parts and reconstruct them to get it working
Last edited by brainiac on Mon Nov 13, 2017 2:41 pm, edited 2 times in total.

Smart Inserter
Smart Inserter
Posts: 1099
Joined: Sun May 04, 2014 11:29 am

Re: Reached game limits on roboports ?

Post by sillyfly »

They have no way of accessing your save files - but they will probably be indispensable for diagnosing or solving this issue.
I suggest you upload your save file :)

Post Reply

Return to “Pending”