Placing underground ghosts rotates 180...

Bugs that are actually features.
Locked
roze
Inserter
Inserter
Posts: 24
Joined: Thu Sep 15, 2016 10:31 am
Contact:

Placing underground ghosts rotates 180...

Post by roze »

Hi,
After upgrading to 1.1.1, I'm VERY disappointed in a lot of new changes.

This thread being specifically for the shift-place on underground belts, since placing a long line of belts facing the same direction have now become seriously more tedious. Previously (and by that I mean, during my 3000+ hours of gameplay), all I did was pic the underground belt, rotate it as I wanted, and held down my left mouse button and painted the line of underground belts. In most cases, I just clone (q) the correct alignment from something close by. The new version places Exactly 1 underground belt when dragging sideways. Nothing less, nothing more. And in addition to this, rotates the belt 180°, making repeated click-placements taking over 10 times longer, since I have to rotate each piece before placing it. Not even turning off lock belts to straight lines prevents this, imo, unwanted behavior.

One work-around is copying (ctrl+c) and paste, then drag. However, this has two side effects, instead of requiring exactly two action (q then drag), it requires several more. First ctrl+c, then selection rectangle, then ctrl+v, then drag. so from two to 7 presses (counting command+key as two, cause it takes longer time to ctrl+key than just key). It also clogs up the copy history with nothing but underground belts in different directions. Not to mention that ctrl+c a single entity usually results in unwanted picks.

Please restore the old behavior either by a separate option, or by incorporating the old behavior into un-selecting the locked belts lines.
unknown.png
unknown.png (403.21 KiB) Viewed 472 times
//Regards

Loewchen
Global Moderator
Global Moderator
Posts: 7091
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Placing underground ghosts rotates 180...

Post by Loewchen »

That is not a bug, make a feature request.

roze
Inserter
Inserter
Posts: 24
Joined: Thu Sep 15, 2016 10:31 am
Contact:

Re: Placing underground ghosts rotates 180...

Post by roze »

I would say its both a bug and a feature request. Since the "Lock Belt Building To Straight Line"-option has forgotten about underground belts.

User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 5201
Joined: Tue Jul 12, 2016 9:03 am
Contact:

Re: Placing underground ghosts rotates 180...

Post by eradicator »

roze wrote:
Mon Nov 30, 2020 9:02 pm
I would say its both a bug and a feature request. Since the "Lock Belt Building To Straight Line"-option has forgotten about underground belts.
I share your pain but that option is and should be unrelated. It would need a second option "don't auto rotate underground-x" that disables it for belts and pipes. (If only cursor_stack rotation was moddable *sigh*...)
Author of: Belt Planner, Hand Crank Generator, Screenshot Maker, /sudo and more.
Mod support languages: 日本語, Deutsch, English
My code in the post above is dedicated to the public domain under CC0.

roze
Inserter
Inserter
Posts: 24
Joined: Thu Sep 15, 2016 10:31 am
Contact:

Re: Placing underground ghosts rotates 180...

Post by roze »

Well, since the thread is already created, and I do not feel like cross/double posting. A mod can move it to feature request if need be.

Loewchen
Global Moderator
Global Moderator
Posts: 7091
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Placing underground ghosts rotates 180...

Post by Loewchen »

roze wrote:
Mon Nov 30, 2020 9:12 pm
Well, since the thread is already created, and I do not feel like cross/double posting. A mod can move it to feature request if need be.
Make a new one, follow 47316.

posila
Factorio Staff
Factorio Staff
Posts: 5076
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: Placing underground ghosts rotates 180...

Post by posila »

Ghost placing was just made to behave more consistently with normal building. You can still achieve what you want by Ctrl + C selecting single underground belt or row of them and placing the ghosts that way.

Locked

Return to “Not a bug”