[0.18.45] Pump not connecting to the fluid wagon

Don't know how to use a machine? Looking for efficient setups? Stuck in a mission?
Post Reply
User avatar
JaJe
Long Handed Inserter
Long Handed Inserter
Posts: 63
Joined: Wed Feb 27, 2019 6:48 pm
Contact:

[0.18.45] Pump not connecting to the fluid wagon

Post by JaJe »

Hello!
As title says, I noticed that sometimes I am unable to make the pump working as intended and transfer fluids into the fluid wagon.
I am using Krastorio 2 mod, as you can see here, I have 3 stations for Petroleum gas/light oil/heavy oil.
The one in the middle refuses to connect to the fluid wagon no matter if i remove and place again the pump.

I guess it has to do with the rail track position and the distance between it and the pump but even that close it still refuses to work.

Loewchen
Global Moderator
Global Moderator
Posts: 7069
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.18.45] Pump not connecting to the fluid wagon

Post by Loewchen »

Make sure the train is automatically driven into the station.

User avatar
JaJe
Long Handed Inserter
Long Handed Inserter
Posts: 63
Joined: Wed Feb 27, 2019 6:48 pm
Contact:

Re: [0.18.45] Pump not connecting to the fluid wagon

Post by JaJe »

It is, I've done that test too, the train stops on the station and still not connect with the pump

Loewchen
Global Moderator
Global Moderator
Posts: 7069
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.18.45] Pump not connecting to the fluid wagon

Post by Loewchen »

If you send the train around again, does it still not work after it returns? If yes, post a link to the save please.

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1561
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [0.18.45] Pump not connecting to the fluid wagon

Post by boskid »

From far away i can see the train is not properly aligned - pump looks almost across the center of the fluid wagon connector. You may back off the train a little on manual and then set it back to automatic. If you can reliably reproduce this state happening when train arrives on automatic i would like to look at the save file.

User avatar
JaJe
Long Handed Inserter
Long Handed Inserter
Posts: 63
Joined: Wed Feb 27, 2019 6:48 pm
Contact:

Re: [0.18.45] Pump not connecting to the fluid wagon

Post by JaJe »

I have fixed by rebuilding the station again, probably the rail track was too close to the pumps.

Post Reply

Return to “Gameplay Help”