[posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

This subforum contains all the issues which we already resolved.
Post Reply
tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

[posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

Hi
Since 0.17 the game doesn't start anymore, tried an updated 0.16 version and both downloadable variants, always with the same result.
Also tried different config.ini settings (like described in "solving common graphic issues") and using different user accounts (up to local admin) to rule out our crappy group policies.

factorio-current.log always looks like this:

Code: Select all

   0.042 2019-02-27 07:01:40; Factorio 0.17.1 (build 43001, win64, alpha)
   0.042 Operating system: Windows 10 (version 1803) 
   0.043 Program arguments: "C:\Users\***\Factorio0.17\bin\x64\factorio.exe" 
   0.043 Read data path: C:/Users/***/Factorio0.17/data
   0.043 Write data path: C:/Users/***/Factorio0.17 [94543/242937MB]
   0.043 Binaries path: C:/Users/***/Factorio0.17/bin
   0.071 System info: [CPU: Intel(R) Core(TM) i5-4210M CPU @ 2.60GHz, 4 cores, RAM: 3580/8105 MB, page: 4241/16297 MB, virtual: 4267/134217727 MB, extended virtual: 0 MB]
   0.072 Display options: [FullScreen: 0] [VSync: 1] [UIScale: automatic (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: de]
   0.103 Available displays: 1
   0.103  [0]: \\.\DISPLAY1 - Intel(R) HD Graphics 4600 {0x05, [0,0], 1600x900, 32bit, 60Hz}
(and of course last stable worked fine)

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

Thanks for the report. That's entire log or did you posted just few first lines?

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

No, thats all, that‘s why I wrote the graphics card in the subject, seems to stop there

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

Based on paths, it's clean 0.17 download, correct? I am just wondering if deleting config.ini would help.

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

Of course my first try was without config.ini, doesn't change much (but the display options):

Code: Select all

   0.042 2019-02-27 08:58:04; Factorio 0.17.1 (build 43001, win64, alpha)
   0.043 Operating system: Windows 10 (version 1803) 
   0.043 Program arguments: "C:\Users\***\Factorio0.17\bin\x64\factorio.exe" 
   0.044 Read data path: C:/Users/***/Factorio0.17/data
   0.044 Write data path: C:/Users/***/Factorio0.17 [94522/242937MB]
   0.044 Binaries path: C:/Users/***/Factorio0.17/bin
   0.063 System info: [CPU: Intel(R) Core(TM) i5-4210M CPU @ 2.60GHz, 4 cores, RAM: 3876/8105 MB, page: 4140/16297 MB, virtual: 4267/134217727 MB, extended virtual: 0 MB]
   0.063 Display options: [FullScreen: 1] [VSync: 1] [UIScale: automatic (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.091 Available displays: 1
   0.092  [0]: \\.\DISPLAY1 - Intel(R) HD Graphics 4600 {0x05, [0,0], 1600x900, 32bit, 60Hz}
Last edited by tpatm on Wed Mar 20, 2019 6:52 am, edited 1 time in total.

dimm
Inserter
Inserter
Posts: 21
Joined: Tue Jun 06, 2017 12:04 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by dimm »

If the problem is still relevant, try running the game with the option --force-opengl

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

I did already, it’s part of the "solving common graphic issues" part.

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

I digged a bit deeper into different system logs and it seems our companys DLP software doesn't like version 0.17.x even when started with full local rights on the machine. Unfortunately I cant view the DLP logs and our IT isn't very likely to help with games :roll:

So this is not a bug in the end but there seems to be a difference to 0.16.x versions how the executable is recognized by my system ... :(

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

Thanks for letting us know.
I've added some extra logging around the area the original log ends, but forgot to ask you for a new log. To enabled it you'd need to launch the game with --debug-graphics commad line parameter in Factorio 0.17.5 or newer.

Can you restrict the rights the game is being launched with? It should need anything special and ZIP version should read and write to its own folder. Maybe try to enable Windows compatibility mode on the executable - maybe that would change something that trick the DLP software to let it run?

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

No luck tricking the anti-trick software ;-)
I even tried to copy everything to an USB device from another pc and then run it from the stick ...

Code: Select all

   0.186 2019-03-20 16:08:45; Factorio 0.17.15 (build 43864, win64, alpha)
   0.187 Operating system: Windows 7  <running in compatibility mode on Windows 10 (version 1803)>
   0.187 Program arguments: "factorio.exe" "--debug-graphics" 
   0.188 Read data path: C:/Users/***/Downloads/Factorio_0.17.15/data
   0.188 Write data path: C:/Users/***/Downloads/Factorio_0.17.15 [94487/242937MB]
   0.188 Binaries path: C:/Users/***/Downloads/Factorio_0.17.15/bin
   0.245 System info: [CPU: Intel(R) Core(TM) i5-4210M CPU @ 2.60GHz, 4 cores, RAM: 4234/8105 MB, page: 4417/16297 MB, virtual: 4292/134217727 MB, extended virtual: 0 MB]
   0.253 Display options: [FullScreen: 1] [VSync: 1] [UIScale: automatic (100.0%)] [Native DPI: 1] [Screen: 255] [Special: 00] [Lang: en]
   0.285 Graphics backend type: 2
   0.285 Available displays: 1
   0.286  [0]: \\.\DISPLAY1 - Intel(R) HD Graphics 4600 {0x05, [0,0], 1600x900, 32bit, 60Hz}
   0.312 Create window: displayIndex=0, width=1536, height=836, flags=000030a5

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

Thanks. Unfortunatelly it ends at a point of creating application window, so something in SDL probably triggers it.

Could you please follow steps I described in following post viewtopic.php?t=51375#p299745, if the antivirus program causes silent crash, it would crate dump with stacktrace so I could see what exactly crashes. Don't bother with dump_on_terminate.bat, traces generated by that were never usefull.

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

Of course.
I used --debug-graphics here too to be consistent
factorio.exe_190321_154545.zip
(396.69 KiB) Downloaded 43 times

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

Thank you! It is crashing inside of dgapi64.dll in a thread created by Factorio but stack seems to be corrupted, so I can't see what function does Factorio call at the moment of the crash. As far as I can tell the DLL is part of the antivirus.

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

Yes this is as far as I was aware. Digital Guardian is our DLP Software and I can’t inspect any logs or events from that to see why it doesn’t like me playing factorio

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

This batch file launches ProcDump so that it creates full dump instead of minidump when Factorio crashes. I might be able to recover stacktrace from fulldump. Also if you could send me the DLL through private message, it might be helpful, but don't do that if it is agains you company rules.
And finally, chance we will be able to find a workaround is quite slim, but it is an interesting issue, so I am willing to put some more time into it, if you are.
Attachments
full_dump_on_exception.zip
(229 Bytes) Downloaded 16 times

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

Link to Dump:
https://drive.google.com/file/d/1gpzfr4 ... hg1nf02TuE

Sorry can't provide the DLL, it's locked from manipulation on my laptop.

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

Hey, I am sorry for the super late reply.
I've looked over the crash dump again and added possible workaround for the crash to 0.17.50, can you please try the latest version and see if it still crashed with Digital Guard?

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

Wow finaly I can play factorio again :)

works fine now, no system events triggered as far as I can see

posila
Factorio Staff
Factorio Staff
Posts: 5064
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by posila »

Excelent! :) Thank you for the fast confirmation and your cooperation.

tpatm
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Feb 27, 2019 6:04 am
Contact:

Re: [posila] [0.17.1] Game fails to start on Windows 10 (Intel HD Graphics 4600)

Post by tpatm »

Thanks for the fix ;-)

Post Reply

Return to “Resolved Problems and Bugs”