Search found 80 matches

by Baughn
Sat Jul 18, 2020 3:42 am
Forum: PyMods
Topic: pY Coal Processing - Discussion
Replies: 1751
Views: 267137

Re: pY Coal Processing - Discussion

immortal_sniper1 wrote:
Wed Jul 15, 2020 9:16 pm
https://discord.gg/SNVbNC
That doesn't seem to be working.

I guess it's expired? It's the weekend now, so I should be able to check the forum more often.
by Baughn
Wed Jul 15, 2020 7:20 pm
Forum: PyMods
Topic: pY Coal Processing - Discussion
Replies: 1751
Views: 267137

Re: pY Coal Processing - Discussion

immortal_sniper1 wrote:
Wed Jul 15, 2020 5:41 pm
no for stuff like that talk with py , are u on discord (our server) u can ask there
I would be, but can't find a link. Help?
by Baughn
Wed Jul 15, 2020 4:25 pm
Forum: PyMods
Topic: pY Coal Processing - Discussion
Replies: 1751
Views: 267137

Re: pY Coal Processing - Discussion

i forgot that glass in stone furnace was removed , i should make a fast recipe(fast since it would use just a little fuel ) but not great in terms on molten/quartz ratio and it affects all mod combinations since it is a pyCP thing not pyAL i need to finish bioprinting then i will take a look again ...
by Baughn
Wed Jul 08, 2020 6:51 pm
Forum: PyMods
Topic: pY Coal Processing - Discussion
Replies: 1751
Views: 267137

Re: pY Coal Processing - Discussion

I guess I am blessed with ears that do not hear the high pitched noise, though I wonder if that's really a blessing or rather a curse... :? The post processing one does sound very muffled though. My sound card driver let's me setup EQ-profiles, perhaps setting up a specific profile for Factorio mig...
by Baughn
Tue Jul 07, 2020 8:08 pm
Forum: PyMods
Topic: pY Coal Processing - Discussion
Replies: 1751
Views: 267137

Re: pY Coal Processing - Discussion

Definitely not. Your headphones and/or ears might be missing it; it's up at 8kHz, as you can see here: https://brage.info/factorio/squeal/Screenshot_20200707_205902.png I took the liberty to apply a low-pass filter to the existing sounds; ffmpeg -af lowpass=f=1000 . You can see the results here: htt...
by Baughn
Tue Jul 07, 2020 5:29 pm
Forum: PyMods
Topic: pY Coal Processing - Discussion
Replies: 1751
Views: 267137

Re: pY Coal Processing - Discussion

The destructive distillation machine (aka, the first coal processing tool we have) makes a high-pitched noise that with my headphones is downright painful, and feels like it's provoking tinnitus.

Could that possibly be changed?
by Baughn
Mon May 25, 2020 4:35 pm
Forum: Won't implement
Topic: Pathfinding flag to avoid biters
Replies: 1
Views: 125

Pathfinding flag to avoid biters

I have a group of bots, used for construction. They do not have any military ability, but they positively enjoy running towards walls in order to repair them. Specifically: They're given a movement command with the target set to the wall. Sometimes, the fastest path to the wall involves running outs...
by Baughn
Mon May 25, 2020 2:49 pm
Forum: Technical Help
Topic: Factorio is not using GPU (Linux)
Replies: 18
Views: 685

Re: Factorio is not using GPU (Linux)

I agree that it should be possible. I just can't help you set it up, sorry.
by Baughn
Wed May 20, 2020 11:32 pm
Forum: Technical Help
Topic: Factorio is not using GPU (Linux)
Replies: 18
Views: 685

Re: Factorio is not using GPU (Linux)

It's not, in general, possible to move an OpenGL application from one GPU to another. Multi-GPU setups require code that simply doesn't exist on Linux.

I bet it's doing software rendering. That said, I wouldn't even begin to know how to debug this. You're on your own here, I"m afraid.
by Baughn
Wed May 20, 2020 6:08 pm
Forum: Technical Help
Topic: Factorio is not using GPU (Linux)
Replies: 18
Views: 685

Re: Factorio is not using GPU (Linux)

Factorio thinks you have 6 monitors. Is that accurate? And can you post your xorg.conf, as well? If you don't actually have six, then my best guess is your Xinerama configuration is creating extra, virtual monitors, and Factorio is for some reason defaulting to one of those. That should be at least ...
by Baughn
Tue May 19, 2020 9:41 pm
Forum: Technical Help
Topic: Factorio is not using GPU (Linux)
Replies: 18
Views: 685

Re: Factorio is not using GPU (Linux)

It seems you've disabled RANDR somehow. That extension can be summed up as "xinerama version 2"; you want it enabled. Custom xorg configuration? It should run fine without any config at all, assuming you're not on a laptop, so try that first. I don't know why a lack of RANDR would break Factorio, bu...
by Baughn
Wed May 06, 2020 9:57 pm
Forum: Desyncs with mods
Topic: [0.18.22] Desynced in multiplayer
Replies: 4
Views: 253

Re: [0.8.22] Desynced in multiplayer

Looks like I can track this down to Rampant.

I'm not sure how that makes sense with the other symptoms, but that's what I've got.
by Baughn
Wed May 06, 2020 9:41 pm
Forum: Desyncs with mods
Topic: [0.18.22] Desynced in multiplayer
Replies: 4
Views: 253

Re: [0.8.22] Desynced in multiplayer

It *seemed* to work for some time, but once I started adding logistics requests again I desynced.

Yay.
by Baughn
Mon May 04, 2020 11:40 pm
Forum: Desyncs with mods
Topic: [0.18.22] Desynced in multiplayer
Replies: 4
Views: 253

Re: [0.8.22] Desynced in multiplayer

Destroying the character with `game.player.character.destroy()` stopped the desyncs, after one final one. I was able to create a new character and it now seems to be working.

So the desync should be caused by the character object somehow? Not sure how to debug that.
by Baughn
Mon May 04, 2020 11:31 pm
Forum: Desyncs with mods
Topic: [0.18.22] Desynced in multiplayer
Replies: 4
Views: 253

Re: [0.8.22] Desynced in multiplayer

Interestingly, each time I reconnect I can see my character in a different position -- further southwest from where I was last time I logged in. It then immediately desyncs.
by Baughn
Mon May 04, 2020 11:23 pm
Forum: Desyncs with mods
Topic: [0.18.22] Desynced in multiplayer
Replies: 4
Views: 253

[0.18.22] Desynced in multiplayer

Not much to say about this one. It worked for a long time, then very abruptly started desyncing two of the players immediately after login. Quickshot, for some reason, is still able to play. Attached is the savegame. The desync report is too large for the forum, so you can find it at https://brage.i...
by Baughn
Sun May 03, 2020 2:46 am
Forum: Technical Help
Topic: Trouble connecting to dedicated server via Vodafone network
Replies: 0
Views: 133

Trouble connecting to dedicated server via Vodafone network

Hi again. This time it's not a Linux issue. A friend of mine has been having intermittent problems connecting to the server, which we eventually tracked down to the cellphone network. Long story short, if too much data is sent via UDP in too short a time then the connection process somehow jams up a...
by Baughn
Wed Mar 04, 2020 9:55 pm
Forum: 1 / 0 magic
Topic: [0.18.9] No longer playable on NixOS
Replies: 13
Views: 1326

Re: [0.18.9] No longer playable on NixOS

So when I confirmed that 0.18.8 worked fine, I didn't actually check 0.18.9. Turns out it also works fine, which means whatever was changed is in my OS. Fortunately I can git-bisect it... Unfortunately this didn't let me replicate the bug. This should mean it's environmental, and I've changed too ma...
by Baughn
Wed Mar 04, 2020 5:56 pm
Forum: Releases
Topic: Version 0.18.10
Replies: 16
Views: 9852

Re: Version 0.18.10

This seems to have fixed viewtopic.php?f=7&t=81699&p=482973.

Was that deliberate? I'm not seeing a changelog entry.
by Baughn
Wed Mar 04, 2020 5:54 pm
Forum: 1 / 0 magic
Topic: [0.18.9] No longer playable on NixOS
Replies: 13
Views: 1326

Re: [0.18.9] No longer playable on NixOS

This appears to be fixed in 0.18.10, but there's no corresponding changelog entry. I'm worried it might be by accident.

Go to advanced search