[kovarex] [0.17.76] Trainfuel is not reliably applied from blueprint

This subforum contains all the issues which we already resolved.
Post Reply
Calibretto22
Burner Inserter
Burner Inserter
Posts: 13
Joined: Thu May 03, 2018 8:54 pm
Contact:

[kovarex] [0.17.76] Trainfuel is not reliably applied from blueprint

Post by Calibretto22 »

Game: 0.17.76 Vanilla

Setup:
- a blueprint with rails and a train that has fuel
- place blueprint repeatedly
- bots build rails and train
- moduleslots for fuel are applied

Bug:
- moduleslots for fuel are not reliably applied

Clarifiacations:
- mostly happens on trains that are rotated or diagonally
- error seems to happen more often on games that have high ups (60+) and less often in my megabase (~45 UPS)

Blueprintexample:




Screenshot @ 60 UPS:
Unbenannt.PNG
Unbenannt.PNG (779.7 KiB) Viewed 1457 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 10882
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.76] Trainfuel is not reliably applied from blueprint

Post by Rseding91 »

Thanks for the report. I don't think this will ever be fixed. Blueprinting trains on curves just doesn't work due to how trains align themselves to rails at a fundamental level.

I'll assign this to Kovarex but i don't think there's a solution except "don't blueprint trains on curves".
If you want to get ahold of me I'm almost always on Discord.

AntiElitz
Filter Inserter
Filter Inserter
Posts: 288
Joined: Sat Aug 29, 2015 11:37 pm
Contact:

Re: [kovarex] [0.17.76] Trainfuel is not reliably applied from blueprint

Post by AntiElitz »

I have to second this report [0.18.10], It's really annoying because its so inconsistent. Not blueprinting on a curve is not really a solution you can manage to do in a naturally grown base.

schmorp
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Apr 17, 2019 8:01 am
Contact:

Re: [kovarex] [0.17.76] Trainfuel is not reliably applied from blueprint

Post by schmorp »

I note that the original bug report says "mostly" on curves, and indeed, this happens for me on straight rails [0.18.32], mostly when I have a blueprint with many trains in them, such as when building an LTN depot - out of ten trains, usually 2-4 do not receive their fuel.

kovarex
Factorio Staff
Factorio Staff
Posts: 7448
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.76] Trainfuel is not reliably applied from blueprint

Post by kovarex »

Hello, the bug was quite straightforward.

The storytime:
4 years ago, when the feature to allow construction robots deliver modules into machines as part of a blueprint or upgrade operation, it wasn't really considered that it might have something to do with moving entities.

So there was a condition: whenever the surface, force or position of the entity changes, just cancel the request.

Since the trains tend to move a little here and there when the blueprint for trains is being completed, that caused the request to be randomly removed.

Well, removing the if and making the request follow the train around was simple and it solved the original bug, but now we had a new problem: when the robot is chasing the locomotive to insert the fuel, but it already has some and runs away, the robots just follows it intil it runs out of power and get stuck in an infinite loop trying to get to the locomotive somewhere deep in the wilderness.

Long story short, the special logic that calls off robots chasing damaged vehicles to repair them when they run out of the logistic network had to be extended for this case, but it works and this smal bug will be finally solved.

TL;DR; Solved for the next release

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users