[Oxyd] [0.17.59] UPS drop after .59

This subforum contains all the issues which we already resolved.
Post Reply
enterisys
Filter Inserter
Filter Inserter
Posts: 701
Joined: Sat Dec 16, 2017 1:39 pm
Contact:

[Oxyd] [0.17.59] UPS drop after .59

Post by enterisys »

Hey

My base suffered 20 UPS drop with new experimental from 55-60 to sub-40.
Briefly checked changes and found only loaders change, as my base is heavily packed with them.
73398

Save
https://drive.google.com/open?id=1nIkGs ... wM_LodoZFa

Mods used - latest.
Attachments
factorio-previous.log
(22.93 KiB) Downloaded 88 times
factorio-current.log
(22.83 KiB) Downloaded 84 times
20190725215358_1.jpg
20190725215358_1.jpg (560.53 KiB) Viewed 3289 times
20190725214635_1.jpg
20190725214635_1.jpg (550.64 KiB) Viewed 3289 times

User avatar
darkfrei
Smart Inserter
Smart Inserter
Posts: 2897
Joined: Thu Nov 20, 2014 11:11 pm
Contact:

Re: [0.17.59] UPS drop after .59

Post by darkfrei »

"aai signal transmission" and "space ex" need UPS

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1790
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [0.17.59] UPS drop after .59

Post by boskid »

darkfrei wrote:
Fri Jul 26, 2019 6:51 am
"aai signal transmission" and "space ex" need UPS
Not relevant amout of time. You can see Entity update 6.247ms -> 16.483ms

User avatar
darkfrei
Smart Inserter
Smart Inserter
Posts: 2897
Joined: Thu Nov 20, 2014 11:11 pm
Contact:

Re: [0.17.59] UPS drop after .59

Post by darkfrei »

Are pipes and fluids also in the "entity" category?

Adamo
Filter Inserter
Filter Inserter
Posts: 476
Joined: Sat May 24, 2014 7:00 am
Contact:

Re: [0.17.59] UPS drop after .59

Post by Adamo »

darkfrei wrote:
Fri Jul 26, 2019 7:12 am
Are pipes and fluids also in the "entity" category?
Pipes are entities. Fluids are the things carried by that entity, or "fluid amount" is the amount in that entity.

Rseding91
Factorio Staff
Factorio Staff
Posts: 12219
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.59] UPS drop after .59

Post by Rseding91 »

Thanks for the report. All of the time is being spent on biters of which had several fixes in the latest release so they would actually do what they're supposed to do.
If you want to get ahold of me I'm almost always on Discord.

Rseding91
Factorio Staff
Factorio Staff
Posts: 12219
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Oxyd] [0.17.59] UPS drop after .59

Post by Rseding91 »

With that being said, a *lot* of the time is spent in wandering which might not be intended? I'll leave this to Oxyd to say if it's a bug or not.
If you want to get ahold of me I'm almost always on Discord.

enterisys
Filter Inserter
Filter Inserter
Posts: 701
Joined: Sat Dec 16, 2017 1:39 pm
Contact:

Re: [Oxyd] [0.17.59] UPS drop after .59

Post by enterisys »

Last time I did alien clean up I noticed that nests are overpacked by biters.

ivanisovich
Burner Inserter
Burner Inserter
Posts: 5
Joined: Sat Jul 27, 2019 4:30 pm
Contact:

Re: [Oxyd] [0.17.59] UPS drop after .59

Post by ivanisovich »

My marathon/deathworld base was running at a smooth 59-60 UPS prior to latest experimental update.

It now varies widely from 53-58. When the game first loads, it gets up to 60 for a minute or two, then slows down.

The mention of biters being a possible cause makes sense. I'm surrounded by biter nests impacted by my thick pollution cloud (and I mean, fully surrounded). I didn't really notice a change in behavior of the biters after the update, though. They still attack mostly the same. They do seem to get stuck less, but will still get stuck on each other as a group of 100 close in on the base; to me, that makes sense, though...they're in a very tight formation. It would seem a good action for them would be to spread out as they approach the base and attack en mass (now the pack just hits about 5-10 at a time with the rest bumping around until the first ones are dead). Maybe that would result in less calculations to change their path.

I'm still scalling up a megabase, and it would be challenging to have to change some plans to get rid of the biters within the pollution cloud....that's a HUGE sea of red....with the only purpose to get rid of the lower UPS. For reference, I surround my base with walls and lasers, have about 2 dozen artillery posts to clear the closer nests, and am working on artillery range 5. No mods are used.

barbary
Long Handed Inserter
Long Handed Inserter
Posts: 51
Joined: Wed Feb 27, 2019 10:31 am
Contact:

Re: [Oxyd] [0.17.59] UPS drop after .59

Post by barbary »

I have also seen a drop of around 8UPS when moving from 0.17.54 to 0.17.59. I am under near constant attack so maybe I am seeing the same bug.

The loss of 8 UPS is almost exactly what I gained from moving from 0.17.43 to 0.17.54.

enterisys
Filter Inserter
Filter Inserter
Posts: 701
Joined: Sat Dec 16, 2017 1:39 pm
Contact:

Re: [Oxyd] [0.17.59] UPS drop after .59

Post by enterisys »

That's new.
As a side note using console to kill biters in revealed chunks moves ups to 60 again.
Attachments
Untitled.png
Untitled.png (2.23 MiB) Viewed 3056 times

ivanisovich
Burner Inserter
Burner Inserter
Posts: 5
Joined: Sat Jul 27, 2019 4:30 pm
Contact:

Re: [Oxyd] [0.17.59] UPS drop after .59

Post by ivanisovich »

An update after a weekend of playing on .59.

I had moments where UPS would run at 60 again. Sometimes, though it would crawl at 45. I researched the next Artillery range level, so my arty rained fire down and I also used that to explore new chunks. Needless to say, lots of new and old areas were forced to load and run for a time.

However, weird things happened. Normally, when my range expands and arty automatically destroys nests in range, the biters will swarm together and then attack the base. This stopped happening in some instances. I even set up a few extended arty outposts to bombard some areas affected by my pollution cloud. In many areas, about 10% of the biters would move a little and then stop. The rest didn't even move. I saw an entire nest area destroyed, and most of the biters never moved. Note that I didn't move my character to those areas, so those chunks were only affected by the artillery. Here is a screenshot of one of those areas showing biters wholly unconcerned their homes were just destroyed. (These biters were all still, and remained unmoving as their homes were destroyed; I took the screenshots later after all areas were cleared in the arty's range, so the nest images had despawned. Just know the ground was covered with nests)

Additionally, I saw weird behavior from a group that approached my laser lined walls. For well over an hour, the group paused, unmoving just out of laser range. In these screenshots you can see it on the minimap...the red blob at the top right of the minimap. I ignored them, and at some point they triggered and move.
Attachments
Expanded view showing how widespread the unmoving biters were.
Expanded view showing how widespread the unmoving biters were.
20190729002222_1.jpg (270.01 KiB) Viewed 3012 times
Area at the edge of the Artillery's range...right side was cleared, left was out of range.
Area at the edge of the Artillery's range...right side was cleared, left was out of range.
20190729002230_1.jpg (900.75 KiB) Viewed 3012 times
20190729002217_1.jpg
20190729002217_1.jpg (874.84 KiB) Viewed 3012 times

Oxyd
Former Staff
Former Staff
Posts: 1428
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [Oxyd] [0.17.59] UPS drop after .59

Post by Oxyd »

Biters that don't do anything can get woken up when other biters bump into them, and it looks like they were being kept active for too long. It should be better in 0.17.61.

Post Reply

Return to “Resolved Problems and Bugs”