[0.17.48] Loaders don't wake up when you pick up items from them

This subforum contains all the issues which we already resolved.
Post Reply
mrvn
Smart Inserter
Smart Inserter
Posts: 5112
Joined: Mon Sep 05, 2016 9:10 am
Contact:

[0.17.48] Loaders don't wake up when you pick up items from them

Post by mrvn »

This happens with Deadlocks loaders but they are just a better gfx for vanilla loaders. So should happen there too.

Place an assembler and set it to e.g. iron rods. Place a loader and belt next to the assembler and fill it with copper plates. This causes the loader entity to go to sleep because the assembler doesn't need any copper plates.

Pick up the copper plates from the belt and loader by pressing f while walking over it. Then place iron plates on the belt.

Expected behavior: The iron plates get loaded into the assembler.

Actual behavior: The loader stays asleep loading nothing.

The loader wakes back up when you rotate it or place something into the assembler by hand. Otherwise it remains stuck.

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.48] Loaders don't wake up when you pick up items from them

Post by posila »

Can you post small save of the bugged scenario, please? From the description it sounds like the loader is loading directly to the assembling machine which is not something vanilla loaders can do.

This is setup I got before I realized you are probably direct-loading to the assembling machine
73398.png
73398.png (42.87 KiB) Viewed 2226 times


EDIT: Nevermind ... I just found out loaders can load into assembling machine ... my mind is blown.

posila
Factorio Staff
Factorio Staff
Posts: 5147
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.48] Loaders don't wake up when you pick up items from them

Post by posila »

Thanks for the report (save would have been helpful, though)

Fixed for 0.17.59

mrvn
Smart Inserter
Smart Inserter
Posts: 5112
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [0.17.48] Loaders don't wake up when you pick up items from them

Post by mrvn »

Thanks.

I noticed the same problem with unloading from an assembler. Probably the same thing and might be fixed by this fixed. Set up the loader to unload the assembler and let it run a cycle. Then put finished product into the empty assembler but it won't get unloaded.

If it's not fixed with the next update I will report it again with a savegame.

slippycheeze
Filter Inserter
Filter Inserter
Posts: 587
Joined: Sun Jun 09, 2019 10:40 pm
Contact:

Re: [0.17.48] Loaders don't wake up when you pick up items from them

Post by slippycheeze »

mrvn wrote:
Mon Jul 22, 2019 9:10 am
I noticed the same problem with unloading from an assembler. Probably the same thing and might be fixed by this fixed. Set up the loader to unload the assembler and let it run a cycle. Then put finished product into the empty assembler but it won't get unloaded.
Oddly enough, the "miniloaders" mod, which is a couple of fast inserters under a pretty picture, won't take items from chests until a belt is placed in front of it. Place chest-belt-miniloader and it does nothing. Place chest-miniloader-belt, or remove and replace the belt, and it'll start moving stuff as expected.

No idea if this is related, and I'll retest and report too after the update, but ... certainly odd.

mrvn
Smart Inserter
Smart Inserter
Posts: 5112
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [0.17.48] Loaders don't wake up when you pick up items from them

Post by mrvn »

slippycheeze wrote:
Mon Jul 22, 2019 4:34 pm
mrvn wrote:
Mon Jul 22, 2019 9:10 am
I noticed the same problem with unloading from an assembler. Probably the same thing and might be fixed by this fixed. Set up the loader to unload the assembler and let it run a cycle. Then put finished product into the empty assembler but it won't get unloaded.
Oddly enough, the "miniloaders" mod, which is a couple of fast inserters under a pretty picture, won't take items from chests until a belt is placed in front of it. Place chest-belt-miniloader and it does nothing. Place chest-miniloader-belt, or remove and replace the belt, and it'll start moving stuff as expected.

No idea if this is related, and I'll retest and report too after the update, but ... certainly odd.
As you say miniloaders are inserters. So totally different entity. Unless they both inherit from entity_that_can_sleep_waiting_for_item in the code. So yeah, 50:50 chance. Try it with 0.17.59+ and report back I would say.

slippycheeze
Filter Inserter
Filter Inserter
Posts: 587
Joined: Sun Jun 09, 2019 10:40 pm
Contact:

Re: [0.17.48] Loaders don't wake up when you pick up items from them

Post by slippycheeze »

mrvn wrote:
Wed Jul 24, 2019 2:47 pm
slippycheeze wrote:
Mon Jul 22, 2019 4:34 pm
mrvn wrote:
Mon Jul 22, 2019 9:10 am
I noticed the same problem with unloading from an assembler. Probably the same thing and might be fixed by this fixed. Set up the loader to unload the assembler and let it run a cycle. Then put finished product into the empty assembler but it won't get unloaded.
Oddly enough, the "miniloaders" mod, which is a couple of fast inserters under a pretty picture, won't take items from chests until a belt is placed in front of it. Place chest-belt-miniloader and it does nothing. Place chest-miniloader-belt, or remove and replace the belt, and it'll start moving stuff as expected.

No idea if this is related, and I'll retest and report too after the update, but ... certainly odd.
As you say miniloaders are inserters. So totally different entity. Unless they both inherit from entity_that_can_sleep_waiting_for_item in the code. So yeah, 50:50 chance. Try it with 0.17.59+ and report back I would say.
Apparently from the author this is a known issue with the snapping code. I thought I turned that off because I don't use it anyway, but IDK if it'll improve soon or not.

enterisys
Filter Inserter
Filter Inserter
Posts: 701
Joined: Sat Dec 16, 2017 1:39 pm
Contact:

Re: [0.17.48] Loaders don't wake up when you pick up items from them

Post by enterisys »

I lost 20 UPS with the update.
viewtopic.php?f=3&t=73643#p445002
My base is pretty heavy with loaders after smelting to save ups for heavy mods.
Can you, please, look again at fix ?

Post Reply

Return to “Resolved Problems and Bugs”