[0.17.24] Electric network info opens when deconstructing pole from map view

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
BattleFluffy
Long Handed Inserter
Long Handed Inserter
Posts: 99
Joined: Sun Mar 31, 2019 4:58 pm
Contact:

[0.17.24] Electric network info opens when deconstructing pole from map view

Post by BattleFluffy » Wed Apr 03, 2019 11:12 am

When I use the deconstruction planner in the Map View, and begin my drag-selection on top of a power pole, it opens the Electric Network Info window, usually blocking my view of the thing I'm trying to deconstruct.

Image

This only happens in Map View. If you drag-select a pole for deconstruction while not in the map, it properly blocks the click from being interpreted as a command to open the Electric Network info.
It also happens when making a new blueprint from the map view.
It affects all types of power poles - I tested Large, Medium, Small and Substation.

The behaviour I would have expected is that it doesn't open the Electric Network Info window if I'm dragging a box to make a Deconstruction Order or Blueprint from the map.

User avatar
BattleFluffy
Long Handed Inserter
Long Handed Inserter
Posts: 99
Joined: Sun Mar 31, 2019 4:58 pm
Contact:

Re: [0.17.24] Electric network info opens when deconstructing pole from map view

Post by BattleFluffy » Wed Apr 03, 2019 2:09 pm

Update - I discovered this only happens if the "drag map" control has been rebound.
The default is left mouse button. I had bound it to mouse button 5.

Bilka
Factorio Staff
Factorio Staff
Posts: 2134
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.17.24] Electric network info opens when deconstructing pole from map view

Post by Bilka » Thu Apr 11, 2019 11:34 am

Thanks for the report, fixed for the next version.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

User avatar
BattleFluffy
Long Handed Inserter
Long Handed Inserter
Posts: 99
Joined: Sun Mar 31, 2019 4:58 pm
Contact:

Re: [0.17.24] Electric network info opens when deconstructing pole from map view

Post by BattleFluffy » Thu Apr 11, 2019 12:56 pm

Thanks!! :D

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users