[kovarex] [0.16.45] Replays desync with console commands

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
DaveMcW
Smart Inserter
Smart Inserter
Posts: 2810
Joined: Tue May 13, 2014 11:06 am
Contact:

[kovarex] [0.16.45] Replays desync with console commands

Post by DaveMcW » Sun May 27, 2018 11:35 pm

Steps to reproduce:

1. Start a new game with replays enabled.
2. Run a console command:

Code: Select all

/c game.print("Hello world")
3. Save the game and load it as a replay.
4. The command runs successfully, but the replay stops with a desync notice.

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.45] Replays desync with console commands

Post by kovarex » Mon May 28, 2018 11:33 am

I tried it and there was no desync.

User avatar
DaveMcW
Smart Inserter
Smart Inserter
Posts: 2810
Joined: Tue May 13, 2014 11:06 am
Contact:

Re: [kovarex] [0.16.45] Replays desync with console commands

Post by DaveMcW » Mon May 28, 2018 3:03 pm

I'm running Ubuntu 18.04, does that have something to do with it?
factorio-current.log
Here is a replay that desyncs:
Attachments
replay-desync.zip
(1.39 MiB) Downloaded 26 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.45] Replays desync with console commands

Post by kovarex » Mon May 28, 2018 3:17 pm

Do you also have it when you write:

Code: Select all

/c game.player.print("Hello world")
?

User avatar
DaveMcW
Smart Inserter
Smart Inserter
Posts: 2810
Joined: Tue May 13, 2014 11:06 am
Contact:

Re: [kovarex] [0.16.45] Replays desync with console commands

Post by DaveMcW » Mon May 28, 2018 4:00 pm

Yes, every command I tried desynced.

Even this:

Code: Select all

/silent-command x = 1 + 2

Oxyd
Factorio Staff
Factorio Staff
Posts: 1245
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [kovarex] [0.16.45] Replays desync with console commands

Post by Oxyd » Mon May 28, 2018 4:01 pm

Thanks, fixed in 0.16.46. It was related to the “running commands will disable achievements” message.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Bing [Bot]