[Dominik] Minor bug: removing items from blueprint causes "shifting"

This subforum contains all the issues which we already resolved.
Post Reply
golfmiketango
Filter Inserter
Filter Inserter
Posts: 531
Joined: Fri Jan 29, 2016 2:48 am
Contact:

[Dominik] Minor bug: removing items from blueprint causes "shifting"

Post by golfmiketango » Tue Jan 09, 2018 8:10 pm

Although it's no big deal, when editing a blueprint to exclude certain entities, the blueprint surface will tend to jump around in the display. In the worst-case scenario of removing a lot of items from a busy blueprint, this can actually become a meaningful problem rather than an aesthetic issue.

I think it's reasonable for the blueprint to resize and therefore shift around when changing the type of items selected via the check-boxes (which actually makes them no longer appear on screen). But I think it's pretty wierd that, i.e., right clicking a roboport smack dab in the middle of the blueprint (which doesn't even visually remove it so much as turn it into some kind of "blueprint-ghost") can nevertheless sometimes cause the whole surface you're looking at to get a new anchor-point in the GUI (perhaps because, under the hood, it no longer puts the roboport coverage area in, and decides the extremities have shrunk?)

User avatar
wheybags
Factorio Staff
Factorio Staff
Posts: 258
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: Minor bug: removing items from blueprint causes "shifting"

Post by wheybags » Wed Jan 10, 2018 10:31 am

Could you post exact steps to reproduce this issue? Including a blueprint string to test on?
I tried creating some blueprints with roboports in the middle and right clicking them, but couldn't reproduce it.

golfmiketango
Filter Inserter
Filter Inserter
Posts: 531
Joined: Fri Jan 29, 2016 2:48 am
Contact:

Re: Minor bug: removing items from blueprint causes "shifting"

Post by golfmiketango » Wed Jan 10, 2018 9:42 pm

wheybags wrote:Could you post exact steps to reproduce this issue? Including a blueprint string to test on?
I tried creating some blueprints with roboports in the middle and right clicking them, but couldn't reproduce it.
That would have been nice, right? Unfortunately I kinda lost track of how I did this but I have definitely seen this behavior lots of times. I am pretty sure I can figure out a repeatable recipe but it will take a day or three as I have a lot of RL stuff on my plate (note to self: you saw this when blueprinting your "shitty compromise"-style 4-lane 1-3-1 offramps with a roboport in the junction area). Will do it (or at least try) eventually, I promise.

As for a blueprint string, I'm not sure about it. I think maybe this only happens when you have "sampled" a blueprint and are previewing your creation. If that's so then a bp string will not in and of itself suffice to repro without some sort of "instructions".

Bilka
Factorio Staff
Factorio Staff
Posts: 1958
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: Minor bug: removing items from blueprint causes "shifting"

Post by Bilka » Fri Jan 12, 2018 10:45 am

I can reproduce this. It happens due to there being less components, so the window resizes.

String for the blueprint:

Code: Select all

0eNq1l9GOqyAQht+Fa9gAarf1VTabxuq0JUfRAG7WNL77Qd1jPJW2aLuXCv1m/n+GkV7QIa+hUkIaFF+QSEupUfxxQVqcZJJ370xTAYqRMFAgjGRSdE/wXSnQmhiVSF2VypAD5Aa1GAmZwTeKWYsfQnR90CYxopSTH/L2EyOQRhgBQyr9Q7OXdXEAZcmPksCoKrXosTayRYYYNSgmYdvldEXja2mBixaMtGOiDRFSgzJ2YQYhfKAwFyX0prA7lGikCHkU0i6R9Aza3MbwvgrD3r0GY4Q86W6PgqL8gn1t13KbCGT7rpB2yagaMBreDsX6V9pUgEyBVEn6h3AbMi3rrsU4pRgVZdbtSQzJIekTGpvm06Vk46+E/64S9qSSd9/K0juF3S5u2bFNMMqEgnRY4g72zttq+rtOB086zejMJV3lwjjdDgYt9C167BBbPn+4t/1s9TjiThOCtThn47FwhqttEdRJ2UJlN4A/w4VeicfjJ0FWdffhmEeLFif/c/yph9GbZSfxqnahC+l9uJk3cu1Rp87y7RbTqK+fnPqK577iOVvRbfx+s5W1udFtnLuuJfMOC9+iPgS3s8KFmZy43MZXIiUgbdKNtcT6cUxScJ2RCfW/1DeuGOHCIf3CGV0IO0MT1ZDpsH5yVHP/mwp7tZ5KlVnde/1SRf43Fv5qRWdxOhMD6Xm9IHsB7y/q8eTPAUZfNtDQk9t3TqMd3Ya7tv0LE0AoZw==
Behaviour:
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

golfmiketango
Filter Inserter
Filter Inserter
Posts: 531
Joined: Fri Jan 29, 2016 2:48 am
Contact:

Re: Minor bug: removing items from blueprint causes "shifting"

Post by golfmiketango » Fri Jan 12, 2018 3:59 pm

Ha! A head-slapper for sure. Nice catch, Bilka, and sorry for having apparently made a quasi-useless/misleading report. I guess the question is, given that there does appear to be a completely valid reason for this behavior, is it annoying enough to fix anyhow. But I will not opine since it's perfectly tolerable as it is and I'm not the one who would get to do the work of fixing it :)

Dominik
Factorio Staff
Factorio Staff
Posts: 540
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik] Minor bug: removing items from blueprint causes "shifting"

Post by Dominik » Fri Feb 16, 2018 2:48 pm

I agree that this is inconvenient and unsanctioned. So I changed it so that empty slots remain in place.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users