[Dominik] [16.13]Electric network info bug

This subforum contains all the issues which we already resolved.
Post Reply
liij
Burner Inserter
Burner Inserter
Posts: 15
Joined: Sun Aug 17, 2014 8:39 am
Contact:

[Dominik] [16.13]Electric network info bug

Post by liij » Thu Jan 04, 2018 12:31 am

For 5 second scale 70 beacons has constant power consumption.
For 1m scale for 70 beacons is going crazy. It changes value 60 times per second, every tick.
I am not using power switches, just solar power grid, and also bug is on multiplayer vanilla servers.

Loewchen
Global Moderator
Global Moderator
Posts: 5213
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [16.13]Electric network info bug

Post by Loewchen » Thu Jan 04, 2018 12:34 am

Post a save where this can be observed please.

liij
Burner Inserter
Burner Inserter
Posts: 15
Joined: Sun Aug 17, 2014 8:39 am
Contact:

Re: [16.13]Electric network info bug

Post by liij » Thu Jan 04, 2018 12:38 am

Loewchen wrote:Post a save where this can be observed please.
This is redmew's server save, where u can check beacon for 5s and 1 min scale
https://ufile.io/z3omn
edit:
check power consumptio for other things, it is often going crazy and changing value 60times per second. I have never seen power consumption values changing so fast.
2nd edit:
it looks like it is something about ceil/floor functions in calculations

LD100
Burner Inserter
Burner Inserter
Posts: 14
Joined: Sun Jul 31, 2016 7:45 pm
Contact:

Re: [16.13]Electric network info bug

Post by LD100 » Thu Jan 04, 2018 3:08 am

I can confirm this behavior in my own savegame for the 1 and 10 min electric network info.
Attachments
0_16_rich_big.zip
see next electric power 1 min for beacon power consumption
(13.13 MiB) Downloaded 25 times

Dominik
Factorio Staff
Factorio Staff
Posts: 540
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik] [16.13]Electric network info bug

Post by Dominik » Fri Jan 05, 2018 3:09 pm

The value changes by themselves are ok. It is a result of some combination of the chosen sampling frequency a frequency of the given energy consumer.
What I have changed though is the way the decimals show so that it shows 0 as well, so it will not be so jumpy.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users