[Rseding91] [0.16.1] reproducible crash when fast-replacing power pole

This subforum contains all the issues which we already resolved.
Post Reply
Tekky
Smart Inserter
Smart Inserter
Posts: 1027
Joined: Sun Jul 31, 2016 10:53 am
Contact:

[Rseding91] [0.16.1] reproducible crash when fast-replacing power pole

Post by Tekky » Wed Dec 13, 2017 11:09 pm

Whenever I do the following, the game crashes:
  1. Load the following savegame:
    fastreplace_crash.zip
    savegame
    (5.2 MiB) Downloaded 26 times
  2. After loading, you will be standing right next to a small power pole with a medium power pole in your hand. Fast-replace the small power pole with the medium power pole.
  3. Afterwards, do the same with the next small power pole immediately to the north. The game will always crash when you do this.
It does not crash if you first remove the small power pole before placing the medium power pole. In other words, it only crashes when using the fast-replace feature.

I have reproduced this crash with version 0.16.0 and 0.16.1.

I am not using any mods.

Here is the crash log:

Code: Select all

   0.001 2017-12-13 23:53:57; Factorio 0.16.1 (build 34215, win64, steam)
   0.001 Operating system: Windows 7 Service Pack 1
   0.002 Program arguments: "C:\Program Files (x86)\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe" "--force-opengl" 
   0.002 Read data path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/data
   0.002 Write data path: C:/Users/Andy/AppData/Roaming/Factorio [52181/599899MB]
   0.002 Binaries path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/bin
   0.010 System info: [CPU: Intel(R) Core(TM) i5 CPU         760  @ 2.80GHz, 4 cores, RAM: 12286MB]
   0.014 Display options: [FullScreen: 1] [VSync: 1] [UIScale: system (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.017 Available display adapters: 1
   0.017  [0]: \\.\DISPLAY1 - NVIDIA GeForce GTX 650 Ti {0x05, [0,0], 1600x1200, 32bit, 60Hz}
   0.017 Create display on adapter 0. Size 1280x720 at position [150, 222].
   0.368 Initialised OpenGL:[0] GeForce GTX 650 Ti/PCIe/SSE2; driver: 4.6.0 NVIDIA 388.13
   0.368   Video memory size (dedicated/total available/current available): 1024/1024/847 MB
   0.391 DSound: Starting _dsound_update thread
   0.391 DSound: Enter _dsound_update; tid=4408
   0.392 Graphics settings preset: medium-with-low-vram
   0.393 Graphics options: [Graphics quality: normal] [Video memory usage: high] [Light scale: 100%] [DXT: false] [Shader: 1]
   0.393                   [Parallel sprite loading: 1] [Max texture size: 4096/4096] [Bmp cache: 1] [Sprite slicing: 1] [Low quality rotation: 1]
   0.538 Loading mod core 0.0.0 (data.lua)
   0.557 Loading mod base 0.16.1 (data.lua)
   0.727 Loading mod base 0.16.1 (data-updates.lua)
   0.781 Checksum for core: 3022494965
   0.781 Checksum of base: 2024614476
   0.913 Loading sounds...
   0.993 Info PlayerData.cpp:67: Local player-data.json unavailable
   0.993 Info PlayerData.cpp:70: Cloud player-data.json available, timestamp 1513205574
   1.093 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/game.glsl
   1.094 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/zoom-to-world.glsl
   1.094 Loaded shader file C:/Program Files (x86)/Steam/steamapps/common/Factorio/data/core/graphics/shaders/alpha-mask.glsl
   1.111 Initial atlas bitmap size is 4096
   1.116 Created atlas bitmap 4096x4095 [none]
   1.124 Created atlas bitmap 4096x4094 [none]
   1.132 Created atlas bitmap 4096x4091 [none]
   1.135 Created atlas bitmap 4096x4090 [none]
   1.138 Created atlas bitmap 4096x4084 [none]
   1.140 Created atlas bitmap 4096x4095 [none]
   1.141 Created atlas bitmap 4096x1779 [none]
   1.143 Created atlas bitmap 4096x3560 [terrain]
   1.144 Created atlas bitmap 4096x3366 [shadow]
   1.146 Created atlas bitmap 4096x1374 [smoke]
   1.147 Created atlas bitmap 4096x1935 [decal]
   1.148 Created atlas bitmap 4096x1868 [no-crop, trilinear-filtering, icon, light]
   1.148 Created atlas bitmap 4096x476 [alpha-mask]
  13.007 Sprites loaded
  13.007 Convert atlas 4096x1868 to: trilinear-filtering 
  13.145 Convert atlas 4096x476 to: alpha-mask
  13.174 Custom inputs active: 0
  13.225 Factorio initialised
  17.537 DSound: Stopping voice
  17.537 DSound: Joining thread
  17.537 DSound: Exit _dsound_update; tid=4408
  17.537 DSound: Waiting for voice to stop ... signaled
  17.537 DSound: Joined thread
  17.537 DSound: Destroying thread
  17.538 DSound: Thread destroyed
  17.538 DSound: Releasing buffer
  17.538 DSound: Voice stopped
  17.538 DSound: Deallocating voice
  17.538 DSound: Deallocated voice
  17.586 Unable unset the current context! The handle is invalid.

  17.587 Steam API shutdown.
  17.588 Goodbye

Rseding91
Factorio Staff
Factorio Staff
Posts: 9983
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.16.1] reproducible crash when fast-replacing power pole

Post by Rseding91 » Wed Dec 13, 2017 11:30 pm

Thanks for the report. It's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Tekky
Smart Inserter
Smart Inserter
Posts: 1027
Joined: Sun Jul 31, 2016 10:53 am
Contact:

Re: [Rseding91] [0.16.1] reproducible crash when fast-replacing power pole

Post by Tekky » Wed Dec 13, 2017 11:37 pm

Thanks. That was fast!

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users