[0.17.49][minor] Replay desync due to editor controls not disabled

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
boskid
Fast Inserter
Fast Inserter
Posts: 191
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

[0.17.49][minor] Replay desync due to editor controls not disabled

Post by boskid » Fri Jun 14, 2019 3:51 pm

What i did:
1/ Open replay for "rails-no-path-unless-repath.zip" (72008)
2/ Wait for editor gui to show up
3/ Select "time" page
4/ press "play"
5/ There is notice:
Map desynchronisation: tick xxx
Replay crc: xxxx
Current crc:xxxx
6/ Game exits to main menu

Desync can also be triggered by:
- "surface" -> "remove all entities" (only when there are some entities to remove)
- "surface" -> "create surface"
- "surface" -> "remove empty chunks"
- editor/settings -> disable all checkboxes
- "time" -> "pause" (when time is running)
- "time" -> "daytime" (when time is running)
- "force" -> "create force" (if force name not empty)
- "time" -> "tick once"
- by changing editor page (for example to "tiles") when replay wants to press "play" on "time" page
desync log records
I consider this bug to be "minor" as it is not game breaking, nothing is lost (it was replay), it needs editor to used within replay record and when replay it needs specific interaction.
---
Minor minor other replay issue: when in replay there is train window, button "open this location in map" (third button above windowed map) works changing game view to map, but map-key is not working so you cannot leave this map view state

Rseding91
Factorio Staff
Factorio Staff
Posts: 9261
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.49][minor] Replay desync due to editor controls not disabled

Post by Rseding91 » Fri Jun 14, 2019 8:52 pm

Ok, I've fixed it so the GUI ignores clicks when in replays.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users