[0.16.51] [Windows] Frame-Drop on Multiplayer

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Eiermann
Inserter
Inserter
Posts: 22
Joined: Tue Jan 08, 2019 7:27 am
Contact:

[0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Eiermann » Sun Jan 13, 2019 11:50 pm

Hello Folks,
im playing with serveral friends on a private factorio server. Unluckily my frame-rate is dropping pretty hard from time to time since we expanded our territory. The game is currently unplayable for me. Tried different steps to fix my problem - without any positiv results. Im the only person on the server who get such frame-drops.

My current setup:
- Windows 10
- i7-7800X @ 3.50 GhZ (6 Cores / 12 Threads)
- 16+ GB of RAM DDR4
- nVidia 1060 GTX with 6GB

Workload while playing:
- CPU 18% (Factorio: 10%)
- RAM 56% (Factorio: 3.3GB / 20%)
- HDD 1%
- ETH 1%

What i have tried so far:
- checked my RAM modules with MemTest
- updated the nvidia driver
- updated other drivers (network, etc)
- checked bios (correct ram & cpu clocks)
- played the exact same savegame online (multiplayer) and offline with the exact same settings (offline is running smoothly)
- restart all server relevant services
- killed all units on the server via kill_all_units()
- played other games to see if the problem happens elsewhere
- different ingame settings (graphics, rendering threads, etc)

The only problem i currently see i a huge difference in the "wait for update" debug info.

Steps to repoduce:
- load the save-game in a dedicated server
- walk around a bit and zoom out max

Attachments:
- fps-drop-online.png: show-time-usage
- fps-drop-offline.png: show-time-usage
- factorio-previous.log: the previous log-file
- factorio-current.log: the current log-file
- FREE-2018.zip the save-game is used for debugging

Save-Game: https://drive.google.com/open?id=1eGjoW ... xXRncicyD3

If you need further information, please let me know! :-)

Best regards,
Alex
Attachments
factorio-previous.log
(30.85 KiB) Downloaded 10 times
factorio-current.log
(7.11 KiB) Downloaded 8 times
fps-drop-online.png
fps-drop-online.png (4.72 MiB) Viewed 380 times
fps-drop-offline.png
fps-drop-offline.png (4.73 MiB) Viewed 380 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9017
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Rseding91 » Mon Jan 14, 2019 12:32 am

Based off the update times debug display I would say you're falling behind the server and it's dropping FPS in attempts to keep up.
If you want to get ahold of me I'm almost always on Discord.

Eiermann
Inserter
Inserter
Posts: 22
Joined: Tue Jan 08, 2019 7:27 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Eiermann » Mon Jan 14, 2019 12:45 am

Thank you for the fast reply. Im not sure this is the issue for the fps-drops because im the person with the fastest internet connection on this server. Any suggestion how to verify this assumption?

Loewchen
Global Moderator
Global Moderator
Posts: 5043
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Loewchen » Mon Jan 14, 2019 1:15 am

Eiermann wrote:
Mon Jan 14, 2019 12:45 am
Im not sure this is the issue for the fps-drops because im the person with the fastest internet connection on this server. Any suggestion how to verify this assumption?
This has nothing to do with your connection speed. Test if the issue disappears when slowing down the server, see: viewtopic.php?f=7&t=3638#p299295

Eiermann
Inserter
Inserter
Posts: 22
Joined: Tue Jan 08, 2019 7:27 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Eiermann » Fri Jan 18, 2019 1:51 pm

After replacing my nvidia driver (again!) the problem is finally solved. I still experience some small drops, but they are very short. If the problem appears again i will add additional logs to this thread. Thank you for your help guys! :-)

fyi: slowing down the server didnt helped.

Eiermann
Inserter
Inserter
Posts: 22
Joined: Tue Jan 08, 2019 7:27 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Eiermann » Fri Jan 18, 2019 10:35 pm

Aaaaaand here i am. Joined the server and had huge lags. I activated the debug settings "show-multiplayer-*" as mentioned in another thread (see screenshot). FPS is currently between 10-40 fps, USP is around 59-60.
Attachments
fps-drop-again-2.png
fps-drop-again-2.png (4.12 MiB) Viewed 320 times
fps-drop-again.png
fps-drop-again.png (4.3 MiB) Viewed 321 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9017
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Rseding91 » Sat Jan 19, 2019 10:02 am

Rseding91 wrote:
Mon Jan 14, 2019 12:32 am
Based off the update times debug display I would say you're falling behind the server and it's dropping FPS in attempts to keep up.
It's still this. Your computer isn't powerful enough to keep up UPS wise and FPS wise at the same time and so it's dropping FPS to keep UPS up with the server.
If you want to get ahold of me I'm almost always on Discord.

User avatar
DaveMcW
Smart Inserter
Smart Inserter
Posts: 2718
Joined: Tue May 13, 2014 11:06 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by DaveMcW » Mon Jan 21, 2019 1:12 am

Rseding91 wrote:
Sat Jan 19, 2019 10:02 am
it's dropping FPS to keep UPS up with the server.
Can we have an alert or some indication when it does this?

Eiermann
Inserter
Inserter
Posts: 22
Joined: Tue Jan 08, 2019 7:27 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Eiermann » Mon Jan 21, 2019 3:26 pm

Rseding91 wrote:
Sat Jan 19, 2019 10:02 am
Rseding91 wrote:
Mon Jan 14, 2019 12:32 am
Based off the update times debug display I would say you're falling behind the server and it's dropping FPS in attempts to keep up.
It's still this. Your computer isn't powerful enough to keep up UPS wise and FPS wise at the same time and so it's dropping FPS to keep UPS up with the server.
What exactly does this mean? I am running a hex-core with @3.50 GHz, the game is installed on a M.2, i am using DDR4-2400 RAM and a new GTX 1060. Since i am able to run the savegame locally without any fps-drops i would suspect the internet-connection (network, router, etc) might be the issue. The server itself is currently running on a Intel Xeon @2.10 GHz. I can easily download the savegame with 20MB/s and more. Could it be that a UDP-Flood or something is causing the issue and the router / firewall is dropping packets?

Could you also explain what the different numbers in "buffer" and "jumps" stand for? Maybe this could help me to solve the issue with my hardware.

Thank you for helping me! :-)

Rseding91
Factorio Staff
Factorio Staff
Posts: 9017
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.51] [Windows] Frame-Drop on Multiplayer

Post by Rseding91 » Mon Jan 21, 2019 6:28 pm

Eiermann wrote:
Mon Jan 21, 2019 3:26 pm
Rseding91 wrote:
Sat Jan 19, 2019 10:02 am
Rseding91 wrote:
Mon Jan 14, 2019 12:32 am
Based off the update times debug display I would say you're falling behind the server and it's dropping FPS in attempts to keep up.
It's still this. Your computer isn't powerful enough to keep up UPS wise and FPS wise at the same time and so it's dropping FPS to keep UPS up with the server.
What exactly does this mean? I am running a hex-core with @3.50 GHz, the game is installed on a M.2, i am using DDR4-2400 RAM and a new GTX 1060. Since i am able to run the savegame locally without any fps-drops i would suspect the internet-connection (network, router, etc) might be the issue. The server itself is currently running on a Intel Xeon @2.10 GHz. I can easily download the savegame with 20MB/s and more. Could it be that a UDP-Flood or something is causing the issue and the router / firewall is dropping packets?

Could you also explain what the different numbers in "buffer" and "jumps" stand for? Maybe this could help me to solve the issue with my hardware.

Thank you for helping me! :-)
It means because the server doesn't have to show any graphics it still runs faster than your computer can. The added overhead of rendering and playing in Multiplayer means the server is still able to out perform your computer at simulating the game.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users