Initialization failed. Error code: 01

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
TheAUGMaster888
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri May 13, 2016 6:43 pm

Initialization failed. Error code: 01

Post by TheAUGMaster888 » Sun Aug 12, 2018 11:00 pm

I have been having this problem no matter what version I have tried playing and this problem occurs every time I launch Factorio from steam or from the direct download off the website and i'm not sure how to fix it can someone please help me. I am trying to run factorio on a lenovo thinkpad t440s
Attachments
Capture.PNG
Capture.PNG (22.03 KiB) Viewed 184 times

Jap2.0
Smart Inserter
Smart Inserter
Posts: 1674
Joined: Tue Jun 20, 2017 12:02 am

Re: Initialization failed. Error code: 01

Post by Jap2.0 » Mon Aug 13, 2018 1:42 am

Can you please post a log? (%appdata%/factorio)
There are 10 types of people: those who get this joke and those who don't.

TheAUGMaster888
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri May 13, 2016 6:43 pm

Re: Initialization failed. Error code: 01

Post by TheAUGMaster888 » Mon Aug 13, 2018 6:41 pm

Code: Select all

0.001 2018-08-13 14:22:33; Factorio 0.16.51 (build 36654, win64, steam)
   0.001 Operating system: Windows 7 
   0.001 Program arguments: "C:\Program Files (x86)\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe" 
   0.001 Read data path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/data
   0.001 Write data path: C:/Users/kcargile.TURNER/AppData/Roaming/Factorio [228349/460329MB]
   0.001 Binaries path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/bin
   0.032 System info: [CPU: Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz, 4 cores, RAM: 5898/7879 MB, page: 7094/15757 MB, virtual: 185/8388607 MB, extended virtual: 0 MB]
   0.032 Display options: [FullScreen: 1] [VSync: 0] [UIScale: system (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.033 Available display adapters: 1
   0.033  [0]: \\.\DISPLAY7 - Intel(R) HD Graphics Family {0x05, [0,0], 1600x900, 32bit, 60Hz}
   0.034 Create display on adapter 0. Size 1280x720 at position [150, 72].
   0.257 D3D9: Skipping adapter 0 as it doesn't have any available modes.
   0.257 D3D9: al_get_d3d_adapter_from_win_adapter failed. Using adapter -1 instead. Total adapter count: 1
   0.258 D3D9: Adapter [0] Intel(R) HD Graphics Family; driver: dlumd9.dll 9.18.7.6
   0.258       Display mode: 1600x900@60; format: 22
   0.341 d3d_create_display failed.

   0.341 Failed to create display (NULL)

   0.341 C:\Program Files (x86)\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe
   0.341 C:\Windows\SYSTEM32\ntdll.dll
   0.341 C:\Windows\system32\kernel32.dll
   0.341 C:\Windows\system32\KERNELBASE.dll
   0.341 C:\Program Files (x86)\Steam\steamapps\common\Factorio\bin\x64\steam_api64.dll
   0.341 C:\Windows\system32\ADVAPI32.dll
   0.341 C:\Windows\system32\msvcrt.dll
   0.341 C:\Windows\SYSTEM32\sechost.dll
   0.341 C:\Windows\system32\RPCRT4.dll
   0.341 C:\Windows\system32\SHELL32.dll
   0.341 C:\Windows\system32\SHLWAPI.dll
   0.341 C:\Windows\system32\GDI32.dll
   0.341 C:\Windows\system32\USER32.dll
   0.341 C:\Windows\system32\LPK.dll
   0.341 C:\Windows\system32\USP10.dll
   0.341 C:\Windows\system32\WLDAP32.dll
   0.341 C:\Windows\system32\ole32.dll
   0.341 C:\Windows\system32\WINMM.dll
   0.341 C:\Windows\system32\PSAPI.DLL
   0.341 C:\Windows\system32\OPENGL32.dll
   0.341 C:\Windows\system32\GLU32.dll
   0.341 C:\Windows\system32\DDRAW.dll
   0.341 C:\Windows\system32\DCIMAN32.dll
   0.341 C:\Windows\system32\SETUPAPI.dll
   0.341 C:\Windows\system32\CFGMGR32.dll
   0.341 C:\Windows\system32\OLEAUT32.dll
   0.341 C:\Windows\system32\DEVOBJ.dll
   0.341 C:\Windows\system32\dwmapi.dll
   0.341 C:\Windows\WinSxS\amd64_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.7600.17007_none_2b47185a719d6182\gdiplus.dll
   0.341 C:\Windows\system32\IMM32.dll
   0.341 C:\Windows\system32\MSCTF.dll
   0.341 C:\Windows\system32\IPHLPAPI.DLL
   0.341 C:\Windows\system32\NSI.dll
   0.341 C:\Windows\system32\WINNSI.DLL
   0.341 C:\Windows\system32\WS2_32.dll
   0.341 C:\Windows\system32\CRYPT32.dll
   0.341 C:\Windows\system32\MSASN1.dll
   0.341 C:\Windows\system32\DSOUND.dll
   0.341 C:\Windows\system32\POWRPROF.dll
   0.342 C:\Windows\system32\VERSION.dll
   0.342 C:\Windows\system32\apphelp.dll
   0.342 C:\Windows\AppPatch\AppPatch64\AcXtrnal.DLL
   0.342 C:\Program Files (x86)\Steam\gameoverlayrenderer64.dll
   0.342 C:\Windows\system32\secur32.dll
   0.342 C:\Windows\system32\SSPICLI.DLL
   0.342 C:\Windows\system32\profapi.dll
   0.342 C:\Program Files (x86)\Steam\steamclient64.dll
   0.342 C:\Windows\system32\imagehlp.dll
   0.342 C:\Program Files (x86)\Steam\tier0_s64.dll
   0.342 C:\Program Files (x86)\Steam\vstdlib_s64.dll
   0.342 C:\Windows\system32\MSWSOCK.dll
   0.342 C:\Windows\system32\cryptbase.dll
   0.342 C:\Windows\System32\wshtcpip.dll
   0.342 C:\Windows\system32\d3d9.dll
   0.342 C:\Windows\system32\d3d8thk.dll
   0.342 C:\Windows\system32\uxtheme.dll
   0.363 Error Util.cpp:49: Initialization failed. Error code: 01
   5.313 Steam API shutdown.
   5.416 Goodbye

Zavian
Smart Inserter
Smart Inserter
Posts: 1065
Joined: Thu Mar 02, 2017 2:57 am

Re: Initialization failed. Error code: 01

Post by Zavian » Mon Aug 13, 2018 7:08 pm

Try updating your graphics driver.

TheAUGMaster888
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri May 13, 2016 6:43 pm

Re: Initialization failed. Error code: 01

Post by TheAUGMaster888 » Mon Aug 13, 2018 7:22 pm

Tried updating my graphics card and it said it was up to date and it was last updated in 2015 so I don't know whats up with that and it wouldn't let me download any updates from the intel website

Loewchen
Global Moderator
Global Moderator
Posts: 4611
Joined: Wed Jan 07, 2015 5:53 pm

Re: Initialization failed. Error code: 01

Post by Loewchen » Mon Aug 13, 2018 8:14 pm

Remove what ever is running now and download the latest manually: https://downloadcenter.intel.com/produc ... phics-4400

TheAUGMaster888
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri May 13, 2016 6:43 pm

Re: Initialization failed. Error code: 01

Post by TheAUGMaster888 » Mon Aug 13, 2018 8:24 pm

I finally did resolve this issue all I had to do was find the update that would be supported by my computer hardware on the intel website to update my intel hd graphics 4400 graphics card Thank You to those who attempted to help me

Post Reply

Return to “Technical Help”