Yuoki Industries - Railways Core 0.6.20 (f0.16.0+)

Energy production, weapons, handling fluids and much more - excellent graphics.

Moderator: YuokiTani

Post Reply
FalcoGer
Long Handed Inserter
Long Handed Inserter
Posts: 78
Joined: Fri Sep 05, 2014 3:11 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by FalcoGer » Thu Mar 10, 2016 6:15 pm

Well, I have a pretty low end pc with 1gb of ram on my graphics card. When I run with waitex it is barely able to load the graphics if i use the less memory demanding version. but if I load the train color mod, even with nothing else, I get a black screen with no textures and only text, which is the error you get when you load too many sprites. I also get this error when I use the full waitex texture replacement. So I imagine when my game breaks with 5 locomotives and wagons, it will almost certainly break with 50, or however many this mod adds.
I have no clue how factorio manages to fill my ram to the brim with textures and graphics to the point where it breaks, but it does.

Fatmice
Filter Inserter
Filter Inserter
Posts: 808
Joined: Thu Dec 04, 2014 11:03 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by Fatmice » Fri Mar 11, 2016 11:13 am

In regard to the game, it loads all sprites at launch into the gfx memory so that there won't be any hiccup during game play. So if you use mods with heavy/large sprites and your gfx can't handle it, then nobody's to blame but you. If you have such low amount of gfx memory then why are you using waitex? Waitex covers all of the vanilla sprites, which there are hundreds...sounds to me like you want your cake and eat it too, which, imo, is not Yuoki's problem. ;)
Maintainer and developer of Atomic Power. See here for more information.
Current release: 0.6.6 - Requires 0.14.x
Example build - Requires 0.14.x

FalcoGer
Long Handed Inserter
Long Handed Inserter
Posts: 78
Joined: Fri Sep 05, 2014 3:11 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by FalcoGer » Fri Mar 11, 2016 11:08 pm

That's not the problem. I can run waitex hd mod. However I can not even run the single train color mod on it's own, because trains have dozens of fairly large sprites. Besides that it's still over the top to have a hundred different train parts that all do practically the same 3 things.

Fatmice
Filter Inserter
Filter Inserter
Posts: 808
Joined: Thu Dec 04, 2014 11:03 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by Fatmice » Sat Mar 12, 2016 12:24 am

Interesting, so you can run waitex hd mod, but can't run the train's...I would figure the sprites are all really equivalent to the hardware regardless of size, so something else is at play here. Your gfx card just can't handle large sprite sheet?
Maintainer and developer of Atomic Power. See here for more information.
Current release: 0.6.6 - Requires 0.14.x
Example build - Requires 0.14.x

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2173
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by steinio » Tue Mar 15, 2016 4:58 pm

Omg i installed Yuoki with the Railway Core and didn't imagined what this addon will bring.
It looks so amazing what is possible to build and i can't await to build all this shops for train parts.

I suddenly fall in love with it :D

Just had to say that...
Greetings steinio
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

SirFloIII
Burner Inserter
Burner Inserter
Posts: 10
Joined: Wed Mar 16, 2016 9:09 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by SirFloIII » Wed Mar 16, 2016 9:16 pm

Hey, Yuoki.

I installed the Railway Core mod and 2 of the add-ons, but when I want to open a savegame or start a new game I get following error message:

__yi_railway__/control.lua:4: attempt to index global 'script' (a nil value)

This is my modlist, in case it is relevant.

https://imgur.com/7BZEAUR

my regards, Flo

EDIT: ah, nevermind, i am an idiot and still running factorio 12.4, but 12.11+ is required.

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2173
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by steinio » Mon Mar 21, 2016 6:53 pm

Hello,

does this mod work with the 8L Train Project viewtopic.php?f=91&t=19458?

Greetings
steinio
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

Fatmice
Filter Inserter
Filter Inserter
Posts: 808
Joined: Thu Dec 04, 2014 11:03 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by Fatmice » Mon Mar 21, 2016 7:00 pm

steinio wrote:Hello,

does this mod work with the 8L Train Project viewtopic.php?f=91&t=19458?

Greetings
steinio
The trains and cargo do not follow those arbitrary standards. As far as incompatibility, no.
Maintainer and developer of Atomic Power. See here for more information.
Current release: 0.6.6 - Requires 0.14.x
Example build - Requires 0.14.x

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2173
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by steinio » Mon Mar 21, 2016 7:07 pm

Hello Fatmice,

thanks for your answer.

So i will play without 8L like i did until now.

Greetings
steinio
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

YuokiTani
Smart Inserter
Smart Inserter
Posts: 1016
Joined: Thu May 08, 2014 7:57 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.6 (f0.12.11+)

Post by YuokiTani » Thu Mar 31, 2016 6:18 am

from FFF 131
Redo of the train graphics and fixing the train distances, so they are whole tiles and vertical and horizontal distances are the same
i highly recommend testing or playing YI-Rails until the train has left - and this mod is superfluous ;)
(should not happen before 1 June 2016 so you have some time left - to make some screenshots)

update to 0.0.7
- now i wait for the changes/differences factorio 0.13 brings ... (no new locomotives or cargo-wagon next 2-3 months)

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2173
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by steinio » Fri Apr 01, 2016 5:49 pm

Hello YuokiTani,

sorry to bother you but after upgrading to 0.0.7 i got the attached error message.
Am i missing something or is this the april fool?

Greetings steinio
Attachments
Yuoki Railway Core 0.0.7.png
Yuoki Railway Core 0.0.7.png (12.74 KiB) Viewed 1968 times
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

YuokiTani
Smart Inserter
Smart Inserter
Posts: 1016
Joined: Thu May 08, 2014 7:57 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by YuokiTani » Fri Apr 01, 2016 8:47 pm

steinio wrote:Hello YuokiTani,
sorry to bother you but after upgrading to 0.0.7 i got the attached error message.
Am i missing something or is this the april fool?
Greetings steinio
this means some code not really work in the real world ...
no joke - it's the bitter reality.

edit in yi_railway/data.lua -> remove 3 last lines (if data ... end)

this removes the yuoki-industries-installed-check and uses stone to make slag-ground-floor-tiles ... not the smartest way, but it will work.

Fatmice
Filter Inserter
Filter Inserter
Posts: 808
Joined: Thu Dec 04, 2014 11:03 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by Fatmice » Fri Apr 01, 2016 10:16 pm

steinio wrote:Hello YuokiTani,

sorry to bother you but after upgrading to 0.0.7 i got the attached error message.
Am i missing something or is this the april fool?

Greetings steinio
Which version of Yuoki Industries are you using as I do not have such a problem? And I've played with Yuoki's mod for a long time.
Maintainer and developer of Atomic Power. See here for more information.
Current release: 0.6.6 - Requires 0.14.x
Example build - Requires 0.14.x

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2173
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by steinio » Sat Apr 02, 2016 10:05 am

Fatmice wrote: Which version of Yuoki Industries are you using as I do not have such a problem? And I've played with Yuoki's mod for a long time.
Hello Fatmice,

i'm just playing with the railway core and train mods but without indutries.

Greetings steinio
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

YuokiTani
Smart Inserter
Smart Inserter
Posts: 1016
Joined: Thu May 08, 2014 7:57 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by YuokiTani » Sat Apr 02, 2016 12:59 pm

steinio wrote:
Fatmice wrote: Which version of Yuoki Industries are you using as I do not have such a problem? And I've played with Yuoki's mod for a long time.
Hello Fatmice,
i'm just playing with the railway core and train mods but without indutries.
Greetings steinio
have the changes here, if you haven't done by yourself yet
Attachments
data.lua
goes into the yi_railway.zip and overwrite the old one
(1.29 KiB) Downloaded 89 times

Fatmice
Filter Inserter
Filter Inserter
Posts: 808
Joined: Thu Dec 04, 2014 11:03 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by Fatmice » Sat Apr 02, 2016 8:30 pm

steinio wrote:
Fatmice wrote: Which version of Yuoki Industries are you using as I do not have such a problem? And I've played with Yuoki's mod for a long time.
Hello Fatmice,

i'm just playing with the railway core and train mods but without indutries.

Greetings steinio
Ah I see. It was assumed that if you were playing with the railway mod that you would also be playing with Yuoki's main mod.
YuokiTani wrote:
have the changes here, if you haven't done by yourself yet
This will fix the case where they don't have the main mod to apply the right prototypes.

Code: Select all

if data.raw.item["y-slag"] ~= nil then -- should be Yuoki-Industries installed	
	require ("prototypes._tiles_slag") 	
else
	require ("prototypes._tiles_slag_2") 	
end
Maintainer and developer of Atomic Power. See here for more information.
Current release: 0.6.6 - Requires 0.14.x
Example build - Requires 0.14.x

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2173
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by steinio » Sat Apr 02, 2016 11:41 pm

Thanks you both,

it's working fine now.

Sorry for not using the industrial mod :)

Greetings steinio
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

Spuds
Burner Inserter
Burner Inserter
Posts: 7
Joined: Wed Apr 13, 2016 1:39 am
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by Spuds » Wed Apr 13, 2016 2:19 am

Fatmice wrote: Ah I see. It was assumed that if you were playing with the railway mod that you would also be playing with Yuoki's main mod.

This will fix the case where they don't have the main mod to apply the right prototypes.

Code: Select all

if data.raw.item["y-slag"] ~= nil then -- should be Yuoki-Industries installed	
	require ("prototypes._tiles_slag") 	
else
	require ("prototypes._tiles_slag_2") 	
end
yeah, was a bit confusing saying it's a standalone mod, yet had an unlisted dependancy. Thanks for the clean if block to work with and without the other mod

Fatmice
Filter Inserter
Filter Inserter
Posts: 808
Joined: Thu Dec 04, 2014 11:03 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by Fatmice » Wed Apr 13, 2016 8:14 am

Spuds wrote:
Fatmice wrote:
yeah, was a bit confusing saying it's a standalone mod, yet had an unlisted dependancy. Thanks for the clean if block to work with and without the other mod
The rail mod was not an independent mod initially. Yuoki decided to split it off the main Yuoki mod only recently due to filesize. The y-slag recipe was originally from Yuoki mod only, thus the error.
Maintainer and developer of Atomic Power. See here for more information.
Current release: 0.6.6 - Requires 0.14.x
Example build - Requires 0.14.x

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2173
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: Yuoki Industries - Railways Core 0.0.7 (f0.12.22+)

Post by steinio » Fri Apr 29, 2016 7:03 pm

Hello,

how does the pump to tank wagon work?
I placed this thingy above the fatmice 'i can drink 4k liter' wagon (horizontal station) like in Rail Tanker but it only destroys 2k oil.

Greetings steinio
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

Post Reply

Return to “Yuoki Industries”

Who is online

Users browsing this forum: No registered users