[1.1.34] Smart Belt Dragging placing belts in the wrong location and or direction

Post your bugs and problems so we can fix them.
Post Reply
User avatar
jan1i3
Inserter
Inserter
Posts: 42
Joined: Sun Dec 09, 2018 1:36 pm
Contact:

[1.1.34] Smart Belt Dragging placing belts in the wrong location and or direction

Post by jan1i3 »

There are several cases where smart belt dragging ends up placing belts on the incorrect row or column or the belts are facing the opposite direction. These are just 3 cases i managed to reproduce.

Syntax:
starting with belts facing north (^)
. = start
^ > v < = move cursor one tile in that direction
r = press r
() = just to make it look better/clearer what the problem is
Case 1
. ^ > v r v < < (<) r

Expected:
The last belts face north (^) (and don't rotate the last belt that is facing east (>) to so it forms a corner)
Case 2
. ^ r ^ v v >

Expected:
The last belt is placed next to the top belt (as that is the last placed belt), faces east (>) and rotates the top belt to also face east (>)
Case 3
. v r v >

Expected:
The last belt is placed next to the bottom belt (and faces west (<))
Note
I was specifically trying to look for ways to reproduce any kind of issues with smart belt dragging, which means the first two cases are actually cases i just came accross while testing, not in the real world, however since i found them they might help find issues that are causing problems in real world cases.

The third case however is definitely something that happens in the real world.

And lastly there are more issues that i came accross but wasn't able to reproduce. I believe it can also be timing related.
Attachments
factorio-current.log
(5.25 KiB) Downloaded 259 times
Also known as JanSharp. jan1i3 was/is my old name ;)

Post Reply

Return to “Bug Reports”