[0.18.36] Crash on startup, mod: EvolutionThroughResearch

Post your bugs and problems so we can fix them.
Post Reply
User avatar
MEOWMI
Fast Inserter
Fast Inserter
Posts: 114
Joined: Wed May 22, 2019 12:21 pm
Contact:

[0.18.36] Crash on startup, mod: EvolutionThroughResearch

Post by MEOWMI »

Not entirely sure if this is worth reporting but the game made me think it might be. I'll report it to the mod author as well.

Description:
Hard crash in loading stage when running the mod EvolutionThroughResearch ( https://mods.factorio.com/mod/EvolutionThroughResearch ).

How to reproduce:
-Install and activate EvolutionThroughResearch
-Restart for crash
Attachments
factorio-current.log
(102.54 KiB) Downloaded 16 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 10970
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: Crash on startup, mod: EvolutionThroughResearch

Post by Rseding91 »

Can you post your mod-settings.dat file from the mods folder as well?
If you want to get ahold of me I'm almost always on Discord.

User avatar
MEOWMI
Fast Inserter
Fast Inserter
Posts: 114
Joined: Wed May 22, 2019 12:21 pm
Contact:

Re: [0.18.36] Crash on startup, mod: EvolutionThroughResearch

Post by MEOWMI »

Attached.

(Also to further clarify, the game loaded with other mods. Tried Pyanodon's mods.)

For what it's worth, the mod loads fine if I clear the settings file (which I'm ok with at the moment).
Attachments
mod-settings_0.txt
.dat is the intended extension
(16.8 KiB) Downloaded 3 times

CaveGrinder
Inserter
Inserter
Posts: 29
Joined: Fri Aug 24, 2018 7:42 pm
Contact:

Re: [0.18.36] Crash on startup, mod: EvolutionThroughResearch

Post by CaveGrinder »

tried looking also from my side if my mod is doing something funny - but not really.
the only additional info i have is: with the given settings file, it is reproducible, both in 0.18.36 and 0.18.40
(steps performed: clear mods folder, download mod-settings_0.txt, rename to mod-settings.dat. add EvolutionThroughResearch_0.1.3.zip from the portal. start game)
callstack / log was the same as in attachment.
globalmodsettings.cpp (228): GlobalModSettingsHelper::save
ERROR: SymGetLineFromAddr64, GetLastError: 487
my mod adds a startup int-setting "evolution-through-research-frequency". Your settings file doesn't contain it yet - and then there is a crash on start if starting the game with that new setting.

Post Reply

Return to “Bug Reports”

Who is online

Users browsing this forum: arl85, boskid