[0.18.0] Crash to Desktop (save process stalled with non-blocking save feature)

Post your bugs and problems so we can fix them.
Post Reply
triffid_hunter
Inserter
Inserter
Posts: 30
Joined: Wed Dec 14, 2016 7:33 am
Contact:

[0.18.0] Crash to Desktop (save process stalled with non-blocking save feature)

Post by triffid_hunter »

Hi Wube team,

Just had an interesting and rare occurrence - factorio crashed!

I think this is my first crash since I bought the game circa 0.14, so you're doing an excellent job regarding stability!

I was poking around in single player with a few minor mods (LTN, Whistle Stop, Mining Drones, Squeakthrough, Beautiful Rail Bridges, Lighted power poles, Noxys waterfill, couple others perhaps - see the attached saves).

It tried to autosave as it has done successfully many many times (including in this session and on this map), but this specific time the dialog remained visible for several minutes with the progress bar at 100%.

I've no idea why it stalled this time, I had 8G of RAM available (from 16G total), and 35G free on the disk where I have my factorio saves.

The game kept running for a while (I have non-blocking save enabled) then crashed.

There's nothing interesting in the log, but I've attached it anyway since I know you've plenty of reason to not believe folks when they say there's nothing interesting in there.

Nothing interesting in dmesg either, last message there is from several hours ago.

I've also attached the save file it was *trying* to write, as well as the previous autosave which wrote successfully. They're time-stamped 5 minutes apart.

My guess is that some unknown and unlogged issue caused the save process to stall, then (as a result of non-blocking save) it tried to autosave *again*, and barfed on the previous autosave process still running.

If that's an accurate assessment, the main problem is that autosave stalled somehow.

Suggestion: if non-blocking autosave stalls, perhaps detect this and at least offer to foreground-save before dying?

System specifics:

Linux Mint 18.3 (Sylvia) (essentially Ubuntu xenial), kernel 4.15.0-64-generic #73~16.04.1-Ubuntu
AMD 1500X Ryzen 3 CPU
nVidia GTX1050Ti, 396.54.09 driver
16GB DDR4-2400 RAM (12G free after factorio crashed, ~8G free while the autosave was stalling with each factorio process taking ~2G)
240G SSD (35G free) + 1TB spinning rust (not used for factorio)

PS: I love the non-blocking save feature, it's a truly genius move to offload game state snapshotting to the kernel's CoW fork mechanism! :D
Attachments
_autosave3.zip
This is the second-to-last save in the same session and map, which had zero issues.
(8.15 MiB) Downloaded 9 times
_autosave1.tmp.zip
This is the latest save, I guess it was in the process of writing it when it crashed. unzip says it's corrupt or incomplete.
(8.13 MiB) Downloaded 6 times
factorio-current.log
log
(59.74 KiB) Downloaded 19 times

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 978
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.18.0] Crash to Desktop (save process stalled with non-blocking save feature)

Post by TruePikachu »

Code: Select all

41635.350 Info AppManager.cpp:268: Saving to _autosave1 (non-blocking).
41635.591 Info AsyncScenarioSaver.cpp:144: Saving process PID: 27878
41636.135 [27878] Info BlueprintShelf.cpp:691: Saving blueprint storage.
[NB: EOF]
Is there a core dump available?

movax20h
Fast Inserter
Fast Inserter
Posts: 109
Joined: Fri Mar 08, 2019 7:07 pm
Contact:

Re: [0.18.0] Crash to Desktop (save process stalled with non-blocking save feature)

Post by movax20h »

I can't reproduce a crash with no mods. non-blocking autosaving works flawlessly for me. Could you share your mods? As a single zip with all required mods.

Could you reproduce it in any way, even only just sometimes?

Post Reply

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users